summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/libssh2/APKBUILD6
-rw-r--r--system/libssh2/test-sshd.patch33
2 files changed, 37 insertions, 2 deletions
diff --git a/system/libssh2/APKBUILD b/system/libssh2/APKBUILD
index 913934a46..401fa2cf0 100644
--- a/system/libssh2/APKBUILD
+++ b/system/libssh2/APKBUILD
@@ -10,7 +10,8 @@ license="BSD-3-Clause"
checkdepends="openssh-server"
makedepends="openssl-dev zlib-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.libssh2.org/download/libssh2-$pkgver.tar.gz"
+source="https://www.libssh2.org/download/libssh2-$pkgver.tar.gz
+ test-sshd.patch"
build() {
./configure \
@@ -33,4 +34,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="41a3ebcf84e32eab69b7411ffb0a3b6e6db71491c968602b17392cfe3490ef00239726ec28acb3d25bf0ed62700db7f4d0bb5a9175618f413865f40badca6e17 libssh2-1.9.0.tar.gz"
+sha512sums="41a3ebcf84e32eab69b7411ffb0a3b6e6db71491c968602b17392cfe3490ef00239726ec28acb3d25bf0ed62700db7f4d0bb5a9175618f413865f40badca6e17 libssh2-1.9.0.tar.gz
+eef3c43184d53a3c655915ad61d182a88d9cced75ba8f8dde73ccf771ff4aeaa0f26e95aeb53601d7c47d96a2421c98678e9baf497f3883faa4427a091eea62c test-sshd.patch"
diff --git a/system/libssh2/test-sshd.patch b/system/libssh2/test-sshd.patch
new file mode 100644
index 000000000..6cc6d711e
--- /dev/null
+++ b/system/libssh2/test-sshd.patch
@@ -0,0 +1,33 @@
+--- libssh2-1.9.0/tests/ssh2.sh 2010-10-25 17:15:14.000000000 -0500
++++ libssh2-1.9.0/tests/ssh2.sh 2019-09-11 18:52:25.932354801 -0500
+@@ -28,6 +28,7 @@ $SSHD -f /dev/null -h "$srcdir"/etc/host
+ -o 'UsePrivilegeSeparation no' \
+ -o 'StrictModes no' \
+ -D \
++ -e \
+ $libssh2_sshd_params &
+ sshdpid=$!
+
+--- libssh2-1.9.0/tests/ssh2.c 2019-03-26 08:08:54.000000000 -0500
++++ libssh2-1.9.0/tests/ssh2.c 2019-09-11 19:38:03.782403778 -0500
+@@ -143,20 +143,6 @@ int main(int argc, char *argv[])
+ */
+ libssh2_channel_setenv(channel, "FOO", "bar");
+
+- /* Request a terminal with 'vanilla' terminal emulation
+- * See /etc/termcap for more options
+- */
+- if(libssh2_channel_request_pty(channel, "vanilla")) {
+- fprintf(stderr, "Failed requesting pty\n");
+- goto skip_shell;
+- }
+-
+- /* Open a SHELL on that pty */
+- if(libssh2_channel_shell(channel)) {
+- fprintf(stderr, "Unable to request shell on allocated pty\n");
+- goto shutdown;
+- }
+-
+ ec = 0;
+
+ skip_shell: