summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/geocode-glib/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/geocode-glib/APKBUILD b/user/geocode-glib/APKBUILD
new file mode 100644
index 000000000..b39728681
--- /dev/null
+++ b/user/geocode-glib/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=geocode-glib
+pkgver=3.26.4
+pkgrel=0
+pkgdesc="GLib-based library for geocoding"
+url="https://www.gnome.org"
+arch="all"
+options="!check" # broken testsuite
+license="LGPL-2.0+ AND BSD-3-Clause AND ODbL-1.0"
+depends=""
+makedepends="meson ninja glib-dev gobject-introspection-dev gtk-doc json-glib-dev libsoup3-dev vala-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/geocode-glib/3.26/geocode-glib-$pkgver.tar.xz"
+
+build() {
+ meson setup \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ --wrap-mode=nofallback \
+ -Dsoup2=false \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C output
+}
+
+sha512sums="998c2f02a8d3d34a8b6a4b031da2e7c28df27014bcf58f3374fbc0c829fff6257c2622fd9bf331e05b85fbc761c64554fb77ce2d986e0f8b59b17aa486f9f609 geocode-glib-3.26.4.tar.xz"