summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/musl-locales/APKBUILD (renamed from user/musl-locales/APKBUILD)14
1 files changed, 9 insertions, 5 deletions
diff --git a/user/musl-locales/APKBUILD b/system/musl-locales/APKBUILD
index 9bbf0c49b..f537430d0 100644
--- a/user/musl-locales/APKBUILD
+++ b/system/musl-locales/APKBUILD
@@ -1,18 +1,17 @@
# Contributor: Alyx <alyx@leuhta.com>
# Maintainer: Alyx <alyx@leuhta.com>
pkgname=musl-locales
-pkgver=0.20190626
+pkgver=0.20200319
pkgrel=0
pkgdesc="Locale program for musl"
url="https://gitlab.com/rilian-la-te/musl-locales"
arch="all"
options="!check" # No test suite.
-license="MIT"
+license="LGPL-3.0-only"
depends=""
makedepends="cmake make gettext-tiny-dev"
subpackages="$pkgname-lang"
-source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname"
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz"
build() {
cmake \
@@ -25,4 +24,9 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f65381b6eec64e69e649dacd3a3f75e74d9236164a1277bd2493afb3cb469049bee026d590a7207413b4d92675f877d1d8d3b16c58840a6e15a81638a2f731f2 musl-locales-0.20190626.tar.gz"
+lang() {
+ license="MIT"
+ default_lang
+}
+
+sha512sums="921c5a4dfb45ac12b1eaf284986237bd95420a58705702d0541a46fa2480ff97cd3ac929661108c67304e4e1bfe1efed7bf8edd535b7260d7eb69d72aa294e45 musl-locales-0.20200319.tar.xz"