summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/xbindkeys/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/xbindkeys/APKBUILD b/user/xbindkeys/APKBUILD
new file mode 100644
index 000000000..87a686f78
--- /dev/null
+++ b/user/xbindkeys/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=xbindkeys
+pkgver=1.8.6
+pkgrel=0
+pkgdesc="a program that allows you to launch shell commands with your keyboard or mouse"
+url="https://www.nongnu.org/xbindkeys/xbindkeys.html"
+arch="all"
+license="GPL-2.0+"
+depends=""
+makedepends="libx11-dev"
+subpackages="$pkgname-dbg $pkgname-doc"
+source="https://www.nongnu.org/xbindkeys/xbindkeys-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-guile
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="3c77541eae9f87d2020c2272984c221094276dae2a8690c5cec9fe1b23c0139229b8f56876170da70684aeaa128642349b6835c375d473186cbf8123517173ba xbindkeys-1.8.6.tar.gz"