summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/imagemagick/APKBUILD2
-rw-r--r--user/opal-utils/APKBUILD44
-rw-r--r--user/opal-utils/musl.patch36
-rw-r--r--user/opal-utils/opal-prd.patch8
-rw-r--r--user/openjdk7/APKBUILD2
-rw-r--r--user/py3-psutil/APKBUILD30
-rw-r--r--user/py3-psutil/utmpx.patch87
7 files changed, 207 insertions, 2 deletions
diff --git a/user/imagemagick/APKBUILD b/user/imagemagick/APKBUILD
index c527b6c0f..4fccc54cd 100644
--- a/user/imagemagick/APKBUILD
+++ b/user/imagemagick/APKBUILD
@@ -16,7 +16,7 @@ makedepends="zlib-dev libpng-dev libjpeg-turbo-dev freetype-dev fontconfig-dev
libxml2-dev librsvg-dev libraw-dev"
checkdepends="freetype fontconfig lcms2 graphviz"
subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx $pkgname-libs"
-source="http://www.imagemagick.org/download/releases/ImageMagick-$_pkgver.tar.xz"
+source="https://distfiles.adelielinux.org/source/ImageMagick-$_pkgver.tar.xz"
builddir="$srcdir/ImageMagick-${_pkgver}"
build() {
diff --git a/user/opal-utils/APKBUILD b/user/opal-utils/APKBUILD
new file mode 100644
index 000000000..d6eddcd70
--- /dev/null
+++ b/user/opal-utils/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=opal-utils
+pkgver=6.3.1
+pkgrel=0
+pkgdesc="Tools for IBM FSP and OpenPOWER systems"
+url="https://lists.ozlabs.org/listinfo/skiboot"
+arch="ppc64"
+license="Apache-2.0"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="skiboot-$pkgver.tar.gz::https://github.com/open-power/skiboot/archive/v$pkgver.tar.gz
+ musl.patch
+ opal-prd.patch
+ "
+builddir="$srcdir/skiboot-$pkgver"
+
+_tools="opal-prd gard"
+
+build() {
+ for _tool in $_tools; do
+ cd "$builddir"/external/$_tool
+ make
+ done
+}
+
+check() {
+ for _tool in $_tools; do
+ cd "$builddir"/external/$_tool
+ make test
+ done
+}
+
+package() {
+ for _tool in $_tools; do
+ cd "$builddir"/external/$_tool
+ make DESTDIR="$pkgdir" prefix="/usr" install
+ done
+}
+
+sha512sums="ad2156d864cedcf3d19e8ff094d12059703aaf9a5ea8403e230ecf33d331dae45e0f28a89c65ad05f94605e493bc8d42df92698847600810d5609bc56ade24b8 skiboot-6.3.1.tar.gz
+e7480f16b6eb41fd65b40ea1f20031118030f24681b7b8afcfdebb8cde7625e45902683cfb5fe0af3259060fb1b92b9c2f5d62354de356e7706a7f08ad9f772e musl.patch
+944dd564a2c846a675544c8ecdb2fa4714235f3fd974e135a71220379640f94883811399fe03d2d697fcb49e219504af264af0f201a6a7b37029687dea6a28cf opal-prd.patch"
diff --git a/user/opal-utils/musl.patch b/user/opal-utils/musl.patch
new file mode 100644
index 000000000..5835935e8
--- /dev/null
+++ b/user/opal-utils/musl.patch
@@ -0,0 +1,36 @@
+--- skiboot-6.3.1/ccan/endian/endian.h.old 2019-05-10 06:50:45.000000000 +0000
++++ skiboot-6.3.1/ccan/endian/endian.h 2019-06-04 07:57:14.416435679 +0000
+@@ -112,9 +112,9 @@
+ #error "Unknown endian"
+ #elif HAVE_LITTLE_ENDIAN && HAVE_BIG_ENDIAN
+ #error "Can't compile for both big and little endian."
+-#elif HAVE_LITTLE_ENDIAN
++#elif HAVE_LITTLE_ENDIAN && !defined(__BYTE_ORDER)
+ #define __BYTE_ORDER __LITTLE_ENDIAN
+-#elif HAVE_BIG_ENDIAN
++#elif HAVE_BIG_ENDIAN && !defined(__BYTE_ORDER)
+ #define __BYTE_ORDER __BIG_ENDIAN
+ #endif
+
+--- skiboot-6.3.1/include/inttypes.h.old 2019-05-10 06:50:45.000000000 +0000
++++ skiboot-6.3.1/include/inttypes.h 2019-06-04 08:07:42.108161539 +0000
+@@ -25,15 +25,15 @@
+
+ #include <stdint.h>
+
+-#ifndef __WORDSIZE
+-/* If we don't have __WORDSIZE it means we're *certainly* building skiboot
++#ifndef __LONG_WIDTH__
++/* If we don't have __LONG_WIDTH__ it means we're *certainly* building skiboot
+ * which will *ALWAYS* have a word size of 32bits.
+ * (unless someone goes and ports skiboot to something that isn't powerpc)
+ */
+-#define __WORDSIZE 32
++#define __LONG_WIDTH__ 32
+ #endif
+
+-#if __WORDSIZE == 64
++#if __LONG_WIDTH__ == 64
+ #define PRIu64 "lu"
+ #define PRIx64 "lx"
+ #else
diff --git a/user/opal-utils/opal-prd.patch b/user/opal-utils/opal-prd.patch
new file mode 100644
index 000000000..29b38cd43
--- /dev/null
+++ b/user/opal-utils/opal-prd.patch
@@ -0,0 +1,8 @@
+--- skiboot-6.3.1/external/opal-prd/thunk.S.old 2019-05-10 06:50:45.000000000 +0000
++++ skiboot-6.3.1/external/opal-prd/thunk.S 2019-06-04 08:01:00.851806263 +0000
+@@ -1,4 +1,4 @@
+-#include <endian.h>
++#define __BYTE_ORDER __BIG_ENDIAN
+ #include <asm/unistd.h>
+
+ #ifndef __NR_switch_endian
diff --git a/user/openjdk7/APKBUILD b/user/openjdk7/APKBUILD
index 597031b43..de476ea21 100644
--- a/user/openjdk7/APKBUILD
+++ b/user/openjdk7/APKBUILD
@@ -57,7 +57,7 @@ if [ "$BOOTSTRAP" != "no" ]; then
makedepends="$makedepends java-gcj-compat"
BOOTSTRAP_JAVA_HOME=/usr/lib/jvm/java-1.5-gcj/
else
- makedepends="$makedepends $pkgname"
+ makedepends="$makedepends $pkgname fastjar"
BOOTSTRAP_JAVA_HOME="$INSTALL_BASE"
fi
diff --git a/user/py3-psutil/APKBUILD b/user/py3-psutil/APKBUILD
new file mode 100644
index 000000000..66d9da144
--- /dev/null
+++ b/user/py3-psutil/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-psutil
+_pkgname=${pkgname#py3-}
+pkgver=5.6.2
+pkgrel=0
+pkgdesc="Process and system utilities"
+url="https://pypi.org/project/psutil/"
+arch="all"
+options="!check" # Requires itself to be installed first
+license="BSD-3-Clause"
+depends="python3"
+makedepends="python3-dev utmps-dev"
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ utmpx.patch
+ "
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ LIBS="-lutmps -lskarnet" python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ff41428b43c59ad948b8b4e6824943258abb30dc76cd042bdf7fe72d5aceb9bcbd2a2038a6a43d2b4c36eccae9007ef78779fe0cb5ee3caa68da9b1ba687b66d psutil-5.6.2.tar.gz
+5b0eea07856afeb0eff3268dc78bd3daf3491022e8a08c422db3eaad1b5e0da71429fe9e2e4b23f3eabf9669e7e4fb5a187c96aedbfe994692bb3e5a98fe2fc2 utmpx.patch"
diff --git a/user/py3-psutil/utmpx.patch b/user/py3-psutil/utmpx.patch
new file mode 100644
index 000000000..e7881e8f2
--- /dev/null
+++ b/user/py3-psutil/utmpx.patch
@@ -0,0 +1,87 @@
+--- psutil-5.6.2/psutil/_psutil_linux.c.old 2019-04-11 21:10:12.000000000 +0000
++++ psutil-5.6.2/psutil/_psutil_linux.c 2019-06-14 20:19:26.804374285 +0000
+@@ -14,7 +14,7 @@
+ #include <stdlib.h>
+ #include <mntent.h>
+ #include <features.h>
+-#include <utmp.h>
++#include <utmpx.h>
+ #include <sched.h>
+ #include <linux/version.h>
+ #include <sys/syscall.h>
+@@ -454,7 +454,7 @@
+ */
+ static PyObject *
+ psutil_users(PyObject *self, PyObject *args) {
+- struct utmp *ut;
++ struct utmpx *utx;
+ PyObject *py_retlist = PyList_New(0);
+ PyObject *py_tuple = NULL;
+ PyObject *py_username = NULL;
+@@ -465,20 +465,20 @@
+ if (py_retlist == NULL)
+ return NULL;
+- setutent();
++ setutxent();
+- while (NULL != (ut = getutent())) {
++ while (NULL != (utx = getutxent())) {
+ py_tuple = NULL;
+ py_user_proc = NULL;
+- if (ut->ut_type == USER_PROCESS)
++ if (utx->ut_type == USER_PROCESS)
+ py_user_proc = Py_True;
+ else
+ py_user_proc = Py_False;
+- py_username = PyUnicode_DecodeFSDefault(ut->ut_user);
++ py_username = PyUnicode_DecodeFSDefault(utx->ut_user);
+ if (! py_username)
+ goto error;
+- py_tty = PyUnicode_DecodeFSDefault(ut->ut_line);
++ py_tty = PyUnicode_DecodeFSDefault(utx->ut_line);
+ if (! py_tty)
+ goto error;
+- py_hostname = PyUnicode_DecodeFSDefault(ut->ut_host);
++ py_hostname = PyUnicode_DecodeFSDefault(utx->ut_host);
+ if (! py_hostname)
+ goto error;
+ py_tuple = Py_BuildValue(
+@@ -486,9 +486,9 @@
+ py_username, // username
+ py_tty, // tty
+ py_hostname, // hostname
+- (float)ut->ut_tv.tv_sec, // tstamp
++ (float)utx->ut_tv.tv_sec, // tstamp
+ py_user_proc, // (bool) user process
+- ut->ut_pid // process id
++ utx->ut_pid // process id
+ );
+ if (! py_tuple)
+ goto error;
+@@ -499,7 +499,7 @@
+ Py_DECREF(py_hostname);
+ Py_DECREF(py_tuple);
+ }
+- endutent();
++ endutxent();
+ return py_retlist;
+
+ error:
+@@ -508,7 +508,7 @@
+ Py_XDECREF(py_hostname);
+ Py_XDECREF(py_tuple);
+ Py_DECREF(py_retlist);
+- endutent();
++ endutxent();
+ return NULL;
+ }
+
+--- psutil-5.6.2/setup.py.old 2019-04-11 21:10:12.000000000 +0000
++++ psutil-5.6.2/setup.py 2019-06-14 20:25:29.994927919 +0000
+@@ -227,6 +227,7 @@
+ ext = Extension(
+ 'psutil._psutil_linux',
+ sources=sources + ['psutil/_psutil_linux.c'],
++ libraries=['utmps', 'skarnet'],
+ define_macros=macros)
+
+ elif SUNOS: