summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/nmap/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/user/nmap/APKBUILD b/user/nmap/APKBUILD
index 3cf0b1db3..163e42745 100644
--- a/user/nmap/APKBUILD
+++ b/user/nmap/APKBUILD
@@ -14,7 +14,8 @@ subpackages="
$pkgname-scripts::noarch
$pkgname-nselibs::noarch
$pkgname-nping
- $pkgname-ncat"
+ $pkgname-ncat
+ netcat::noarch"
source="https://nmap.org/dist/$pkgname-$pkgver.tar.bz2"
prepare() {
@@ -23,7 +24,6 @@ prepare() {
}
build() {
- cd "$builddir"
# zenmap and ndiff require python 2
./configure \
--build=$CBUILD \
@@ -44,12 +44,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
@@ -84,4 +82,12 @@ nping() {
mv "$pkgdir"/usr/bin/nping "$subpkgdir"/usr/bin
}
+netcat() {
+ pkgdesc="Symlinks for netcat and nc to ncat"
+ depends="$pkgname-ncat"
+ mkdir -p "$subpkgdir"/usr/bin
+ ln -s ncat "$subpkgdir"/usr/bin/netcat
+ ln -s ncat "$subpkgdir"/usr/bin/nc
+}
+
sha512sums="084c148b022ff6550e269d976d0077f7932a10e2ef218236fe13aa3a70b4eb6506df03329868fc68cb3ce78e4360b200f5a7a491d3145028fed679ef1c9ecae5 nmap-7.70.tar.bz2"