summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/cogl/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/user/cogl/APKBUILD b/user/cogl/APKBUILD
index 2f1b161e3..7e0311e66 100644
--- a/user/cogl/APKBUILD
+++ b/user/cogl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=cogl
pkgver=1.22.8
-pkgrel=0
+pkgrel=1
pkgdesc="GObject-based GL/GLES abstraction library"
url="https://gnome.org"
arch="all"
@@ -10,7 +10,8 @@ options="!check" # broken testsuite, no logs/messages to determine why
license="MIT AND SGI-B-2.0 AND BSD-3-Clause AND Public-Domain AND LGPL-2.0+ AND Apache-2.0"
depends=""
makedepends="glib-dev libxcomposite-dev libxrandr-dev mesa-dev cairo-dev
- pango-dev vala gobject-introspection-dev gdk-pixbuf-dev"
+ pango-dev vala gobject-introspection-dev gdk-pixbuf-dev libglvnd-dev
+ wayland-dev wayland-protocols"
subpackages="$pkgname-dev $pkgname-lang"
source="https://download.gnome.org/sources/cogl/1.22/cogl-$pkgver.tar.xz"
@@ -23,7 +24,9 @@ build() {
--mandir=/usr/share/man \
--localstatedir=/var \
--enable-kms-egl-platform=yes \
- --enable-xlib-egl-platform=yes
+ --enable-xlib-egl-platform=yes \
+ --enable-wayland-egl-platform=yes \
+ --enable-wayland-egl-server=yes
make
}