summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/aspell-dict-de/APKBUILD23
-rw-r--r--user/aspell-dict-ga/APKBUILD9
-rw-r--r--user/aspell-dict-it/APKBUILD10
-rw-r--r--user/aspell-dict-lt/APKBUILD10
-rw-r--r--user/aspell-dict-ml/APKBUILD6
-rw-r--r--user/aspell-dict-pl/APKBUILD8
-rw-r--r--user/aspell-dict-ro/APKBUILD11
-rw-r--r--user/aspell-dict-sk/APKBUILD8
-rw-r--r--user/aspell-dict-tl/APKBUILD10
9 files changed, 50 insertions, 45 deletions
diff --git a/user/aspell-dict-de/APKBUILD b/user/aspell-dict-de/APKBUILD
index 90b8097a5..080984aa3 100644
--- a/user/aspell-dict-de/APKBUILD
+++ b/user/aspell-dict-de/APKBUILD
@@ -1,26 +1,31 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=aspell-dict-de
-pkgver=20030222.1
-_pkgver=${pkgver%.*}-${pkgver#*.}
+pkgver=20161207
pkgrel=0
pkgdesc="German dictionaries for aspell"
-url="http://aspell.net"
+url="http://j3e.de/ispell/igerman98/index.html"
arch="noarch"
options="!check" # no tests
license="GPL-2.0-only"
depends="aspell"
makedepends="debianutils-which"
-source="ftp://ftp.gnu.org/gnu/aspell/dict/de/aspell6-de-$_pkgver.tar.bz2"
-builddir="$srcdir/aspell6-de-$_pkgver"
+source="https://j3e.de/ispell/igerman98/dict/igerman98-${pkgver}.tar.bz2"
+builddir="$srcdir/igerman98-$pkgver"
+_langs="de_DE de_AT de_CH"
build() {
cd "$builddir"
- ./configure --vars DESTDIR="$pkgdir"
+ for i in $_langs; do
+ make aspell/${i}.rws
+ done
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ cd "$builddir"/aspell
+ mkdir -p "$pkgdir"/usr/share/aspell
+ for i in $_langs; do
+ install -m644 ${i}.alias ${i}.dat ${i}_affix.dat ${i}.multi ${i}.rws "$pkgdir"/usr/share/aspell
+ done
}
-sha512sums="2005b56938565b11b761ace31006c1accfd32d401685cc5676cc4d85406bedda81b1df062949359f1bd6972073d3713204d87c7f81d9535fa956cdf130dd8db6 aspell6-de-20030222-1.tar.bz2"
+sha512sums="62be84ac76fd2a0acc25439aa4c04339e54a1c7a2f619d76e0e01cfb53eeeca263c5cc335e315f9adeee9bab5cc392d4c473ca55cbed371c04c123d6fa2272aa igerman98-20161207.tar.bz2"
diff --git a/user/aspell-dict-ga/APKBUILD b/user/aspell-dict-ga/APKBUILD
index d845f8f46..7ade44261 100644
--- a/user/aspell-dict-ga/APKBUILD
+++ b/user/aspell-dict-ga/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=aspell-dict-ga
-pkgver=4.5.0
+pkgver=5.0.0
_pkgver=${pkgver%.*}-${pkgver#*.*.}
+_pkgver2=${pkgver%.*}
pkgrel=0
pkgdesc="Irish dictionaries for aspell"
-url="http://aspell.net"
+url="https://cadhan.com/gaelspell/"
arch="noarch"
options="!check" # no tests
license="GPL-2.0-only"
depends="aspell"
makedepends="debianutils-which"
-source="ftp://ftp.gnu.org/gnu/aspell/dict/ga/aspell5-ga-$_pkgver.tar.bz2"
+source="https://github.com/kscanne/gaelspell/releases/download/v$_pkgver2/aspell5-ga-$_pkgver.tar.bz2"
builddir="$srcdir/aspell5-ga-$_pkgver"
build() {
@@ -23,4 +24,4 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="e68003e08d75e172e6223c7011795f40a386776559c2f05e049de196f0d5dcbe570a5ec704e6543b519eba5c847054d30b19e462c7ee228eddac4d72ccd82db0 aspell5-ga-4.5-0.tar.bz2"
+sha512sums="15c4e3d85c1ad589300f7288af054d0574e849163816e5e5aec56d464a71fcd02eba129ed74ed7ec341bb19ad2578091c6701b36ac23cc5a7972026742e9bb57 aspell5-ga-5.0-0.tar.bz2"
diff --git a/user/aspell-dict-it/APKBUILD b/user/aspell-dict-it/APKBUILD
index 8657914d9..639d81c27 100644
--- a/user/aspell-dict-it/APKBUILD
+++ b/user/aspell-dict-it/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=aspell-dict-it
-pkgver=2.2.20050523.0
-_pkgver=${pkgver%.*.*}_${pkgver#*.*.}
-_pkgver=${_pkgver%.*}-${_pkgver#*.*_*.}
+pkgver=2.4.20070901.0
+_pkgver=${pkgver%.*.*}-${pkgver#*.*.}
+_pkgver=${_pkgver%.*}-${_pkgver#*.*-*.}
pkgrel=0
pkgdesc="Italian dictionaries for aspell"
url="http://aspell.net"
@@ -12,7 +12,7 @@ options="!check" # no tests
license="GPL-2.0-only"
depends="aspell"
makedepends="debianutils-which"
-source="ftp://ftp.gnu.org/gnu/aspell/dict/it/aspell6-it-$_pkgver.tar.bz2"
+source="https://downloads.sourceforge.net/linguistico/aspell6-it-$_pkgver.tar.bz2"
builddir="$srcdir/aspell6-it-$_pkgver"
build() {
@@ -24,4 +24,4 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="2a2ccdbb8bb52e8e08525a40f985c1a2987c00d5e9fd39f57b8dc8689f3503f63751efe9ae4bec45fc5efea64666cd64abbda3e437ad0819f15b5a96987cda5a aspell6-it-2.2_20050523-0.tar.bz2"
+sha512sums="6a5014880e51103e70d57a6b01e2d4bb5d51ae939f72ee9270b46891804203399c817dd73c3a0b91c004744a4e66a1a5b402d19be0a53db952152cdd3c1741e9 aspell6-it-2.4-20070901-0.tar.bz2"
diff --git a/user/aspell-dict-lt/APKBUILD b/user/aspell-dict-lt/APKBUILD
index 256ba69e1..8d31a0a30 100644
--- a/user/aspell-dict-lt/APKBUILD
+++ b/user/aspell-dict-lt/APKBUILD
@@ -1,18 +1,18 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=aspell-dict-lt
-pkgver=1.2.1.0
+pkgver=1.3
_pkgver=${pkgver%.*}-${pkgver#*.*.*.}
pkgrel=0
pkgdesc="Lithuanian dictionaries for aspell"
-url="http://aspell.net"
+url="https://launchpad.net/ispell-lt"
arch="noarch"
options="!check" # no tests
license="GPL-2.0-only"
depends="aspell"
makedepends="debianutils-which"
-source="ftp://ftp.gnu.org/gnu/aspell/dict/lt/aspell6-lt-$_pkgver.tar.bz2"
-builddir="$srcdir/aspell6-lt-$_pkgver"
+source="https://launchpad.net/ispell-lt/main/$pkgver/+download/aspell6-lt-$pkgver.tar.bz2"
+builddir="$srcdir/aspell6-lt-$pkgver"
build() {
cd "$builddir"
@@ -23,4 +23,4 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="d0dcea087a926f7defbab0180d9c04c93a53da8843fe374f7f59284362453ee6b198568066053ad591df4c194d7c3b0ac59331611698b78e2ded558aa5e7775b aspell6-lt-1.2.1-0.tar.bz2"
+sha512sums="dd19994f703b78b1296644699df18ddcdfdcb2441003ed9edee03ee18601ff2e15e9b4ed8fbf844d72b31f0c0313a6755c89b67c44eea35485c30f2abc3b206f aspell6-lt-1.3.tar.bz2"
diff --git a/user/aspell-dict-ml/APKBUILD b/user/aspell-dict-ml/APKBUILD
index 074c106af..8cd3ee5fc 100644
--- a/user/aspell-dict-ml/APKBUILD
+++ b/user/aspell-dict-ml/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=aspell-dict-ml
-pkgver=0.03.1
+pkgver=0.04.1
_pkgver=${pkgver%.*}-${pkgver#*.*.}
pkgrel=0
pkgdesc="Malayalam dictionaries for aspell"
@@ -11,7 +11,7 @@ options="!check" # no tests
license="GPL-2.0-only"
depends="aspell"
makedepends="debianutils-which"
-source="ftp://ftp.gnu.org/gnu/aspell/dict/ml/aspell6-ml-$_pkgver.tar.bz2"
+source="http://gnu.mirrors.pair.com/savannah/savannah/smc/Spellchecker/aspell6-ml-$_pkgver.tar.bz2"
builddir="$srcdir/aspell6-ml-$_pkgver"
build() {
@@ -23,4 +23,4 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="78c3bc296a70a3b205427bcffe29b69ae6f673ffd22fd8a1ef5550ae271ed1f7704fff15c4948dcee2d7722c5d4b279766ef74d0661969b13bbca4d3a53971da aspell6-ml-0.03-1.tar.bz2"
+sha512sums="a9b6e522f9a4b4d9034f9cd2e1546e0cdfc9bad9f9c7515c8144efb186fb164ab55d422e93da89f0cf7c2b7e6f7b5d439747cc8b7e211c5b09a3638573765563 aspell6-ml-0.04-1.tar.bz2"
diff --git a/user/aspell-dict-pl/APKBUILD b/user/aspell-dict-pl/APKBUILD
index f57d8bec4..b76f848e5 100644
--- a/user/aspell-dict-pl/APKBUILD
+++ b/user/aspell-dict-pl/APKBUILD
@@ -1,18 +1,18 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=aspell-dict-pl
-pkgver=6.0.20061121.0
+pkgver=6.0.20190103.0
_pkgver=${pkgver%.*.*}_${pkgver#*.*.}
_pkgver=${_pkgver%.*}-${pkgver#*.*.*.}
pkgrel=0
pkgdesc="Polish dictionaries for aspell"
-url="http://aspell.net"
+url="https://sjp.pl/slownik/ort/"
arch="noarch"
options="!check" # no tests
license="GPL-2.0-only"
depends="aspell"
makedepends="debianutils-which"
-source="ftp://ftp.gnu.org/gnu/aspell/dict/pl/aspell6-pl-$_pkgver.tar.bz2"
+source="https://sjp.pl/slownik/ort/sjp-aspell6-pl-$_pkgver.tar.bz2"
builddir="$srcdir/aspell6-pl-$_pkgver"
build() {
@@ -24,4 +24,4 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="424842fd3b4b2a00445590527a64393044e067b32ab973d07d90d5f35cd146ea7ae88c4f4b473a68759aa0d27a5c0fcd75b9ef0bb8ceb76e731eafd3aefc81c6 aspell6-pl-6.0_20061121-0.tar.bz2"
+sha512sums="213702540233ac564629ad4cbe92958cd55e90c3e6c25ff1f3a40624a08074f339b04624d6e8184d1c7b60eeecc19a98d4827c4bdcfeae2cd9ed17ec9fbf085d sjp-aspell6-pl-6.0_20190103-0.tar.bz2"
diff --git a/user/aspell-dict-ro/APKBUILD b/user/aspell-dict-ro/APKBUILD
index a116d1d50..f80bc913f 100644
--- a/user/aspell-dict-ro/APKBUILD
+++ b/user/aspell-dict-ro/APKBUILD
@@ -1,18 +1,17 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=aspell-dict-ro
-pkgver=3.3.2
-_pkgver=${pkgver%.*}-${pkgver#*.*.}
+pkgver=3.3.10
pkgrel=0
pkgdesc="Romanian dictionaries for aspell"
-url="http://aspell.net"
+url="https://sourceforge.net/projects/rospell/"
arch="noarch"
options="!check" # no tests
license="GPL-2.0-only"
depends="aspell"
makedepends="debianutils-which"
-source="ftp://ftp.gnu.org/gnu/aspell/dict/ro/aspell5-ro-$_pkgver.tar.bz2"
-builddir="$srcdir/aspell5-ro-$_pkgver"
+source="https://download.sourceforge.net/rospell/aspell5-ro-$pkgver.tar.bz2"
+builddir="$srcdir/aspell5-ro-$pkgver"
build() {
cd "$builddir"
@@ -23,4 +22,4 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="0027334b6201e24b038d78d5b01b8495a661dc41df44b099b6c27156d11f33c26db1dd7bc9dbf45263695820b20da3891da58a30584f5e285579dec199b5acd3 aspell5-ro-3.3-2.tar.bz2"
+sha512sums="c535894d11ee168311a2cc0f799005639b21f3284a2a51db25d513d3e0494cf6d2fb7517bc79bc76f2d9ae89bb43c8bcbac7f451195ee22a7cce361aa09914ba aspell5-ro-3.3.10.tar.bz2"
diff --git a/user/aspell-dict-sk/APKBUILD b/user/aspell-dict-sk/APKBUILD
index df481fad4..ac036cc6e 100644
--- a/user/aspell-dict-sk/APKBUILD
+++ b/user/aspell-dict-sk/APKBUILD
@@ -1,17 +1,17 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=aspell-dict-sk
-pkgver=2.01.2
+pkgver=2.02.0
_pkgver=${pkgver%.*}-${pkgver#*.*.}
pkgrel=0
pkgdesc="Slovak dictionaries for aspell"
-url="http://aspell.net"
+url="http://www.sk-spell.sk.cx/aspell-sk"
arch="noarch"
options="!check" # no tests
license="GPL-2.0-only"
depends="aspell"
makedepends="debianutils-which"
-source="ftp://ftp.gnu.org/gnu/aspell/dict/sk/aspell6-sk-$_pkgver.tar.bz2"
+source="http://www.sk-spell.sk.cx/file_download/103/aspell6-sk-$_pkgver.tar.bz2"
builddir="$srcdir/aspell6-sk-$_pkgver"
build() {
@@ -23,4 +23,4 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="020de459d4ff9c6e0c88428d43c9feea346bf8fadb9fa1233e9e54471ee23f970524a9a47cc6a45d04d6857387c9d9d1ecc1af2062325298354ee6c2d9c314b4 aspell6-sk-2.01-2.tar.bz2"
+sha512sums="fcdf5c043168c887f93dfad5b9c6e07d9edd0c6194139e61bee2ba3928798792d8e8b446754bc55a67acc6d333034ebed9655cc3c15ad638f834b5a9efcc63cd aspell6-sk-2.02-0.tar.bz2"
diff --git a/user/aspell-dict-tl/APKBUILD b/user/aspell-dict-tl/APKBUILD
index 7146e8b7f..c108875fb 100644
--- a/user/aspell-dict-tl/APKBUILD
+++ b/user/aspell-dict-tl/APKBUILD
@@ -1,18 +1,18 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=aspell-dict-tl
-pkgver=0.02.1
+pkgver=0.4.0
_pkgver=${pkgver%.*}-${pkgver#*.*.}
pkgrel=0
pkgdesc="Tagalog dictionaries for aspell"
-url="http://aspell.net"
+url="" # no suitable website
arch="noarch"
options="!check" # no tests
license="GPL-2.0-only"
depends="aspell"
makedepends="debianutils-which"
-source="ftp://ftp.gnu.org/gnu/aspell/dict/tl/aspell5-tl-$_pkgver.tar.bz2"
-builddir="$srcdir/aspell5-tl-$_pkgver"
+source="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/tagalog-wordlist/aspell6-tl-$_pkgver.tar.bz2"
+builddir="$srcdir/aspell6-tl-$_pkgver"
build() {
cd "$builddir"
@@ -23,4 +23,4 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="2bff0f0191104312b8674ef65ee77a8e80225bc9bb6afe651aeb94a03db8781e8545b5b09f0143f557092c868f0873c17c55055b8cdd66f18a648ba2c805a6f0 aspell5-tl-0.02-1.tar.bz2"
+sha512sums="e9ad3e7e619ed19ffde923a07553c4930c60292a0e5592a68cf0e09d6f6d3b3b7ff74adb8f53e9255528c319c12ef442eff4e3b2ce169156d1664b5d565a7f5a aspell6-tl-0.4-0.tar.bz2"