summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--legacy/dmenu/APKBUILD (renamed from user/dmenu/APKBUILD)2
-rw-r--r--legacy/libxfont/APKBUILD (renamed from user/libxfont/APKBUILD)0
-rw-r--r--legacy/which/APKBUILD (renamed from user/which/APKBUILD)5
3 files changed, 2 insertions, 5 deletions
diff --git a/user/dmenu/APKBUILD b/legacy/dmenu/APKBUILD
index ec90c9934..36c844132 100644
--- a/user/dmenu/APKBUILD
+++ b/legacy/dmenu/APKBUILD
@@ -7,10 +7,10 @@ pkgrel=0
pkgdesc="Dynamic menu for X"
url="https://tools.suckless.org/dmenu/"
arch="all"
+options="!check" # This package has no testsuite
license="MIT OR X11"
depends=""
makedepends="libx11-dev libxinerama-dev libxft-dev"
-options="!check" # This package has no testsuite
subpackages="$pkgname-doc"
source="https://dl.suckless.org/tools/$pkgname-$pkgver.tar.gz"
diff --git a/user/libxfont/APKBUILD b/legacy/libxfont/APKBUILD
index c98112974..c98112974 100644
--- a/user/libxfont/APKBUILD
+++ b/legacy/libxfont/APKBUILD
diff --git a/user/which/APKBUILD b/legacy/which/APKBUILD
index ab0d0a5bc..f8360b7b7 100644
--- a/user/which/APKBUILD
+++ b/legacy/which/APKBUILD
@@ -9,11 +9,10 @@ arch="all"
license="GPL-2.0+ AND LGPL-2.0+ AND GPL-3.0+"
makedepends=""
subpackages="$pkgname-doc"
-source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
provider_priority=1
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -22,12 +21,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}