summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/bash-completion/APKBUILD69
-rw-r--r--user/py3-markdown/APKBUILD28
-rw-r--r--user/py3-pygments/APKBUILD41
-rw-r--r--user/tmux-bash-completion/APKBUILD23
4 files changed, 161 insertions, 0 deletions
diff --git a/user/bash-completion/APKBUILD b/user/bash-completion/APKBUILD
new file mode 100644
index 000000000..42575f687
--- /dev/null
+++ b/user/bash-completion/APKBUILD
@@ -0,0 +1,69 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=bash-completion
+pkgver=2.8
+pkgrel=0
+pkgdesc="Command-line tab-completion for bash"
+url="https://github.com/scop/bash-completion"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="bash"
+makedepends=""
+subpackages="$pkgname-doc"
+source="https://github.com/scop/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz"
+
+# Provided with util-linux and networkmanager:
+_conflicting="
+ cal
+ chsh
+ dmesg
+ eject
+ hd
+ hexdump
+ hwclock
+ ionice
+ look
+ ncal
+ newgrp
+ renice
+ rfkill
+ rtcwake
+ su
+ nmcli
+ umount
+ mount
+ "
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
+ install -m644 AUTHORS CHANGES CONTRIBUTING.md README.md \
+ "$pkgdir"/usr/share/doc/$pkgname/
+
+ cd "$pkgdir"/usr/share/bash-completion/completions
+ for c in $_conflicting; do
+ rm -f $c
+ done
+}
+
+sha512sums="d839ef5a98811a2aade7ebdc0bc84c84a41c74db384f89913b06f3c25add1ba22528ac25392b19d27280685d258c74dcdc11247cbaae5b8d82f2c0b546abc268 bash-completion-2.8.tar.xz"
diff --git a/user/py3-markdown/APKBUILD b/user/py3-markdown/APKBUILD
new file mode 100644
index 000000000..ef362e1f9
--- /dev/null
+++ b/user/py3-markdown/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=py3-markdown
+_pkgname=Markdown
+pkgver=3.0.1
+pkgrel=0
+pkgdesc="A Python implementation of Markdown"
+url="https://python-markdown.github.io/"
+arch="noarch"
+options="!check" # needs flake8
+license="BSD-3-Clause"
+depends="python3"
+makedepends="python3-dev"
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir"
+}
+
+sha512sums="c648c1b8ecb3c907ff2bd636ec6c08b4b629967fb916913f77db641f6d61b83d16929af2f15f5695c8cdb9614031606110e02a7e0bbb3aab0be38a8e285f12f1 Markdown-3.0.1.tar.gz"
diff --git a/user/py3-pygments/APKBUILD b/user/py3-pygments/APKBUILD
new file mode 100644
index 000000000..59055ed48
--- /dev/null
+++ b/user/py3-pygments/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: zlg <zlg+packages@zlg.space>
+pkgname=py3-pygments
+_pkgname=Pygments
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="A syntax highlighting package written in Python."
+url="http://pygments.org/"
+arch="noarch"
+options="!check" # needs nose, flake8
+license="BSD-2-Clause"
+depends="python3"
+makedepends="python3-dev"
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+# Reactivate once nose and flake8 are packaged
+check() {
+ cd "$builddir"
+ sed -i -e 's:python:python3:' Makefile
+ make test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+doc() {
+ cd "$builddir"
+ install -m 644 -D doc/pygmentize.1 "$pkgdir"/usr/share/man/man1/pygmentize.1
+}
+
+sha512sums="cc0a4f73e19fa6cbf46314de2e809460c807c631e39ba05cbe5edb5f40db1a687aafcd9715585a0ed45f791710eb6038305e273f282f8682df76f30e63710b29 Pygments-2.2.0.tar.gz"
diff --git a/user/tmux-bash-completion/APKBUILD b/user/tmux-bash-completion/APKBUILD
new file mode 100644
index 000000000..e34f15ea5
--- /dev/null
+++ b/user/tmux-bash-completion/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: zlg <zlg+adelie@zlg.space>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=tmux-bash-completion
+pkgver=1.0.0_git20170805
+_commit=847eda60c4664bfca833a086a3e2167957c26be0
+pkgrel=0
+pkgdesc="bash-completion files for tmux"
+url="https://github.com/imomaliev/tmux-bash-completion"
+arch="noarch"
+options="!check" # no tests
+license="GPL-2.0-only"
+depends="bash-completion tmux"
+makedepends=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/imomaliev/tmux-bash-completion/archive/$_commit.tar.gz"
+builddir="$srcdir/$pkgname-$_commit"
+
+package() {
+ cd "$builddir"
+ install -Dm644 ./completions/tmux "$pkgdir"/usr/share/bash-completion/completions/tmux
+}
+
+sha512sums="6c4c761aa152d1352a575c91e2c375d3f19ad01263b603b9e0cde4bdd95ce478c93bb55bfcd9fa5332cde12399e1e1e1c062e6be2ed7403b96e808275401effa tmux-bash-completion-1.0.0_git20170805.tar.gz"