summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/python3/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index e09001beb..ba29bea30 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -94,12 +94,9 @@ build() {
--with-system-ffi \
--with-threads
- # set thread stack size to 1MB so we don't segfault before we hit
+ # set thread stack size to 2MB so we don't segfault before we hit
# sys.getrecursionlimit()
- stacksize=0x100000;
- case "$CARCH" in
- ppc64) stacksize=0x200000;;
- esac
+ stacksize=0x200000;
make EXTRA_CFLAGS="$CFLAGS -DTHREAD_STACK_SIZE=$stacksize"
}