summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/openssh/APKBUILD6
-rw-r--r--system/openssh/CVE-2018-20685.patch33
-rw-r--r--system/ruby/APKBUILD4
-rw-r--r--user/cdrtools/APKBUILD5
-rw-r--r--user/haveged/APKBUILD51
-rw-r--r--user/haveged/fix-cpu-cache-size-detection.patch15
-rw-r--r--user/haveged/haveged.confd5
-rw-r--r--user/haveged/haveged.initd11
-rw-r--r--user/hermit/APKBUILD22
-rw-r--r--user/php7/APKBUILD5
-rw-r--r--user/pulseaudio/APKBUILD3
-rw-r--r--user/uwsgi/APKBUILD86
-rw-r--r--user/xorg-server/APKBUILD6
-rw-r--r--user/xorg-server/support-coffeelake.patch14
-rw-r--r--user/xterm/APKBUILD24
-rw-r--r--user/xterm/posix-ptmx.patch21
16 files changed, 297 insertions, 14 deletions
diff --git a/system/openssh/APKBUILD b/system/openssh/APKBUILD
index 015e59192..145fc5c86 100644
--- a/system/openssh/APKBUILD
+++ b/system/openssh/APKBUILD
@@ -4,7 +4,7 @@
pkgname=openssh
pkgver=7.9_p1
_myver=${pkgver%_*}${pkgver#*_}
-pkgrel=1
+pkgrel=2
pkgdesc="Port of OpenBSD's free SSH release"
url="http://www.openssh.org/portable.html"
arch="all"
@@ -26,6 +26,7 @@ subpackages="$pkgname-doc
source="http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/$pkgname-$_myver.tar.gz
bsd-compatible-realpath.patch
+ CVE-2018-20685.patch
disable-forwarding-by-default.patch
fix-utmpx.patch
openssh7.4-peaktput.patch
@@ -36,6 +37,8 @@ source="http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/$pkgname-$_myver.tar
sshd.confd
"
# secfixes:
+# 7.9_p1-r2:
+# - CVE-2018-20685
# 7.9_p1:
# - CVE-2018-15473
# 7.7_p1:
@@ -150,6 +153,7 @@ openrc() {
sha512sums="0412c9c429c9287f0794023951469c8e6ec833cdb55821bfa0300dd90d0879ff60484f620cffd93372641ab69bf0b032c2d700ccc680950892725fb631b7708e openssh-7.9p1.tar.gz
f2b8daa537ea3f32754a4485492cc6eb3f40133ed46c0a5a29a89e4bcf8583d82d891d94bf2e5eb1c916fa68ec094abf4e6cd641e9737a6c05053808012b3a73 bsd-compatible-realpath.patch
+b8907d3d6ebceeca15f6bc97551a7613c68df5c31e4e76d43b7c0bd9ad42dedcabc20a2cc5404b89f40850a4765b24892bde50eab1db55c96ad5cf23bb1f8d04 CVE-2018-20685.patch
8df35d72224cd255eb0685d2c707b24e5eb24f0fdd67ca6cc0f615bdbd3eeeea2d18674a6af0c6dab74c2d8247e2370d0b755a84c99f766a431bc50c40b557de disable-forwarding-by-default.patch
0c1e832cec420bc7b57558041d2288912a438db97050b87f6a57e94a2741a374cc5d141fe352968b0d1ba6accaff965794463fe9169d136678a8915a60d2f0b7 fix-utmpx.patch
398096a89aa104abeff31aa043ac406a6348e0fdd4d313b7888ee0b931d38fd71fc21bceee46145e88f03bc27e00890e068442faee2d33f86cfbc04d58ffa4b6 openssh7.4-peaktput.patch
diff --git a/system/openssh/CVE-2018-20685.patch b/system/openssh/CVE-2018-20685.patch
new file mode 100644
index 000000000..f2f1ecfc5
--- /dev/null
+++ b/system/openssh/CVE-2018-20685.patch
@@ -0,0 +1,33 @@
+From 6010c0303a422a9c5fa8860c061bf7105eb7f8b2 Mon Sep 17 00:00:00 2001
+From: "djm@openbsd.org" <djm@openbsd.org>
+Date: Fri, 16 Nov 2018 03:03:10 +0000
+Subject: [PATCH] upstream: disallow empty incoming filename or ones that refer
+ to the
+
+current directory; based on report/patch from Harry Sintonen
+
+OpenBSD-Commit-ID: f27651b30eaee2df49540ab68d030865c04f6de9
+---
+ scp.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/scp.c b/scp.c
+index 60682c687..4f3fdcd3d 100644
+--- a/scp.c
++++ b/scp.c
+@@ -1,4 +1,4 @@
+-/* $OpenBSD: scp.c,v 1.197 2018/06/01 04:31:48 dtucker Exp $ */
++/* $OpenBSD: scp.c,v 1.198 2018/11/16 03:03:10 djm Exp $ */
+ /*
+ * scp - secure remote copy. This is basically patched BSD rcp which
+ * uses ssh to do the data transfer (instead of using rcmd).
+@@ -1106,7 +1106,8 @@ sink(int argc, char **argv)
+ SCREWUP("size out of range");
+ size = (off_t)ull;
+
+- if ((strchr(cp, '/') != NULL) || (strcmp(cp, "..") == 0)) {
++ if (*cp == '\0' || strchr(cp, '/') != NULL ||
++ strcmp(cp, ".") == 0 || strcmp(cp, "..") == 0) {
+ run_err("error: unexpected filename: %s", cp);
+ exit(1);
+ }
diff --git a/system/ruby/APKBUILD b/system/ruby/APKBUILD
index 87ba80226..1ed293793 100644
--- a/system/ruby/APKBUILD
+++ b/system/ruby/APKBUILD
@@ -28,13 +28,13 @@
pkgname=ruby
pkgver=2.5.3
_abiver="${pkgver%.*}.0"
-pkgrel=0
+pkgrel=1
pkgdesc="An object-oriented language for quick and easy programming"
url="http://www.ruby-lang.org/"
arch="all"
license="Ruby AND BSD-2-Clause"
depends="ca-certificates"
-depends_dev="gmp-dev"
+depends_dev="ruby=$pkgver-r$pkgrel gmp-dev"
makedepends="$depends_dev zlib-dev openssl-dev db-dev libedit-dev
libffi-dev coreutils yaml-dev linux-headers autoconf"
install="$pkgname.post-upgrade"
diff --git a/user/cdrtools/APKBUILD b/user/cdrtools/APKBUILD
index c9e6c1d70..0145aa351 100644
--- a/user/cdrtools/APKBUILD
+++ b/user/cdrtools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=cdrtools
pkgver=3.01
-pkgrel=0
+pkgrel=1
pkgdesc="Highly portable CD/DVD/Blu-Ray command line recording software"
url="http://cdrecord.sourceforge.net/private/cdrecord.html"
arch="all"
@@ -26,6 +26,9 @@ check() {
package() {
cd "$builddir"
smake INS_BASE=/usr DESTDIR="$pkgdir" install
+
+ mv "$pkgdir"/usr/share/man/man3 "$pkgdir"/usr/share/man/man3sch
+ rename .3 .3sch "$pkgdir"/usr/share/man/man3sch/*.3
}
sha512sums="54f06496e47184e324fc9d8b1153d3c806ed43c3c57e2a8d79a79afe12aa5334e82fa500fe1b1bf49307ad7dfabe687f6e1ad914fc2f0c5c429d8e6a34c293eb cdrtools-3.01.tar.bz2"
diff --git a/user/haveged/APKBUILD b/user/haveged/APKBUILD
new file mode 100644
index 000000000..7a40a3fc4
--- /dev/null
+++ b/user/haveged/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Contributor: Danilo Godec <danilo.godec@agenda.si>
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=haveged
+pkgver=1.9.4
+pkgrel=1
+pkgdesc="Entropy harvesting daemon using CPU timings"
+url="http://www.issihosts.com/haveged/"
+arch="all"
+license="GPL-3.0+"
+subpackages="$pkgname-doc $pkgname-openrc"
+makedepends="linux-headers"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirka-h/haveged/archive/$pkgver.tar.gz
+ fix-cpu-cache-size-detection.patch
+ haveged.initd
+ haveged.confd"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+
+ rm "$pkgdir"/usr/lib/libhavege.la
+
+ install -Dm755 "$srcdir"/haveged.initd \
+ "$pkgdir"/etc/init.d/haveged
+ install -Dm644 "$srcdir"/haveged.confd \
+ "$pkgdir"/etc/conf.d/haveged
+}
+
+sha512sums="20017c7637779c0cfa414233bb67efb2976f92c08e4eb1b7ea41ccd483dad755629d8e05fb8560a2db811fc2ded7d05fa081ab10c59341cb4c206595a964641d haveged-1.9.4.tar.gz
+6279296b057f19daf25020ac14997268230af4b11510d6e5c4a86989c119d6b081d2501069af198772302d5cce1464514c749033a4928fb95671268825a84ba8 fix-cpu-cache-size-detection.patch
+5d1e4186580951d4e6e01193e9c8827ceddaf3c2e28a981fc9176cb446bed32b059304796a77d9db6fb761a21f8fd27dd3d31e06a0fb7a5985b4ea94978fcd64 haveged.initd
+57201472fc659aaab919562a00d474d3823d5becea62e8b13ef93eda05e1fd667721c968f224fcae871d13cfcd16d1924403d9181e0899fa214fa00bf4fefc75 haveged.confd"
diff --git a/user/haveged/fix-cpu-cache-size-detection.patch b/user/haveged/fix-cpu-cache-size-detection.patch
new file mode 100644
index 000000000..07da2b46d
--- /dev/null
+++ b/user/haveged/fix-cpu-cache-size-detection.patch
@@ -0,0 +1,15 @@
+Some ARM cpus does not report the cache size or say it is -1
+
+diff --git a/src/havegetune.c b/src/havegetune.c
+index f1a99f2..de39c53 100644
+--- a/src/havegetune.c
++++ b/src/havegetune.c
+@@ -795,6 +795,8 @@ static int vfs_configInfoCache(
+ ctype = vfs_configFile(pAnchor, path, vfs_configType);
+ strcpy(path+plen, "size");
+ size = vfs_configFile(pAnchor, path, vfs_configInt);
++ if (size == -1)
++ size = ctype == 'I' ? GENERIC_ICACHE : GENERIC_DCACHE;
+ cfg_cacheAdd(pAnchor, SRC_VFS_INDEX, pArgs[1], level, ctype, size);
+ }
+ }
diff --git a/user/haveged/haveged.confd b/user/haveged/haveged.confd
new file mode 100644
index 000000000..c4c1e0a3b
--- /dev/null
+++ b/user/haveged/haveged.confd
@@ -0,0 +1,5 @@
+# Config file for /etc/init.d/haveged
+
+# Any extra options you want to pass to haveged
+# on start-up should be put here.
+HAVEGED_OPTS="-w 1024"
diff --git a/user/haveged/haveged.initd b/user/haveged/haveged.initd
new file mode 100644
index 000000000..86660e9c3
--- /dev/null
+++ b/user/haveged/haveged.initd
@@ -0,0 +1,11 @@
+#!/sbin/openrc-run
+
+command="/usr/sbin/haveged"
+command_args="$HAVEGED_OPTS"
+command_background="yes"
+
+pidfile="/run/$RC_SVCNAME.pid"
+
+depend() {
+ need net
+}
diff --git a/user/hermit/APKBUILD b/user/hermit/APKBUILD
new file mode 100644
index 000000000..e2b1002d4
--- /dev/null
+++ b/user/hermit/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Luis Ressel <aranea@aixah.de>
+# Maintainer: Luis Ressel <aranea@aixah.de>
+pkgname=hermit
+pkgver=2.0
+pkgrel=0
+pkgdesc="A monospace font designed to be clear, pragmatic and very readable"
+url="https://pcaro.es/p/hermit/"
+arch="noarch"
+options="!check" # No testing fonts
+license="OFL-1.1"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="https://pcaro.es/d/otf-$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"
+
+package() {
+ cd "$builddir"
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/OTF/ *.otf
+}
+
+sha512sums="ee41f8cbcdedfff568cd47ab7730c462ddd67d6170c05d35eaf64a7f954a4bb72d6ac99a383749f7032d9cf7b407b7a5ef3270b4209692c1572beb9744a21d42 otf-hermit-2.0.tar.gz"
diff --git a/user/php7/APKBUILD b/user/php7/APKBUILD
index 89ab74709..9da2b1de2 100644
--- a/user/php7/APKBUILD
+++ b/user/php7/APKBUILD
@@ -26,7 +26,7 @@
pkgname=php7
_pkgname=php
pkgver=7.2.11
-pkgrel=2
+pkgrel=3
_apiver=20170718
pkgdesc="The PHP7 language runtime engine"
url="https://php.net/"
@@ -34,7 +34,8 @@ arch="all"
options="!checkroot"
license="PHP-3.01 AND Zend-2.0 AND Custom:TSRM AND LGPL-2.1+ AND MIT AND Beerware AND Public-Domain AND BSD-3-Clause AND Apache-1.0 AND PostgreSQL AND BSD-2-Clause AND Zlib AND BSD-4-Clause"
depends=""
-depends_dev="$pkgname=$pkgver-r$pkgrel autoconf pcre-dev"
+depends_dev="$pkgname=$pkgver-r$pkgrel autoconf icu-dev libedit-dev libxml2-dev
+ pcre-dev zlib-dev"
makedepends="autoconf
apache-httpd-dev
aspell-dev
diff --git a/user/pulseaudio/APKBUILD b/user/pulseaudio/APKBUILD
index 15d8dcca3..9e3f7a565 100644
--- a/user/pulseaudio/APKBUILD
+++ b/user/pulseaudio/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=pulseaudio
pkgver=12.2
-pkgrel=2
+pkgrel=3
pkgdesc="A featureful, general-purpose sound server"
url="https://www.freedesktop.org/wiki/Software/PulseAudio"
pkgusers="pulse"
@@ -78,6 +78,7 @@ libs() {
"$subpkgdir"/usr/lib/
mv "$pkgdir"/usr/lib/libpulse.so.0* \
"$pkgdir"/usr/lib/libpulse-simple.so.0* \
+ "$pkgdir"/usr/lib/libpulse-mainloop-*.so.0* \
"$subpkgdir"/usr/lib/
mv "$pkgdir"/etc/pulse/client.conf \
"$subpkgdir"/etc/pulse/
diff --git a/user/uwsgi/APKBUILD b/user/uwsgi/APKBUILD
new file mode 100644
index 000000000..1e10be30d
--- /dev/null
+++ b/user/uwsgi/APKBUILD
@@ -0,0 +1,86 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=uwsgi
+pkgver=2.0.17.1
+pkgrel=0
+pkgdesc="Web application server"
+url="https://projects.unbit.it/uwsgi"
+arch="all"
+options="!check" # Requires unpackaged `cppcheck`.
+license="GPL-2.0-only"
+depends=""
+makedepends="libxml2-dev openssl-dev zlib-dev
+ perl-dev php7-dev php7-embed python3-dev ruby-dev"
+subpackages=""
+# Keep psgi at the end for the CFLAGS hack.
+_plugins="asyncio cgi corerouter http php python rack psgi"
+for _plugin in $_plugins; do
+ subpackages="$subpackages $pkgname-$_plugin"
+done
+source="https://projects.unbit.it/downloads/uwsgi-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+
+ echo 'plugin_dir = /usr/lib/uwsgi/plugins' >> buildconf/core.ini
+ echo 'plugin_build_dir = .' >> buildconf/core.ini
+
+ python3 uwsgiconfig.py --build core
+
+ for _plugin in $_plugins; do
+ [ $_plugin != "psgi" ] || export CFLAGS="-D_GNU_SOURCE -include /usr/include/setjmp.h"
+ python3 uwsgiconfig.py --plugin plugins/$_plugin core
+ done
+}
+
+check() {
+ cd "$builddir"
+ python3 uwsgiconfig.py --check
+}
+
+package() {
+ cd "$builddir"
+ install -D -m755 "$builddir"/uwsgi "$pkgdir"/usr/bin/uwsgi
+}
+
+_plugpack() {
+ pkgdesc="$pkgdesc ($2 plugin)"
+ depends=""
+
+ install -D -m755 "$builddir"/$1_plugin.so \
+ "$subpkgdir"/usr/lib/uwsgi/plugins/$1_plugin.so
+}
+
+asyncio() {
+ _plugpack asyncio "Python asyncio"
+}
+
+cgi() {
+ _plugpack cgi "CGI"
+}
+
+corerouter() {
+ _plugpack corerouter "Core router"
+}
+
+http() {
+ _plugpack http "HTTP server"
+}
+
+php() {
+ _plugpack php "PHP"
+}
+
+psgi() {
+ _plugpack psgi "PSGI"
+}
+
+python() {
+ _plugpack python "Python 3"
+}
+
+rack() {
+ _plugpack rack "Ruby Rack"
+}
+
+sha512sums="10d357961fde3a3f5f8e77986cc647313f95a33243e24c2afc482fce21df68a8ae48f90e7b5b76d7edc3cf8fd474d99823d6d60ef7477349abc65a319222f11b uwsgi-2.0.17.1.tar.gz"
diff --git a/user/xorg-server/APKBUILD b/user/xorg-server/APKBUILD
index 181bbde15..e5f0041eb 100644
--- a/user/xorg-server/APKBUILD
+++ b/user/xorg-server/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=xorg-server
pkgver=1.20.3
-pkgrel=1
+pkgrel=2
pkgdesc="X.Org X11 server"
url="https://www.X.Org/"
arch="all"
@@ -27,6 +27,7 @@ makedepends="$depends_dev autoconf automake libtool util-macros
source="https://www.X.Org/releases/individual/xserver/$pkgname-$pkgver.tar.bz2
autoconfig-sis.patch
fix-musl-arm.patch
+ support-coffeelake.patch
"
# secfixes:
@@ -141,4 +142,5 @@ xwayland() {
sha512sums="ee44554f86df4297f54c5871fe7a18954eeef4338775a25f36d6577b279c4775f61128da71b86cfaeadcc080838d6749dede138d4db178866579da2056543fba xorg-server-1.20.3.tar.bz2
30a78f4278edd535c45ee3f80933427cb029a13abaa4b041f816515fdd8f64f00b9c6aef50d4eba2aaf0d4f333e730399864fd97fa18891273601c77a6637200 autoconfig-sis.patch
-b799e757a22a61ac283adbd7a8df1ad4eccce0bb6cac38a0c962ba8438bba3cf6637a65bb64859e7b32399fca672283a49960207e186c271ba574580de360d09 fix-musl-arm.patch"
+b799e757a22a61ac283adbd7a8df1ad4eccce0bb6cac38a0c962ba8438bba3cf6637a65bb64859e7b32399fca672283a49960207e186c271ba574580de360d09 fix-musl-arm.patch
+1deae020ffd7e3ea91d8d3d8118dbb80c5d08308d9a253deaa3afc42f93ff13d1a93d3aaca7acce5d45213dee9c072a15c3ed385432bc833f403e7c8472e9fd6 support-coffeelake.patch"
diff --git a/user/xorg-server/support-coffeelake.patch b/user/xorg-server/support-coffeelake.patch
new file mode 100644
index 000000000..99f12aada
--- /dev/null
+++ b/user/xorg-server/support-coffeelake.patch
@@ -0,0 +1,14 @@
+This PCI ID has been seen in the wild on the i7-9700K.
+
+diff --git a/hw/xfree86/dri2/pci_ids/i965_pci_ids.h b/hw/xfree86/dri2/pci_ids/i965_pci_ids.h
+index 82e4a549e..1ef1a0edf 100644
+--- a/hw/xfree86/dri2/pci_ids/i965_pci_ids.h
++++ b/hw/xfree86/dri2/pci_ids/i965_pci_ids.h
+@@ -174,6 +174,7 @@ CHIPSET(0x3EA4, cfl_gt1, "Intel(R) HD Graphics (Coffeelake 2x6 GT1)")
+ CHIPSET(0x3E91, cfl_gt2, "Intel(R) UHD Graphics 630 (Coffeelake 3x8 GT2)")
+ CHIPSET(0x3E92, cfl_gt2, "Intel(R) UHD Graphics 630 (Coffeelake 3x8 GT2)")
+ CHIPSET(0x3E96, cfl_gt2, "Intel(R) HD Graphics (Coffeelake 3x8 GT2)")
++CHIPSET(0x3E98, cfl_gt2, "Intel(R) UHD Graphics 630 (Coffeelake 3x8 GT2)")
+ CHIPSET(0x3E9A, cfl_gt2, "Intel(R) HD Graphics (Coffeelake 3x8 GT2)")
+ CHIPSET(0x3E9B, cfl_gt2, "Intel(R) UHD Graphics 630 (Coffeelake 3x8 GT2)")
+ CHIPSET(0x3E94, cfl_gt2, "Intel(R) HD Graphics (Coffeelake 3x8 GT2)")
diff --git a/user/xterm/APKBUILD b/user/xterm/APKBUILD
index 35177bf1a..ab8a22b7a 100644
--- a/user/xterm/APKBUILD
+++ b/user/xterm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=xterm
pkgver=341
-pkgrel=0
+pkgrel=1
pkgdesc="An X-based terminal emulator"
url="https://invisible-island.net/xterm/"
arch="all"
@@ -11,11 +11,13 @@ license="X11"
makedepends="libx11-dev libsm-dev libice-dev libxt-dev utmps-dev libxaw-dev
libxext-dev freetype-dev ncurses-dev pcre-dev"
subpackages="$pkgname-doc"
-source="ftp://ftp.invisible-island.net/xterm/xterm-$pkgver.tgz"
+source="ftp://ftp.invisible-island.net/xterm/xterm-$pkgver.tgz
+ posix-ptmx.patch
+ "
build() {
cd "$builddir"
- LIBS="-lutmps -lskarnet -ltinfow" ./configure \
+ LIBS="-ltinfow" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -23,7 +25,18 @@ build() {
--mandir=/usr/share/man \
--localstatedir=/var \
--with-pcre
- make
+ # This is NOT A TYPO!
+ #
+ # XTerm does not use ld(1) as a linker. It uses a shell script
+ # called 'plink.sh' which tries to Be Smart, but is actually
+ # Quite Dumb.
+ #
+ # It determines that the utmp symbols are in musl, and decides
+ # -lutmps really isn't necessary. However! There is some solace.
+ #
+ # -k is like -l, but is forced, even if it isn't "really needed".
+ # So we use -k for utmps.
+ make EXTRA_LOADFLAGS="-kutmps -lskarnet"
}
package() {
@@ -31,4 +44,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="336b8e8d3bfbc373ce1a0547571f705401142b54a8206050d2cdf961dfd99e01c9e78e10df443eb3278fb02116536cf55bc1501835978b9b390399614ab77494 xterm-341.tgz"
+sha512sums="336b8e8d3bfbc373ce1a0547571f705401142b54a8206050d2cdf961dfd99e01c9e78e10df443eb3278fb02116536cf55bc1501835978b9b390399614ab77494 xterm-341.tgz
+e29ef756243faa6f5ced3c74d6879b4fc8f9839501becae49af4f458d0f499bcda40a0eb66dada9cae8bf9789256daf3d1605ac1b5b4301654d8b5ac6eaca81d posix-ptmx.patch"
diff --git a/user/xterm/posix-ptmx.patch b/user/xterm/posix-ptmx.patch
new file mode 100644
index 000000000..351aba9ab
--- /dev/null
+++ b/user/xterm/posix-ptmx.patch
@@ -0,0 +1,21 @@
+--- xterm/main.c.old
++++ xterm/main.c
+@@ -2654,7 +2654,7 @@ get_pty(int *pty, char *from GCC_UNUSED)
+ close(opened_tty);
+ opened_tty = -1;
+ }
+-#elif defined(HAVE_POSIX_OPENPT) && defined(HAVE_PTSNAME) && defined(HAVE_GRANTPT_PTY_ISATTY)
++#elif defined(HAVE_POSIX_OPENPT) && defined(HAVE_PTSNAME)
+ if ((*pty = posix_openpt(O_RDWR)) >= 0) {
+ char *name = ptsname(*pty);
+ if (name != 0) {
+@@ -3735,7 +3735,7 @@ spawnXTerm(XtermWidget xw)
+ /*
+ * now in child process
+ */
+-#if defined(_POSIX_SOURCE) || defined(SVR4) || defined(__convex__) || defined(__SCO__) || defined(__QNX__)
++#if defined(_POSIX_VERSION) || defined(SVR4) || defined(__convex__) || defined(__SCO__) || defined(__QNX__)
+ int pgrp = setsid(); /* variable may not be used... */
+ #else
+ int pgrp = getpid();
+