summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/diskdev_cmds/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/user/diskdev_cmds/APKBUILD b/user/diskdev_cmds/APKBUILD
index afcfd2ae0..f3a60eb61 100644
--- a/user/diskdev_cmds/APKBUILD
+++ b/user/diskdev_cmds/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=diskdev_cmds
pkgver=332.14
-pkgrel=0
+pkgrel=1
pkgdesc="HFS+ utilities ported from OS X 10.8.4 (fsck/mkfs)"
url="https://opensource.apple.com/release/mac-os-x-10411ppc.html"
arch="all"
@@ -29,10 +29,15 @@ package() {
ln -s newfs_hfs "$pkgdir"/sbin/mkfs.hfs
ln -s newfs_hfs "$pkgdir"/sbin/mkfs.hfsplus
- install -D -m644 "$builddir"/fsck_hfs.tproj/fsck_hfs.8 "$pkgdir"/usr/share/man/man8/fsck_hfs.8
+ install -D -m644 "$builddir"/newfs_hfs.tproj/hfsbootdata.img \
+ "$pkgdir"/usr/share/hfsprogs/hfsbootdata
+
+ install -D -m644 "$builddir"/fsck_hfs.tproj/fsck_hfs.8 \
+ "$pkgdir"/usr/share/man/man8/fsck_hfs.8
ln -s fsck_hfs.8 "$pkgdir"/usr/share/man/man8/fsck.hfs.8
ln -s fsck_hfs.8 "$pkgdir"/usr/share/man/man8/fsck.hfsplus.8
- install -m644 "$builddir"/newfs_hfs.tproj/newfs_hfs.8 "$pkgdir"/usr/share/man/man8/newfs_hfs.8
+ install -m644 "$builddir"/newfs_hfs.tproj/newfs_hfs.8 \
+ "$pkgdir"/usr/share/man/man8/newfs_hfs.8
ln -s newfs_hfs.8 "$pkgdir"/usr/share/man/man8/mkfs.hfs.8
ln -s newfs_hfs.8 "$pkgdir"/usr/share/man/man8/mkfs.hfsplus.8
}