summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/wimlib/APKBUILD6
-rw-r--r--user/wimlib/header.patch14
2 files changed, 17 insertions, 3 deletions
diff --git a/user/wimlib/APKBUILD b/user/wimlib/APKBUILD
index 76e26f88e..e2340c0e8 100644
--- a/user/wimlib/APKBUILD
+++ b/user/wimlib/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: CyberLeo <cyberleo@cyberleo.net>
# Maintainer: CyberLeo <cyberleo@cyberleo.net>
pkgname=wimlib
-pkgver=1.13.4
+pkgver=1.14.4
pkgrel=0
pkgdesc="Windows Imaging (WIM) archive manipulation library and tools"
url="https://wimlib.net/"
arch="all"
license="(GPL-2.0 OR LGPL-2.1) AND CC0"
depends=""
-makedepends="libxml2-dev fuse-dev ntfs-3g ntfs-3g-dev"
+makedepends="fuse3-dev ntfs-3g ntfs-3g-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-libs"
source="https://wimlib.net/downloads/wimlib-$pkgver.tar.gz"
@@ -26,4 +26,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="480fe6fa6c6e8f1bf9c3960f5e1671f3266535b18dc72e9d7c4c05c7fb833d9b00db5ae9fb49154da6e71e536cae8b562cbf81ab5a124e2a79326927e2cf7344 wimlib-1.13.4.tar.gz"
+sha512sums="f3c25ee14fe849f452f004ce8137ef040410ea048555ae71180086f010858b6ed593c8881b805bac65f9ee878bf11661a7f17677c6c24e2c77149c35ee0cd853 wimlib-1.14.4.tar.gz"
diff --git a/user/wimlib/header.patch b/user/wimlib/header.patch
new file mode 100644
index 000000000..cf6c32bc0
--- /dev/null
+++ b/user/wimlib/header.patch
@@ -0,0 +1,14 @@
+The RENAME_* flags are only exposed by <linux/fs.h> on musl systems. I have
+not yet been able to triage whether this is something that should be fixed
+musl-side or if this is an issue for upstream.
+
+--- wimlib-1.14.4/src/mount_image.c.old 2023-07-22 18:55:59.000000000 -0500
++++ wimlib-1.14.4/src/mount_image.c 2024-12-11 18:46:19.018387960 -0600
+@@ -52,6 +52,7 @@
+ #include <sys/time.h>
+ #include <unistd.h>
+ #include <utime.h>
++#include <linux/fs.h>
+
+ #include "wimlib/blob_table.h"
+ #include "wimlib/dentry.h"