summaryrefslogtreecommitdiff
path: root/dev-libs/libfetch/libfetch-2.33.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libfetch/libfetch-2.33.ebuild')
-rw-r--r--dev-libs/libfetch/libfetch-2.33.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-libs/libfetch/libfetch-2.33.ebuild b/dev-libs/libfetch/libfetch-2.33.ebuild
index 4ca3a76b1..25f02eb46 100644
--- a/dev-libs/libfetch/libfetch-2.33.ebuild
+++ b/dev-libs/libfetch/libfetch-2.33.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# Copyright 2015-2016 Adélie Linux Team
+# Distributed under the terms of the NCSA License
EAPI=5
+inherit eutils
+
DESCRIPTION="High-level retrieval and download library for FTP and HTTP(S)"
HOMEPAGE="http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/net/libfetch/"
SRC_URI="http://distfiles.foxkit.us/source/${PN}/${P}.tar.bz2"
@@ -16,6 +17,13 @@ IUSE="+ipv6 +ssl"
DEPEND="ssl? ( dev-libs/openssl:0 )"
RDEPEND="${DEPEND}"
+EPATCH_SOURCE=( "${FILESDIR}"/${P}-remove-hardcoded-compiler.patch )
+
+src_prepare() {
+ epatch
+ epatch_user
+}
+
src_compile() {
use ssl || export FETCH_WITH_OPENSSL=false
use ipv6 || export FETCH_WITH_INET6=false