summaryrefslogtreecommitdiff
path: root/experimental/mono/python.patch
diff options
context:
space:
mode:
Diffstat (limited to 'experimental/mono/python.patch')
-rw-r--r--experimental/mono/python.patch131
1 files changed, 131 insertions, 0 deletions
diff --git a/experimental/mono/python.patch b/experimental/mono/python.patch
new file mode 100644
index 000000000..692ddb42d
--- /dev/null
+++ b/experimental/mono/python.patch
@@ -0,0 +1,131 @@
+diff -Nurd mono-6.6.0.161.old/mono/tests/Makefile.am mono-6.6.0.161/mono/tests/Makefile.am
+--- mono-6.6.0.161.old/mono/tests/Makefile.am 2020-07-02 16:22:55.467038705 +0000
++++ mono-6.6.0.161/mono/tests/Makefile.am 2020-07-02 16:31:31.637032664 +0000
+@@ -3142,7 +3142,7 @@
+ # Tests for the Mono lldb plugin
+ EXTRA_DIST += test_lldb.py test-lldb.cs
+ test-lldb: test-lldb.exe
+- python test_lldb.py $(JITTEST_PROG)
++ python3 test_lldb.py $(JITTEST_PROG)
+
+ noinst_LTLIBRARIES = libtest.la
+
+diff -Nurd mono-6.6.0.161.old/mono/tests/Makefile.in mono-6.6.0.161/mono/tests/Makefile.in
+--- mono-6.6.0.161.old/mono/tests/Makefile.in 2020-07-02 16:22:55.467038705 +0000
++++ mono-6.6.0.161/mono/tests/Makefile.in 2020-07-02 16:31:20.937032789 +0000
+@@ -3509,7 +3509,7 @@
+ coreclr-gcstress:
+ $(MAKE) -C $(mono_build_root)/acceptance-tests coreclr-gcstress
+ test-lldb: test-lldb.exe
+- python test_lldb.py $(JITTEST_PROG)
++ python3 test_lldb.py $(JITTEST_PROG)
+
+ test-internalsvisibleto: test-runner.exe $(INTERNALSVISIBLETO_TEST) $(INTERNALSVISIBLETO_TESTAOT) $(INTERNALSVISIBLETO_TESTAOT_LIBS)
+ $(TOOLS_RUNTIME) $(TEST_RUNNER) --testsuite-name $@ $(INTERNALSVISIBLETO_TEST)
+diff -Nurd mono-6.6.0.161.old/mono/tests/gc-descriptors/gen-descriptor-tests.py mono-6.6.0.161/mono/tests/gc-descriptors/gen-descriptor-tests.py
+--- mono-6.6.0.161.old/mono/tests/gc-descriptors/gen-descriptor-tests.py 2020-07-02 16:22:55.467038705 +0000
++++ mono-6.6.0.161/mono/tests/gc-descriptors/gen-descriptor-tests.py 2020-07-02 16:32:05.947032262 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ from __future__ import print_function
+ from optparse import OptionParser
+diff -Nurd mono-6.6.0.161.old/mono/utils/jemalloc/Makefile.in mono-6.6.0.161/mono/utils/jemalloc/Makefile.in
+--- mono-6.6.0.161.old/mono/utils/jemalloc/Makefile.in 2020-07-02 16:22:55.447038705 +0000
++++ mono-6.6.0.161/mono/utils/jemalloc/Makefile.in 2020-07-02 16:30:54.457033099 +0000
+@@ -632,11 +632,11 @@
+
+ define ValidateVersionTemplate
+ #$(eval REPOSITORY_$(2):=$(shell test -z $(3) && echo $(1) || echo "$(3)"))
+-#$(eval DIRECTORY_$(2):=$(shell python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-dir $(1)))
++#$(eval DIRECTORY_$(2):=$(shell python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-dir $(1)))
+ #$(eval DIRECTORY_$(2):=$(shell test -z $(DIRECTORY_$(2)) && echo $(1) || echo $(DIRECTORY_$(2))))
+-#$(eval MODULE_$(2):=$(shell python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-url $(1)))
+-#$(eval NEEDED_$(2)_VERSION:=$(shell python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-rev $(1)))
+-#$(eval $(2)_BRANCH_AND_REMOTE:=$(shell python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-remote-branch $(1)))
++#$(eval MODULE_$(2):=$(shell python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-url $(1)))
++#$(eval NEEDED_$(2)_VERSION:=$(shell python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-rev $(1)))
++#$(eval $(2)_BRANCH_AND_REMOTE:=$(shell python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-remote-branch $(1)))
+
+ #$(eval $(2)_VERSION:=$$$$(shell cd $($(2)_PATH) 2>/dev/null && git rev-parse HEAD ))
+
+@@ -728,19 +728,19 @@
+
+ __bump-version-%:
+ @if [ "$(REV)" = "" ]; then echo "Usage: make bump-version-$* REV=<ref>"; exit 1; fi
+- python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-rev $* $(REV)
++ python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-rev $* $(REV)
+ @if [ "$(COMMIT)" = "1" ]; then echo "[submodules] Bump $* to pick up $(REV)." | git commit -F - $(SUBMODULES_CONFIG_FILE); fi
+
+ __bump-branch-%:
+ @if [ "$(BRANCH)" = "" ]; then echo "Usage: make bump-branch-$* BRANCH=<branch> REMOTE_BRANCH=<remote branch>"; exit 1; fi
+ @if [ "$(REMOTE_BRANCH)" == "" ]; then echo "Usage: make bump-branch-$* BRANCH=<branch> REMOTE_BRANCH=<remote branch>"; exit 1; fi
+- python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-branch $* $(BRANCH)
+- python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-remote-branch $* $(REMOTE_BRANCH)
++ python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-branch $* $(BRANCH)
++ python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-remote-branch $* $(REMOTE_BRANCH)
+ @if [ "$(COMMIT)" = "1" ]; then echo "[submodules] Bump $* to switch to $(BRANCH) $(REMOTE BRANCH)." | git commit -F - $(SUBMODULES_CONFIG_FILE); fi
+
+ __bump-current-version-%:
+ REV=$(shell cd $(ACCEPTANCE_TESTS_PATH)/$* && git log -1 --pretty=format:%H); \
+- python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-rev $* $$REV; \
++ python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-rev $* $$REV; \
+ if [ "$(COMMIT)" = "1" ]; then echo "[submodules] Bump $* to pick up $$REV:" | git commit -F - $(SUBMODULES_CONFIG_FILE); fi
+
+ $(eval $(call ValidateVersionTemplate,jemalloc,JEMALLOC))
+diff -Nurd mono-6.6.0.161/mono/mini/Makefile.in mono-6.6.0.161.new/mono/mini/Makefile.in
+--- mono-6.6.0.161/mono/mini/Makefile.in 2019-12-10 07:57:17.000000000 +0000
++++ mono-6.6.0.161.new/mono/mini/Makefile.in 2020-07-02 16:37:51.297028220 +0000
+@@ -1287,7 +1287,7 @@
+ libmonoinclude_HEADERS = jit.h
+ CSFLAGS = -unsafe -nowarn:0219,0169,0414,0649,0618
+ GENMDESC_OPTS =
+-GENMDESC_PRG = python $(srcdir)/genmdesc.py $(target_define) $(srcdir)
++GENMDESC_PRG = python3 $(srcdir)/genmdesc.py $(target_define) $(srcdir)
+ LLVM_AOT_RUNTIME_OPTS = $(if $(LLVM),--llvm,)
+ @AMD64_FALSE@LLVM_AOT_COMPILER_OPTS =
+ @AMD64_TRUE@LLVM_AOT_COMPILER_OPTS = $(if $(LLVM),"=llvmllc=-mcpu=generic -mattr=+sse3",)
+diff -Nurd mono-6.8.0.123/acceptance-tests/Makefile.in mono-6.8.0.123.new/acceptance-tests/Makefile.in
+--- mono-6.8.0.123/acceptance-tests/Makefile.in 2020-05-11 18:05:40.000000000 +0000
++++ mono-6.8.0.123.new/acceptance-tests/Makefile.in 2020-07-04 18:56:11.214908746 +0000
+@@ -5743,11 +5743,11 @@
+
+ define ValidateVersionTemplate
+ #$(eval REPOSITORY_$(2):=$(shell test -z $(3) && echo $(1) || echo "$(3)"))
+-#$(eval DIRECTORY_$(2):=$(shell python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-dir $(1)))
++#$(eval DIRECTORY_$(2):=$(shell python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-dir $(1)))
+ #$(eval DIRECTORY_$(2):=$(shell test -z $(DIRECTORY_$(2)) && echo $(1) || echo $(DIRECTORY_$(2))))
+-#$(eval MODULE_$(2):=$(shell python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-url $(1)))
+-#$(eval NEEDED_$(2)_VERSION:=$(shell python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-rev $(1)))
+-#$(eval $(2)_BRANCH_AND_REMOTE:=$(shell python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-remote-branch $(1)))
++#$(eval MODULE_$(2):=$(shell python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-url $(1)))
++#$(eval NEEDED_$(2)_VERSION:=$(shell python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-rev $(1)))
++#$(eval $(2)_BRANCH_AND_REMOTE:=$(shell python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) get-remote-branch $(1)))
+
+ #$(eval $(2)_VERSION:=$$$$(shell cd $($(2)_PATH) 2>/dev/null && git rev-parse HEAD ))
+
+@@ -5839,19 +5839,19 @@
+
+ __bump-version-%:
+ @if [ "$(REV)" = "" ]; then echo "Usage: make bump-version-$* REV=<ref>"; exit 1; fi
+- python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-rev $* $(REV)
++ python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-rev $* $(REV)
+ @if [ "$(COMMIT)" = "1" ]; then echo "[submodules] Bump $* to pick up $(REV)." | git commit -F - $(SUBMODULES_CONFIG_FILE); fi
+
+ __bump-branch-%:
+ @if [ "$(BRANCH)" = "" ]; then echo "Usage: make bump-branch-$* BRANCH=<branch> REMOTE_BRANCH=<remote branch>"; exit 1; fi
+ @if [ "$(REMOTE_BRANCH)" == "" ]; then echo "Usage: make bump-branch-$* BRANCH=<branch> REMOTE_BRANCH=<remote branch>"; exit 1; fi
+- python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-branch $* $(BRANCH)
+- python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-remote-branch $* $(REMOTE_BRANCH)
++ python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-branch $* $(BRANCH)
++ python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-remote-branch $* $(REMOTE_BRANCH)
+ @if [ "$(COMMIT)" = "1" ]; then echo "[submodules] Bump $* to switch to $(BRANCH) $(REMOTE BRANCH)." | git commit -F - $(SUBMODULES_CONFIG_FILE); fi
+
+ __bump-current-version-%:
+ REV=$(shell cd $(ACCEPTANCE_TESTS_PATH)/$* && git log -1 --pretty=format:%H); \
+- python $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-rev $* $$REV; \
++ python3 $(SCRIPT) $(SUBMODULES_CONFIG_FILE) set-rev $* $$REV; \
+ if [ "$(COMMIT)" = "1" ]; then echo "[submodules] Bump $* to pick up $$REV:" | git commit -F - $(SUBMODULES_CONFIG_FILE); fi
+
+ $(eval $(call ValidateVersionTemplate,benchmarker,BENCHMARKER))