summaryrefslogtreecommitdiff
path: root/harmony/check/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'harmony/check/APKBUILD')
-rw-r--r--harmony/check/APKBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/harmony/check/APKBUILD b/harmony/check/APKBUILD
deleted file mode 100644
index 09af1b010..000000000
--- a/harmony/check/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=check
-pkgver=0.12.0
-pkgrel=1
-pkgdesc="A unit test framework for C"
-url="https://libcheck.github.io/check/"
-arch="all"
-license="LGPL2+"
-makedepends="pkgconfig"
-checkdepends="diffutils"
-subpackages="$pkgname-doc $pkgname-dev"
-source="https://github.com/libcheck/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir"/$pkgname-$pkgver
-
-build() {
- cd "$builddir"
- # NOTE: disabled forking due to hardened
- # https://github.com/libcheck/check/issues/138
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --disable-fork
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="403454d166ddd4e25f96d6c52028f4173f4a5ad4a249dd782e3a8d5db1ad0178956d74577cf0d4c963a5a7d09077a59042a74f74d6b528b7212e18ab5def1dd9 check-0.12.0.tar.gz"