summaryrefslogtreecommitdiff
path: root/harmony/libnih/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'harmony/libnih/APKBUILD')
-rw-r--r--harmony/libnih/APKBUILD57
1 files changed, 0 insertions, 57 deletions
diff --git a/harmony/libnih/APKBUILD b/harmony/libnih/APKBUILD
deleted file mode 100644
index f12895d65..000000000
--- a/harmony/libnih/APKBUILD
+++ /dev/null
@@ -1,57 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
-pkgname=libnih
-pkgver=1.0.3
-pkgrel=5
-pkgdesc="glib-like library for embedded use"
-url="http://launchpad.net/libnih"
-arch="all"
-license="LGPL"
-options="!checkroot"
-depends=
-depends_dev="dbus-dev expat-dev"
-makedepends="$depends_dev gettext-dev"
-checkdepends="dbus-x11 linux-headers"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://launchpad.net/libnih/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz
- musl-fix-signals.patch
- disable-broken-test.patch
- musl-enomem-message.patch
- parse-test-fix.patch
- "
-
-builddir="${srcdir}/${pkgname}-${pkgver}"
-prepare() {
- cd "$builddir"
- update_config_sub
- default_prepare
-}
-
-build() {
- cd "$builddir"
- LIBS="-lintl" ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --libdir=/lib \
- --sysconfdir=/etc \
- --localstatedir=/var
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="fce40d2445b28c27b8838631681ca3206a4f053b2dd4fc488fc9ef98bbd3d933e3d62b82cf346be2ef1677f6457f692cf5544cd915a6bb1e5c618f98ffa101b4 libnih-1.0.3.tar.gz
-77a979b3076c4e4229359f28c2e9d4fb66d799a66d60391ab6fd7e0dfe2a615b88330a979877b105293a95ed147546596eca174f52b75beca0457c49a017d040 musl-fix-signals.patch
-b5b77b1f18d7aa5d603a0d312b785c28200c38b7bbe5c384ee576c762bd9e3163682c29dd5410baf18c5c3734f0b719602caa1de096f1758d624d94b7753066a disable-broken-test.patch
-b800c99153ad66c9d7399bc7544a0237de0c7a4ddac129509f13eb1c31805fcac31c93bbf2945da557dfc900c9ec837ec0fded1c3f9887095dae52ff6fc046ec musl-enomem-message.patch
-3f24f648c27e9b5a6872859fe97b34055b0f43b11f0321508852b20b6dd94de5c8d24a6dbaab9d49e7004bf0c571c11ebf520d49630d8a89bceeb7783de7dcd2 parse-test-fix.patch"