summaryrefslogtreecommitdiff
path: root/harmony/libtool
diff options
context:
space:
mode:
Diffstat (limited to 'harmony/libtool')
-rw-r--r--harmony/libtool/APKBUILD55
-rw-r--r--harmony/libtool/libtool-fix-cross-compile.patch36
-rw-r--r--harmony/libtool/libtool.patch41
3 files changed, 0 insertions, 132 deletions
diff --git a/harmony/libtool/APKBUILD b/harmony/libtool/APKBUILD
deleted file mode 100644
index 518d33a0a..000000000
--- a/harmony/libtool/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=libtool
-pkgver=2.4.6
-pkgrel=5
-pkgdesc="A generic library support script"
-arch="all"
-license="GPL"
-url="http://www.gnu.org/software/libtool"
-source="ftp://ftp.gnu.org/pub/gnu/libtool/${pkgname}-${pkgver}.tar.gz
- libtool-fix-cross-compile.patch
- "
-depends="bash libltdl"
-makedepends="m4 help2man"
-checkdepends="mawk autoconf automake gzip"
-subpackages="libltdl $pkgname-doc"
-options="libtool"
-
-builddir="$srcdir"/$pkgname-$pkgver
-
-build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-static \
- lt_cv_shlibpath_overrides_runpath=yes
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-check() {
- cd "$builddir"
- # Test 70 and 117 are known to fail
- # Test 170 repeats the entire test suite with shorter max_cmd_len
- make check TESTSUITEFLAGS="1-69 71-116 118-169"
-}
-
-libltdl() {
- pkgdesc="Runtime libraries for GNU Libtool Dynamic Module Loader"
- depends=
- mkdir -p "$subpkgdir/usr/lib"
- mv "$pkgdir/usr/lib/libltdl.so"* "$subpkgdir/usr/lib/"
-}
-
-md5sums="addf44b646ddb4e3919805aa88fa7c5e libtool-2.4.6.tar.gz
-3657a65e226879586c29360eac6ae41b libtool-fix-cross-compile.patch"
-sha256sums="e3bd4d5d3d025a36c21dd6af7ea818a2afcd4dfc1ea5a17b39d7854bcd0c06e3 libtool-2.4.6.tar.gz
-c98362e9b1efd90618813a6901144452dc03f51e6300686bb07e068ac851c245 libtool-fix-cross-compile.patch"
-sha512sums="3233d81cb2739a54b840a0a82064eebbfaa4fb442fb993a35d6bd41d8395c51f038c90ae048b9252f172d0a5bbfb4b36e2b13d4477001f9ff7d4124237819a18 libtool-2.4.6.tar.gz
-aa14cadd70a633520249fa3a6a4c45b309a980380e62dd5982b3ae842c478a77401ad809297fceebd167c167b0a19f380e6a6c295bc75d1029d56d3bf262b209 libtool-fix-cross-compile.patch"
diff --git a/harmony/libtool/libtool-fix-cross-compile.patch b/harmony/libtool/libtool-fix-cross-compile.patch
deleted file mode 100644
index 585897e0d..000000000
--- a/harmony/libtool/libtool-fix-cross-compile.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- libtool-2.4.6.orig/build-aux/ltmain.in
-+++ libtool-2.4.6/build-aux/ltmain.in
-@@ -6449,7 +6449,7 @@
- fi
- else
- # We cannot seem to hardcode it, guess we'll fake it.
-- add_dir=-L$libdir
-+ add_dir="-L$lt_sysroot$libdir"
- # Try looking first in the location we're being installed to.
- if test -n "$inst_prefix_dir"; then
- case $libdir in
-@@ -7628,9 +7628,11 @@
- test relink = "$opt_mode" || rpath=$compile_rpath$rpath
- for libdir in $rpath; do
- if test -n "$hardcode_libdir_flag_spec"; then
-+ func_replace_sysroot "$libdir"
-+ libdir=$func_replace_sysroot_result
-+ func_stripname '=' '' "$libdir"
-+ libdir=$func_stripname_result
- if test -n "$hardcode_libdir_separator"; then
-- func_replace_sysroot "$libdir"
-- libdir=$func_replace_sysroot_result
- if test -z "$hardcode_libdirs"; then
- hardcode_libdirs=$libdir
- else
-@@ -8360,6 +8362,10 @@
- hardcode_libdirs=
- for libdir in $compile_rpath $finalize_rpath; do
- if test -n "$hardcode_libdir_flag_spec"; then
-+ func_replace_sysroot "$libdir"
-+ libdir=$func_replace_sysroot_result
-+ func_stripname '=' '' "$libdir"
-+ libdir=$func_stripname_result
- if test -n "$hardcode_libdir_separator"; then
- if test -z "$hardcode_libdirs"; then
- hardcode_libdirs=$libdir
diff --git a/harmony/libtool/libtool.patch b/harmony/libtool/libtool.patch
deleted file mode 100644
index 4302b7e07..000000000
--- a/harmony/libtool/libtool.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff --git a/main/libtool/APKBUILD b/main/libtool/APKBUILD
-index de86f2aeb7..3a7d137533 100644
---- a/main/libtool/APKBUILD
-+++ b/main/libtool/APKBUILD
-@@ -4,13 +4,14 @@ pkgver=2.4.6
- pkgrel=1
- pkgdesc="A generic library support script"
- arch="all"
--license='GPL'
-+license="GPL"
- url="http://www.gnu.org/software/libtool"
- source="ftp://ftp.gnu.org/pub/gnu/libtool/${pkgname}-${pkgver}.tar.gz
- libtool-fix-cross-compile.patch
- "
- depends="bash libltdl"
- makedepends="m4 help2man"
-+checkdepends="mawk autoconf automake gzip"
- subpackages="libltdl $pkgname-doc"
- options="libtool"
-
-@@ -23,7 +24,7 @@ build() {
- --host=$CHOST \
- --prefix=/usr \
- --disable-static \
-- || return 1
-+ lt_cv_shlibpath_overrides_runpath=yes
- make
- }
-
-@@ -32,6 +33,11 @@ package() {
- make DESTDIR="$pkgdir" install
- }
-
-+check() {
-+ cd "$builddir"
-+ make check
-+}
-+
- libltdl() {
- pkgdesc="Runtime libraries for GNU Libtool Dynamic Module Loader"
- depends=