summaryrefslogtreecommitdiff
path: root/harmony/libxml2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'harmony/libxml2/APKBUILD')
-rw-r--r--harmony/libxml2/APKBUILD77
1 files changed, 0 insertions, 77 deletions
diff --git a/harmony/libxml2/APKBUILD b/harmony/libxml2/APKBUILD
deleted file mode 100644
index 8f7207c16..000000000
--- a/harmony/libxml2/APKBUILD
+++ /dev/null
@@ -1,77 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
-pkgname=libxml2
-pkgver=2.9.7
-pkgrel=2
-pkgdesc="XML parsing library, version 2"
-url="http://www.xmlsoft.org/"
-arch="all"
-license="MIT"
-depends=
-depends_dev="zlib-dev icu-dev"
-checkdepends="perl tar"
-makedepends="$depends_dev python3-dev"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-utils py-libxml2:py"
-options="!check !strip" # Impossible to run on Python 3
-source="ftp://ftp.xmlsoft.org/${pkgname}/${pkgname}-${pkgver}.tar.gz
- libxml2-2.9.4-remove-pyverify_fd.patch
- python-segfault-fix.patch
- "
-builddir="$srcdir/$pkgname-$pkgver"
-
-# secfixes:
-# 2.9.4-r1:
-# - CVE-2016-5131
-# 2.9.4-r2:
-# - CVE-2016-9318
-# 2.9.4-r4:
-# - CVE-2017-5969
-
-prepare() {
- default_prepare
- # setup.py is generated
- rm python/setup.py
-}
-
-build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --with-icu \
- --with-python=/usr/bin/python3
- make
-}
-
-package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install
-}
-
-dev() {
- default_dev
- mv "$pkgdir"/usr/lib/*.sh "$subpkgdir"/usr/lib/
-}
-
-py() {
- cd "$builddir"
-
- pkgdesc="$pkgname Python bindings"
- provides="py3-libxml2=$pkgver-r$pkgrel"
- install -d "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
-}
-
-utils() {
- pkgdesc="XML utilities"
- replaces="libxml2"
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
-}
-
-sha512sums="da06cb7c5032ef4b7c8e902fabb9d2c74634c42c161be07a7c66a00d53a68029f89b0d4de32a6b9d4ff338c2d1d9c4e53aefb9cf50cb1c2d6c6b06b442ef42d5 libxml2-2.9.7.tar.gz
-271e701daf08f10a8b591c5128f596105901a29ecc9ee72f088afab266eaec7932a4a7d2194baa07c69e1aa93f3e9dc01a4a890456f53416c45d490598be41d9 libxml2-2.9.4-remove-pyverify_fd.patch
-384b3d2031cd8f77528190bbb7652faa9ccb22bc604bcf4927e59046d38830dac38010828fe1568b6514976f725981a6d3ac1aa595d31477a36db2afe491452c python-segfault-fix.patch"