summaryrefslogtreecommitdiff
path: root/sys-devel/compat-headers/compat-headers-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/compat-headers/compat-headers-1.0.ebuild')
-rw-r--r--sys-devel/compat-headers/compat-headers-1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-devel/compat-headers/compat-headers-1.0.ebuild b/sys-devel/compat-headers/compat-headers-1.0.ebuild
new file mode 100644
index 000000000..5b3a9e68f
--- /dev/null
+++ b/sys-devel/compat-headers/compat-headers-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2015-2016 Adélie Linux Team
+# Distributed under the terms of the NCSA License
+
+EAPI=6
+
+DESCRIPTION="Development headers for compatibility with BSD and glibc"
+HOMEPAGE="http://alpinelinux.org/"
+SRC_URI="http://git.alpinelinux.org/cgit/aports/plain/main/libc-dev/sys-cdefs.h?id=e3725c0af137717d6883265a92db3838900b5cee -> cdefs.h
+ http://git.alpinelinux.org/cgit/aports/plain/main/libc-dev/sys-queue.h?id=e3725c0af137717d6883265a92db3838900b5cee -> queue.h
+ http://git.alpinelinux.org/cgit/aports/plain/main/libc-dev/sys-tree.h?id=e3725c0af137717d6883265a92db3838900b5cee -> tree.h"
+
+LICENSE="BSD-2 BSD-3 GPL2"
+SLOT="0"
+KEYWORDS="arm mips ppc ppc64 x86 x86_64"
+IUSE=""
+
+DEPEND="!sys-libs/glibc"
+RDEPEND="${DEPEND}"
+
+src_unpack () {
+ mkdir -p "${S}"
+ for header in cdefs.h queue.h tree.h; do
+ cp "${DISTDIR}/${header}" "${S}"
+ done
+}
+
+src_install () {
+ insinto /usr/include/sys
+ doins cdefs.h queue.h tree.h
+}