summaryrefslogtreecommitdiff
path: root/sys-libs/librpc/librpc-20151104.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/librpc/librpc-20151104.ebuild')
-rw-r--r--sys-libs/librpc/librpc-20151104.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-libs/librpc/librpc-20151104.ebuild b/sys-libs/librpc/librpc-20151104.ebuild
new file mode 100644
index 000000000..869bd623a
--- /dev/null
+++ b/sys-libs/librpc/librpc-20151104.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2016 Adélie Linux Team
+# Distributed under the terms of the NCSA License
+
+EAPI=6
+
+CMAKE_MIN_VERSION=2.6
+# Required for silliness.
+CMAKE_IN_SOURCE_BUILD=true
+
+inherit cmake-utils
+
+DESCRIPTION="Standalone librpc forked from uclibc"
+HOMEPAGE="http://openwrt.org/"
+SRC_URI="http://git.openwrt.org/project?p=project/librpc-uclibc.git;a=snapshot;h=a921e3ded051746f9f7cd5e5a312fb6771716aac;sf=tgz -> librpc-20151104.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="mips ~ppc ~ppc64 x86 x86_64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/librpc-uclibc-a921e3d"
+
+PATCHES=( "${FILESDIR}/${P}-fix-throw-decls.patch"
+ "${FILESDIR}/${P}-perror.patch"
+ "${FILESDIR}/${P}-sys-types.patch"
+)