summaryrefslogtreecommitdiff
path: root/system/abuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/abuild')
-rw-r--r--system/abuild/APKBUILD24
-rw-r--r--system/abuild/apkpath.patch25
-rw-r--r--system/abuild/auto-dev-symbols.patch18
-rw-r--r--system/abuild/bang.patch10
-rw-r--r--system/abuild/modernise.patch164
5 files changed, 34 insertions, 207 deletions
diff --git a/system/abuild/APKBUILD b/system/abuild/APKBUILD
index b2ccb8f8d..257a11ad0 100644
--- a/system/abuild/APKBUILD
+++ b/system/abuild/APKBUILD
@@ -1,12 +1,13 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=abuild
-pkgver=3.3.1
-pkgrel=4
+pkgver=3.4.1
+pkgrel=1
pkgdesc="Script to build APK packages"
url="https://code.foxkit.us/adelie/abuild"
arch="all"
options="suid !check"
license="GPL-2.0-only"
+pkggroups="abuild"
depends="fakeroot sudo pax-utils openssl apk-tools>=2.0.7-r1 libc-utils
attr libarchive-tools pkgconf patch lzip"
if [ "$CBUILD" = "$CHOST" ]; then
@@ -15,16 +16,12 @@ fi
makedepends_build="pkgconfig"
makedepends_host="openssl-dev zlib-dev"
makedepends="$makedepends_host $makedepends_build"
-install="$pkgname.pre-install $pkgname.pre-upgrade"
subpackages="abuild-rootbld:_rootbld:noarch $pkgname-doc"
-pkggroups="abuild"
-source="https://distfiles.adelielinux.org/source/abuild-$pkgver+adelie.tar.xz
+install="$pkgname.pre-install $pkgname.pre-upgrade"
+source="https://distfiles.adelielinux.org/source/abuild-$pkgver.tar.xz
+ apkpath.patch
keyhole.patch
- auto-dev-symbols.patch
- bang.patch
- modernise.patch
"
-builddir="$srcdir/$pkgname-$pkgver+adelie"
# secfixes:
# 3.3.1-r1:
@@ -32,7 +29,6 @@ builddir="$srcdir/$pkgname-$pkgver+adelie"
prepare() {
default_prepare
-
sed -i -e "/^CHOST=/s/=.*/=$CHOST/" abuild.conf
}
@@ -58,8 +54,6 @@ _rootbld() {
mkdir -p "$subpkgdir"
}
-sha512sums="c358f84d198527eeeac1a1aacc101174e18f9f34f692b12a4e4deb6b32d5f3ebdc703c90de6a6f81f195a81eebb90a11f9bfea13ef5db531d9b5d5ae6ecd6a66 abuild-3.3.1+adelie.tar.xz
-757d750d4b5c88bf00774b64f2b93a9461e03f284d9423dc58c581e1309f276628de3114fcb510afd7c3cd55ceb721c1278e42756977c97ebe2597207805318d keyhole.patch
-2aa43539fc465f5abdc7c3d994363b80d1f7494c2d659093e5a2c45056e07617506ad8ea98f0e7d4ebe2596802b76605cd7c9f3ffc5a30c488c30bb36248e3d2 auto-dev-symbols.patch
-0fccb03673f2f72a7bd2d2afd1c79141eeb73b3119e83fff966fb8a2851c0484912be70a7b384be1dc384c344cf27427e2fc2426c2f9bf56aa5625f32436524d bang.patch
-b5b200da56c4319d332a7c5ddf38879fba0a4af723e1c6492f80a101afc8711d978dd7e1e5c31c80ed7fee15dcb19e7c449c92761b509a8063e417869885edc5 modernise.patch"
+sha512sums="6446171cc68d8341b5267816e7a05e0dc7b8a4e89c8c8410ae61e9501b163cc32db888476b14f032c16ef15bdd4dd4844e087394c2d061db8281f7bdfb34d450 abuild-3.4.1.tar.xz
+bc373c93344d498a48675256bb26cf9bebac74f54d8e53a09c0975e3047c481ee35c6b88e5de392efd2d0ce2a8de23ebbf0822e1a093ee01ea99349f238c62f7 apkpath.patch
+757d750d4b5c88bf00774b64f2b93a9461e03f284d9423dc58c581e1309f276628de3114fcb510afd7c3cd55ceb721c1278e42756977c97ebe2597207805318d keyhole.patch"
diff --git a/system/abuild/apkpath.patch b/system/abuild/apkpath.patch
new file mode 100644
index 000000000..4390fe0b0
--- /dev/null
+++ b/system/abuild/apkpath.patch
@@ -0,0 +1,25 @@
+From d9811dee71cfafde1fe6d596a2b9922b60dd0c4f Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Fri, 21 Feb 2020 19:28:36 -0600
+Subject: [PATCH] abuild: Solve, once and for all, 'apk: not found'
+
+---
+ abuild.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/abuild.in b/abuild.in
+index 1b8898b..2212789 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -23,7 +23,7 @@ fi
+ # defaults
+ : ${FAKEROOT:="fakeroot"}
+ : ${SUDO_APK:="abuild-apk"}
+-: ${APK:="apk"}
++: ${APK:="/sbin/apk"}
+ : ${ADDUSER:="abuild-adduser"}
+ : ${ADDGROUP:="abuild-addgroup"}
+
+--
+2.25.0
+
diff --git a/system/abuild/auto-dev-symbols.patch b/system/abuild/auto-dev-symbols.patch
deleted file mode 100644
index 1fbca7bad..000000000
--- a/system/abuild/auto-dev-symbols.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- abuild-3.3.1+adelie/abuild.in.old 2019-03-07 00:48:00.110000000 +0000
-+++ abuild-3.3.1+adelie/abuild.in 2019-12-20 23:44:19.956669659 +0000
-@@ -1651,6 +1651,7 @@
- default_dbg() {
- local f
- pkgdesc="$pkgdesc (debug symbols)"
-+ install_if="symbols $pkgname=$pkgver-r$pkgrel"
-
- binfiles=$(scanelf -R "$pkgdir" | grep ET_DYN | sed "s:$pkgdir\/::g" | sed "s:ET_DYN ::g")
- for f in $binfiles; do
-@@ -1681,6 +1682,7 @@
- local i= j=
- depends="$depends_dev"
- pkgdesc="$pkgdesc (development files)"
-+ install_if="dev $pkgname=$pkgver-r$pkgrel"
-
- cd "$pkgdir" || return 0
- local libdirs=usr/
diff --git a/system/abuild/bang.patch b/system/abuild/bang.patch
deleted file mode 100644
index 7140f4dd8..000000000
--- a/system/abuild/bang.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/abuild.in b/abuild.in
-index acee26f..6e06f29 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -1,4 +1,4 @@
--#!/bin/sh -e
-+#!/bin/bash -e
-
- # abuild - build apk packages (light version of makepkg)
- # Copyright (c) 2008-2015 Natanael Copa <ncopa@alpinelinux.org>
diff --git a/system/abuild/modernise.patch b/system/abuild/modernise.patch
deleted file mode 100644
index b87b098f9..000000000
--- a/system/abuild/modernise.patch
+++ /dev/null
@@ -1,164 +0,0 @@
-From 9221c1d06e9185b734d58c155764ed24fcfc48ed Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Tue, 14 Jan 2020 04:46:41 -0600
-Subject: [PATCH 1/2] newapkbuild: Drastically modernise output APKBUILD file
-
----
- newapkbuild.in | 44 +++++++++++++++++++++++++++++++-------------
- 1 file changed, 31 insertions(+), 13 deletions(-)
-
-diff --git a/newapkbuild.in b/newapkbuild.in
-index 85f838f..dbcef14 100644
---- a/newapkbuild.in
-+++ b/newapkbuild.in
-@@ -68,13 +68,9 @@ build_cmake() {
- -DCMAKE_BUILD_TYPE=RelWithDebugInfo \\
- -DCMAKE_CXX_FLAGS="\$CXXFLAGS" \\
- -DCMAKE_C_FLAGS="\$CFLAGS" \\
-- \${CMAKE_CROSSOPTS}
-+ \${CMAKE_CROSSOPTS} \\
-+ .
- make
--}
--
--check() {
-- cd "\$builddir"
-- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
- __EOF__
- }
-
-@@ -115,6 +111,12 @@ check_make() {
- __EOF__
- }
-
-+check_cmake() {
-+ cat >>APKBUILD<<__EOF__
-+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-+__EOF__
-+}
-+
- check_python() {
- cat >>APKBUILD<<__EOF__
- python3 setup.py test
-@@ -193,7 +195,7 @@ newaport() {
- python) makedepends="python3-dev";;
- cmake) makedepends="cmake";;
- meson) makedepends="meson";;
-- *) makedepends="\$depends_dev";;
-+ *) makedepends="";;
- esac
-
- # Replace pkgver in $source
-@@ -226,9 +228,15 @@ url="$url"
- arch="all"
- license="$license"
- depends="$depends"
--depends_dev=""
- makedepends="$makedepends"
-+__EOF__
-+ if [ -n "$install" ]; then
-+ cat >>APKBUILD<<__EOF__
- install="$install"
-+__EOF__
-+ fi
-+
-+ cat >>APKBUILD<<__EOF__
- subpackages="\$pkgname-dev \$pkgname-doc"
- source="$source"
- __EOF__
-@@ -241,7 +249,12 @@ __EOF__
- builddir=$(echo ${i#*/} | sed "s/$pv/\$pkgver/g")
- fi
- done
-- printf 'builddir="$srcdir/%s"\n\n' "$builddir" >> APKBUILD
-+ if [ -n "$sdir" ] && [ "$sdir" = "src/$pkgname-$pv" ]; then
-+ # No builddir needed.
-+ :
-+ else
-+ printf 'builddir="$srcdir/%s"\n\n' "$builddir" >> APKBUILD
-+ fi
-
- # Subpackage -dev is usually required only for C/C++. Since depends_dev
- # confuses a lot people, remove it if there's no .h or .hpp file.
-@@ -271,7 +284,6 @@ __EOF__
- # Create build() function
- cat >>APKBUILD<<__EOF__
- build() {
-- cd "\$builddir"
- __EOF__
-
- case "$buildtype" in
-@@ -287,6 +299,8 @@ __EOF__
- build_perl;;
- python)
- build_python;;
-+ *)
-+ printf '# Add build instructions here.' >> APKBUILD
- esac
-
- cat >>APKBUILD<<__EOF__
-@@ -297,14 +311,17 @@ __EOF__
- # Create check() function
- cat >>APKBUILD<<__EOF__
- check() {
-- cd "\$builddir"
- __EOF__
-
- case "$buildtype" in
-- make|cmake|autotools|perl)
-+ make|autotools|perl)
- check_make;;
-+ cmake)
-+ check_cmake;;
- python)
- check_python;;
-+ *)
-+ printf '# Add test instructions here.' >> APKBUILD
- esac
-
- cat >>APKBUILD<<__EOF__
-@@ -315,7 +332,6 @@ __EOF__
- # Create package() function
- cat >>APKBUILD<<__EOF__
- package() {
-- cd "\$builddir"
- __EOF__
-
- case "$buildtype" in
-@@ -329,6 +345,8 @@ __EOF__
- package_perl;;
- python)
- package_python;;
-+ *)
-+ printf '# Add packaging instructions here.' >> APKBUILD
- esac
-
- if [ -n "$cpinitd" ]; then
---
-2.24.1
-
-From 59cb9822c0ac347d58f1c37627a58fe14dce965d Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Tue, 14 Jan 2020 04:47:36 -0600
-Subject: [PATCH 2/2] newapkbuild: Newline after source
-
----
- newapkbuild.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/newapkbuild.in b/newapkbuild.in
-index dbcef14..9c4ffbf 100644
---- a/newapkbuild.in
-+++ b/newapkbuild.in
-@@ -251,7 +251,7 @@ __EOF__
- done
- if [ -n "$sdir" ] && [ "$sdir" = "src/$pkgname-$pv" ]; then
- # No builddir needed.
-- :
-+ printf '\n' >> APKBUILD
- else
- printf 'builddir="$srcdir/%s"\n\n' "$builddir" >> APKBUILD
- fi
---
-2.24.1
-