summaryrefslogtreecommitdiff
path: root/system/abuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/abuild')
-rw-r--r--system/abuild/0001-abuild-add-env-option-to-require-tests.patch33
-rw-r--r--system/abuild/0001-abuild-continue-faking-POSIX-support-for-now.patch31
-rw-r--r--system/abuild/0001-newapkbuild-fix-typo.patch25
-rw-r--r--system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch40
-rw-r--r--system/abuild/APKBUILD29
-rw-r--r--system/abuild/adelie-customisations.patch48
-rw-r--r--system/abuild/newapkbuild-cmake.patch35
-rw-r--r--system/abuild/posix-abuild.patch68
8 files changed, 109 insertions, 200 deletions
diff --git a/system/abuild/0001-abuild-add-env-option-to-require-tests.patch b/system/abuild/0001-abuild-add-env-option-to-require-tests.patch
deleted file mode 100644
index 49497421b..000000000
--- a/system/abuild/0001-abuild-add-env-option-to-require-tests.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From d85a92478fc8a95bdcb4bf84c30c20ca935abc08 Mon Sep 17 00:00:00 2001
-From: Carlo Landmeter <clandmeter@gmail.com>
-Date: Tue, 24 Oct 2017 14:48:52 +0200
-Subject: [PATCH] abuild: add env option to require tests
-
-This adds an env option REQUIRE_CHECK to require testsuites to
-be run. This does not clutter getopts so it can be safely removed
-afterwards when we enforce tests globally. This will allow our CI
-infrastructure to enforce testsuites where possible.
----
- abuild.in | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/abuild.in b/abuild.in
-index 41b465d..7e3c818 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -226,6 +226,12 @@ default_sanitycheck() {
- check_secfixes_comment || return 1
-
- makedepends_has 'g++' && ! options_has toolchain && warning "g++ should not be in makedepends"
-+
-+ if ! options_has "!check" && [ -n "$REQUIRE_CHECK" ]; then
-+ (unset check; . "$APKBUILD"; type check >/dev/null 2>&1) || \
-+ die "Testsuites (abuild check) are required or needs to be explicitly disabled!"
-+ fi
-+
- return 0
- }
-
---
-2.14.2
-
diff --git a/system/abuild/0001-abuild-continue-faking-POSIX-support-for-now.patch b/system/abuild/0001-abuild-continue-faking-POSIX-support-for-now.patch
new file mode 100644
index 000000000..d3bcb70ca
--- /dev/null
+++ b/system/abuild/0001-abuild-continue-faking-POSIX-support-for-now.patch
@@ -0,0 +1,31 @@
+From 2a696e782445c020db606e92f49a7afb8b9bda1a Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Sun, 20 May 2018 02:10:36 -0500
+Subject: [PATCH] abuild: continue faking POSIX support for now
+
+---
+ abuild.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/abuild.in b/abuild.in
+index bd32f4e..e3a35ca 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -1,4 +1,4 @@
+-#!/bin/ash -e
++#!/bin/sh -e
+
+ # abuild - build apk packages (light version of makepkg)
+ # Copyright (c) 2008-2015 Natanael Copa <ncopa@alpinelinux.org>
+@@ -441,7 +441,7 @@ default_unpack() {
+ tar -C "$srcdir" -xf "$s" || return 1;;
+ *.tar.gz|*.tgz)
+ msg "Unpacking $s..."
+- $gunzip -c "$s" | tar -C "$srcdir" -x || return 1;;
++ $gunzip -c "$s" | tar -C "$srcdir" -f - -x || return 1;;
+ *.tar.bz2)
+ msg "Unpacking $s..."
+ tar -C "$srcdir" -jxf "$s" || return 1;;
+--
+2.15.0
+
diff --git a/system/abuild/0001-newapkbuild-fix-typo.patch b/system/abuild/0001-newapkbuild-fix-typo.patch
new file mode 100644
index 000000000..9df4f8526
--- /dev/null
+++ b/system/abuild/0001-newapkbuild-fix-typo.patch
@@ -0,0 +1,25 @@
+From 15299d6c47c3a0fdd0091691ad3461680f1cadff Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Tue, 22 May 2018 21:50:06 -0500
+Subject: [PATCH 1/2] newapkbuild: fix typo
+
+---
+ newapkbuild.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/newapkbuild.in b/newapkbuild.in
+index 541f261..1a005c3 100644
+--- a/newapkbuild.in
++++ b/newapkbuild.in
+@@ -170,7 +170,7 @@ newaport() {
+ pkgname=$pn
+ fi
+ if [ -e "$pkgname"/APKBUILD ] && [ -z "$force" ]; then
+- error "$pkgname/APKBUILD already exist"
++ error "$pkgname/APKBUILD already exists"
+ return 1
+ fi
+ mkdir -p "$pkgname"
+--
+2.15.0
+
diff --git a/system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch b/system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch
new file mode 100644
index 000000000..338aff758
--- /dev/null
+++ b/system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch
@@ -0,0 +1,40 @@
+From d3040cca076e187259e4aa4b1d613752d7254fcd Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Tue, 22 May 2018 21:50:55 -0500
+Subject: [PATCH 2/2] newapkbuild: move checksum call to after fetch
+
+unpack will no longer unpack without a checksum, even with -f. This
+means that newapkbuild will not be able to deduce what kind of build
+system is contained within, so the templates for CMake, Perl, etc are
+never used.
+
+This patch ensures checksumming is done right after fetch, so that
+unpack works properly.
+---
+ newapkbuild.in | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/newapkbuild.in b/newapkbuild.in
+index 1a005c3..77d1a8b 100644
+--- a/newapkbuild.in
++++ b/newapkbuild.in
+@@ -228,7 +228,7 @@ subpackages="\$pkgname-dev \$pkgname-doc"
+ source="$source"
+ __EOF__
+
+- abuild -f fetch unpack
++ abuild -f fetch checksum unpack
+ # Figure out the builddir
+ for i in src/*; do
+ if [ -d "$i" ]; then
+@@ -339,7 +339,6 @@ __EOF__
+ }
+
+ __EOF__
+- abuild -f checksum
+ }
+
+ usage() {
+--
+2.15.0
+
diff --git a/system/abuild/APKBUILD b/system/abuild/APKBUILD
index 8dd1c12b6..9705e141e 100644
--- a/system/abuild/APKBUILD
+++ b/system/abuild/APKBUILD
@@ -1,10 +1,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abuild
-pkgver=3.1.0
-_ver=${pkgver%_git*}
+pkgver=3.2.0_rc1
pkgrel=2
-pkgdesc="Script to build Alpine Packages"
-url="http://git.alpinelinux.org/cgit/abuild/"
+pkgdesc="Script to build APK packages"
+url="https://code.foxkit.us/adelie/aports"
arch="all"
license="GPL-2.0"
depends="fakeroot sudo pax-utils openssl apk-tools>=2.0.7-r1 libc-utils
@@ -17,16 +16,15 @@ makedepends_host="openssl-dev zlib-dev"
makedepends="$makedepends_host $makedepends_build"
install="$pkgname.pre-install $pkgname.pre-upgrade"
subpackages="apkbuild-cpan:cpan:noarch apkbuild-gem-resolver:gems:noarch
- abuild-rootbld:_rootbld:noarch"
+ abuild-rootbld:_rootbld:noarch $pkgname-doc"
options="suid !check"
pkggroups="abuild"
-source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
- posix-abuild.patch
- newapkbuild-cmake.patch
- adelie-customisations.patch
- 0001-abuild-add-env-option-to-require-tests.patch
+source="https://distfiles.adelielinux.org/source/abuild-$pkgver+adelie.tar.xz
+ 0001-abuild-continue-faking-POSIX-support-for-now.patch
+ 0001-newapkbuild-fix-typo.patch
+ 0002-newapkbuild-move-checksum-call-to-after-fetch.patch
"
-builddir="$srcdir/$pkgname-$_ver"
+builddir="$srcdir/$pkgname-$pkgver+adelie"
prepare() {
default_prepare
@@ -71,8 +69,7 @@ _rootbld() {
mkdir -p "$subpkgdir"
}
-sha512sums="bb9093d67942e3a63e4e053692c0bca30940cae05955518206cd9f7029211a188b7f442456ae126e61cbdca224eddb31e967d5cf0637e16893163cc963871a52 abuild-3.1.0.tar.xz
-86194084e95cdb42d4b1bc3d4ff2b8144125aa4e7f74f8c97023c55f2304d27d8c377baf5075666c9b43323506357b962d83d4a30a3f41cde7b53542889adf2d posix-abuild.patch
-705c393b37c37a364473590190122a43a2962946290a873e6685cd4eb43c4874bfdf7489e7b655f870b332dee38edca5dcf2d3906461001875a55b9e6549b824 newapkbuild-cmake.patch
-e27f29b94fe55fe59ab9dc28986cd1755a41221ad6b4457c7c0b268e561f7c6946ea6fcb8b7ace897acfde2e4660ec7150ef43fb0c71c6c20dfd38aa1d062140 adelie-customisations.patch
-e02cc44c8ad9dd61c9b80684b8cf5b64477a6fd6221cde9efea2a7594c6e7ce01a51f8bd4b80d72f82f7caf93217979fb0b354c420983891fa93f34c4252a035 0001-abuild-add-env-option-to-require-tests.patch"
+sha512sums="8d9e66ec6a4e814f9be0a10b53c4b183afa97c9969d9bb86fdec0b9096756d6343cec4840fb61a5812eb4879e61c106adbdd286e63d9cfc4f8b66b6cad79557b abuild-3.2.0_rc1+adelie.tar.xz
+b7aa7ff9858eee2ff20eeed3b8da60d40e608b4da2676acb9c8b16ca6639283e5d70884888efd505fcd239bb462f726203e4773a4f706b16d07742b2a8631b6c 0001-abuild-continue-faking-POSIX-support-for-now.patch
+4ef673998b8f28469eeb4d1448a664f7052686466a67b1a3f3cab1e249ad44308df92737da4eae3c3ffea06806f460e23fc1c0ddccd7f9e82c4e308cb63be029 0001-newapkbuild-fix-typo.patch
+c6ebe8219c2e8ec9fc75da1c597b2d8d960e632286a6c7f1d1ffb6623b4d4acca54ae90a6c07637c589cbbe3ed2fb0da0c26a41df20cac0318b4894991e2dbf4 0002-newapkbuild-move-checksum-call-to-after-fetch.patch"
diff --git a/system/abuild/adelie-customisations.patch b/system/abuild/adelie-customisations.patch
deleted file mode 100644
index db7280abc..000000000
--- a/system/abuild/adelie-customisations.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git a/functions.sh.in b/functions.sh.in
-index 4f2c023..a4de25c 100644
---- a/functions.sh.in
-+++ b/functions.sh.in
-@@ -5,16 +5,20 @@ program=${0##*/}
-
- arch_to_hostspec() {
- case "$1" in
-- aarch64) echo "aarch64-alpine-linux-musl" ;;
-- armel) echo "armv5-alpine-linux-musleabi" ;;
-- armhf) echo "armv6-alpine-linux-muslgnueabihf" ;;
-- armv7) echo "armv7-alpine-linux-musleabihf" ;;
-- ppc) echo "powerpc-alpine-linux-musl" ;;
-- ppc64) echo "powerpc64-alpine-linux-musl" ;;
-- ppc64le) echo "powerpc64le-alpine-linux-musl" ;;
-- s390x) echo "s390x-alpine-linux-musl" ;;
-- x86) echo "i586-alpine-linux-musl" ;;
-- x86_64) echo "x86_64-alpine-linux-musl" ;;
-+ aarch64) echo "aarch64-foxkit-linux-musl" ;;
-+ armel) echo "armv5-foxkit-linux-musleabi" ;;
-+ armhf) echo "armv6-foxkit-linux-muslgnueabihf" ;;
-+ armv7) echo "armv7-foxkit-linux-musleabihf" ;;
-+ i528) echo "pentium4-foxkit-linux-musl" ;;
-+ mips) echo "mips-foxkit-linux-musl" ;;
-+ mips32) echo "mips32el-foxkit-linux-musl" ;;
-+ pmmx) echo "i586-foxkit-linux-musl" ;;
-+ ppc) echo "powerpc-foxkit-linux-musl" ;;
-+ ppc64) echo "powerpc64-foxkit-linux-musl" ;;
-+ ppc64le) echo "powerpc64le-foxkit-linux-musl" ;;
-+ s390x) echo "s390x-foxkit-linux-musl" ;;
-+ x86) echo "i486-foxkit-linux-musl" ;;
-+ x86_64) echo "x86_64-foxkit-linux-musl" ;;
- *) echo "unknown" ;;
- esac
- }
-@@ -25,7 +29,11 @@ hostspec_to_arch() {
- arm*-*-*-*eabi) echo "armel" ;;
- armv6*-*-*-*eabihf) echo "armhf" ;;
- armv7*-*-*-*eabihf) echo "armv7" ;;
-- i[0-9]86-*-*-*) echo "x86" ;;
-+ i486-*-*-*) echo "x86" ;;
-+ i586-*-*-*) echo "pmmx" ;;
-+ mips32*-*-*-*) echo "mips32" ;;
-+ mips*-*-*-*) echo "mips" ;;
-+ pentium4-*-*-*) echo "i528" ;;
- powerpc-*-*-*) echo "ppc" ;;
- powerpc64-*-*-*) echo "ppc64" ;;
- powerpc64le-*-*-*) echo "ppc64le" ;;
diff --git a/system/abuild/newapkbuild-cmake.patch b/system/abuild/newapkbuild-cmake.patch
deleted file mode 100644
index e83ba753a..000000000
--- a/system/abuild/newapkbuild-cmake.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 4e0fb906bb3c77f307763a9565295e7d23a3b5e7 Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Wed, 11 Oct 2017 17:47:23 -0500
-Subject: [PATCH] newapkbuild: add default check to CMake and RelWithDebugInfo
- type
-
----
- newapkbuild.in | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/newapkbuild.in b/newapkbuild.in
-index c11aa39..d1cf2b9 100644
---- a/newapkbuild.in
-+++ b/newapkbuild.in
-@@ -66,11 +66,16 @@ build_cmake() {
- -DCMAKE_INSTALL_PREFIX=/usr \\
- -DCMAKE_INSTALL_LIBDIR=lib \\
- -DBUILD_SHARED_LIBS=True \\
-- -DCMAKE_BUILD_TYPE=Release \\
-+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \\
- -DCMAKE_CXX_FLAGS="\$CXXFLAGS" \\
- -DCMAKE_C_FLAGS="\$CFLAGS" \\
- \${CMAKE_CROSSOPTS}
- make
-+}
-+
-+check() {
-+ cd "\$builddir"
-+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
- __EOF__
- }
-
---
-2.14.1
-
diff --git a/system/abuild/posix-abuild.patch b/system/abuild/posix-abuild.patch
deleted file mode 100644
index ae95bec72..000000000
--- a/system/abuild/posix-abuild.patch
+++ /dev/null
@@ -1,68 +0,0 @@
---- src/abuild.in 2017-09-19 07:02:57.000000000 -0500
-+++ src/abuild.in 2017-09-23 22:34:32.534221312 -0500
-@@ -1,4 +1,4 @@
--#!/bin/ash -e
-+#!/bin/sh -e
-
- # abuild - build apk packages (light version of makepkg)
- # Copyright (c) 2008-2015 Natanael Copa <ncopa@alpinelinux.org>
-@@ -425,11 +425,11 @@
- tar -C "$srcdir" --lzip -xf "$s" || return 1;;
- *.tar.lzma)
- msg "Unpacking $s..."
-- unlzma -c "$s" | tar -C "$srcdir" -x \
-+ unlzma -c "$s" | tar -C "$srcdir" -f - -x \
- || return 1;;
- *.tar.xz)
- msg "Unpacking $s..."
-- unxz -c "$s" | tar -C "$srcdir" -x || return 1;;
-+ unxz -c "$s" | tar -C "$srcdir" -f - -x || return 1;;
- *.zip)
- msg "Unpacking $s..."
- unzip -n -q "$s" -d "$srcdir" || return 1;;
-@@ -476,7 +476,7 @@
- subpkgarch=${_splitarch#*:}
- if [ "$subpkgarch" = "$_splitarch" -o -z "$subpkgarch" ]; then
- case "$subpkgname" in
-- *-doc | *-lang | *-lang-*) subpkgarch="noarch" ;;
-+ *-doc | *-lang | *-lang-* | *-openrc) subpkgarch="noarch" ;;
- *) subpkgarch="$pkgarch" ;;
- esac
- fi
-@@ -1395,7 +1395,7 @@
- touch .dummy
- set -- .dummy
- fi
-- tar --xattrs -f - -c "$@" | abuild-tar --hash | gzip -9 >"$dir"/data.tar.gz
-+ tar --format pax --xattrs -f - -c "$@" | abuild-tar --hash | gzip -9 >"$dir"/data.tar.gz
-
- msg "Create checksum..."
- # append the hash for data.tar.gz
-@@ -1404,7 +1404,7 @@
-
- # control.tar.gz
- cd "$dir"
-- tar -f - -c $(cat "$dir"/.metafiles) | abuild-tar --cut \
-+ tar --format pax -f - -c $(cat "$dir"/.metafiles) | abuild-tar --cut \
- | gzip -9 > control.tar.gz
- abuild-sign -q control.tar.gz || exit 1
-
-@@ -1483,9 +1483,7 @@
-
- # predefined function check
- default_check() {
-- warning "APKBUILD does not run any tests!"
-- msg2 "Alpine policy will soon require that packages have any relevant testsuites run during the build process."
-- msg2 "To fix, either define a check() function, or declare !check in \$options to indicate the package does not have a testsuite."
-+ die "APKBUILD does not run any tests!"
- }
-
- check() {
-@@ -2337,6 +2335,7 @@
- }
-
- usage() {
-+ echo "$program $program_version"
- cat <<-EOF
- usage: $program [options] [-P REPODEST] [-s SRCDEST] [-D DESCRIPTION] [cmd] ...
- $program [-c] -n PKGNAME[-PKGVER]