summaryrefslogtreecommitdiff
path: root/system/adelie-base
diff options
context:
space:
mode:
Diffstat (limited to 'system/adelie-base')
-rw-r--r--system/adelie-base/APKBUILD16
-rw-r--r--system/adelie-base/group2
-rw-r--r--system/adelie-base/passwd9
3 files changed, 19 insertions, 8 deletions
diff --git a/system/adelie-base/APKBUILD b/system/adelie-base/APKBUILD
index 4bd4b1c26..5cebd3c92 100644
--- a/system/adelie-base/APKBUILD
+++ b/system/adelie-base/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=adelie-base
pkgver=0.8.1
-pkgrel=3
+pkgrel=6
pkgdesc="The Adélie Linux Base System"
url="http://adelielinux.org/"
arch="noarch"
@@ -14,7 +14,7 @@ _core_depends="apk-tools adelie-keys shadow
sysklogd
patch sed nvi psmisc less"
depends="adelie-core debianutils libarchive-tools file zsh binutils
- console-setup sysklogd man-db tzdata"
+ console-setup sysklogd man-db tzdata gettys-openrc"
makedepends=""
makedepends_host="$depends"
install=""
@@ -66,20 +66,22 @@ doc() {
DOCS="CONTRIBUTING.rst LICENSE README.rst"
for _doc in $DOCS; do
install -Dm644 "$srcdir"/$pkgname-$pkgver/$_doc \
- "$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
+ "$subpkgdir"/usr/share/doc/$pkgname/$_doc
done
}
posix() {
# We pull in vim for /usr/bin/ex, until apk has an alternatives system
- depends="adelie-base at bc cflow ed fcron heirloom-pax m4 mailx mawk vim"
+ depends="adelie-base at bc cflow ed fcron heirloom-devtools
+ heirloom-pax mailx mawk vim"
pkgdesc="$pkgdesc - Additional POSIX tools"
mkdir -p "$subpkgdir"
return 0
}
lsb() {
- depends="adelie-base gettext-tiny gzip libarchive-tools linux-pam make mawk ncurses nspr nss"
+ depends="adelie-base gettext-tiny gzip libarchive-tools linux-pam make
+ mawk ncurses nspr nss"
pkgdesc="$pkgdesc - Additional LSB tools"
mkdir -p "$subpkgdir"
return 0
@@ -93,7 +95,7 @@ devkit() {
}
sha512sums="6eb6e2798e924caa911f3d070b1c955aa1abde42ac7b51224b2c4dc851a7dcfc586915ef8b3977a1cfb13a4f503003ea62acf59417daa8a2d4b6cc2e27b755ad adelie-base-0.8.1.tar.xz
-50a2d4df4218594dd3288ac96d5336ad72318451a66540f4c86cdf31498fedf5e39ce3bfee423adbaca1ffcaf26aeaa82f17ed847bc25c0f193d2b5a5c121b97 group
-cce002394e6febc678679ca829afd5d91d26a1d5c5d3ab59f52412c75de95008c2df7e775b7539054c132a8b65160e00c5315b4b66feb27dd714259198068fd5 passwd
+37260d9315fd8d8b0df3dfb5bd3e1035a47ba1e43f33aa195e3feca6d169da282c1b067ef4603e7e9acaedbfef8b58cf490c00bdca444d43c9d570355ad29eac group
+1288d9d1ee77e1159bacbc94a44b2ae9c6dff94c5001be6e560cd5859f86181c47341317025d4999bc7d57cfcebb7974804514d981b7bd66ffd00c5edaf5360c passwd
5b87e0c73e7d73715467b09c9c228b14abfdc1567b3d8a3e6ef86694a9d016c798c22411c9c8ccf41920fbe185199f6d6dbd45d4bceb6652ab4a7bea87c4fe51 addgroup
f50be377c781b1eefb1804ac9d96b4ebc64f80abe0d12b288413687a000e79ca30c531bbced2c63f9e4df59b1d8a71d0eda09ee82782eaafea453f2f1c2f7b8f adduser"
diff --git a/system/adelie-base/group b/system/adelie-base/group
index 20b392d9d..df4d3b55a 100644
--- a/system/adelie-base/group
+++ b/system/adelie-base/group
@@ -40,6 +40,8 @@ users:x:100:games
catchlog:x:104:
ntp:x:123:
nofiles:x:200:
+qmail:x:201:
+qmaill:x:202:
smmsp:x:209:smmsp
locate:x:245:
abuild:x:300:
diff --git a/system/adelie-base/passwd b/system/adelie-base/passwd
index 6ecdc2b67..48653288a 100644
--- a/system/adelie-base/passwd
+++ b/system/adelie-base/passwd
@@ -23,7 +23,14 @@ postgres:x:70:70:PostgreSQL Master User:/var/lib/postgresql:/bin/sh
cyrus:x:85:12::/usr/cyrus:/sbin/nologin
vpopmail:x:89:89:Mail Service User:/var/vpopmail:/sbin/nologin
utmp:x:107:406:User tracking system:/var/empty:/sbin/nologin
-catchlog:x:108:104:s6 logging system:/var/empty:/sbin/nologin
+catchlog:x:108:104:s6 catch-all logger:/var/empty:/sbin/nologin
+alias:x:109:200:qmail alias user:/var/qmail/alias:/sbin/nologin
+qmaild:x:110:200:qmail daemon user:/var/qmail:/sbin/nologin
+qmailp:x:111:200:qmail password user:/var/qmail:/sbin/nologin
+qmailq:x:112:201:qmail queue user:/var/qmail:/sbin/nologin
+qmailr:x:113:201:qmail remote user:/var/qmail:/sbin/nologin
+qmails:x:114:201:qmail send user:/var/qmail:/sbin/nologin
+qmaill:x:115:202:qmail logger user:/var/qmail:/sbin/nologin
ntp:x:123:123:NTP User:/var/empty:/sbin/nologin
smmsp:x:209:209:smmsp:/var/spool/mqueue:/sbin/nologin
guest:x:405:100:Guest User:/dev/null:/sbin/nologin