summaryrefslogtreecommitdiff
path: root/system/apk-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/apk-tools/APKBUILD')
-rw-r--r--system/apk-tools/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/system/apk-tools/APKBUILD b/system/apk-tools/APKBUILD
index c20759d7c..aa4f95f5d 100644
--- a/system/apk-tools/APKBUILD
+++ b/system/apk-tools/APKBUILD
@@ -21,7 +21,6 @@ source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
prepare() {
default_prepare
- cd "$builddir"
sed -i -e 's:-Werror::' Make.rules
echo "FULL_VERSION=$pkgver-r$pkgrel" > config.mk
echo "LUAAPK=" >> config.mk
@@ -29,18 +28,15 @@ prepare() {
}
build() {
- cd "$builddir"
make
make static
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -d "$pkgdir"/var/lib/apk \
"$pkgdir"/var/cache/misc \
@@ -55,8 +51,8 @@ static() {
install -Dm755 "$srcdir"/$pkgname-$pkgver/src/apk.static \
"$subpkgdir"/sbin/apk.static
- # lets sign the static binary so it can be vefified from distros
- # that does not have apk-tools
+ # Sign the static binary so it can be vefified from distros
+ # that do not have apk-tools
local abuild_conf="${ABUILD_CONF:-"/etc/abuild.conf"}"
local abuild_home="${ABUILD_USERDIR:-"$HOME/.abuild"}"
local abuild_userconf="${ABUILD_USERCONF:-"$abuild_home/abuild.conf"}"