summaryrefslogtreecommitdiff
path: root/system/apk-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/apk-tools/APKBUILD')
-rw-r--r--system/apk-tools/APKBUILD38
1 files changed, 23 insertions, 15 deletions
diff --git a/system/apk-tools/APKBUILD b/system/apk-tools/APKBUILD
index cbbf3ceaf..d664340e0 100644
--- a/system/apk-tools/APKBUILD
+++ b/system/apk-tools/APKBUILD
@@ -1,28 +1,32 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=apk-tools
-pkgver=2.10.5
+pkgver=2.12.0
pkgrel=0
pkgdesc="Alpine Package Keeper - package manager"
-url="https://git.alpinelinux.org/cgit/apk-tools/"
+url="https://git.adelielinux.org/adelie/apk-tools"
arch="all"
license="GPL-2.0-only"
depends="ca-certificates"
makedepends_build=""
makedepends_host="zlib-dev openssl openssl-dev linux-headers"
makedepends="$makedepends_build $makedepends_host"
-subpackages="$pkgname-static"
-source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
- dash.patch
- pmmx.patch
+subpackages="$pkgname-dev $pkgname-static $pkgname-doc"
+source="https://dev.sick.bike/dist/$pkgname-v$pkgver+adelie.tar.gz
+ https://dev.sick.bike/dist/$pkgname-help-v$pkgver.tar.gz
+ apk.zsh-completion
+ s6-linux-init.patch
"
+builddir="$srcdir/$pkgname-v$pkgver"
prepare() {
default_prepare
sed -i -e 's:-Werror::' Make.rules
- echo "FULL_VERSION=$pkgver-r$pkgrel" > config.mk
- echo "LUAAPK=" >> config.mk
- echo "export LUAAPK" >> config.mk
+ cat >config.mk <<-EOF
+ FULL_VERSION=$pkgver-r$pkgrel
+ LUA=no
+ export LUA
+ EOF
}
build() {
@@ -40,13 +44,16 @@ package() {
"$pkgdir"/var/cache/misc \
"$pkgdir"/etc/apk/keys \
"$pkgdir"/etc/apk/protected_paths.d
- # the shipped README is empty
- rm -r "$pkgdir"/usr/share/
+ # the shipped README is not useful
+ rm -r "$pkgdir"/usr/share/doc
+
+ install -Dm644 "$srcdir"/apk.zsh-completion \
+ "$pkgdir"/usr/share/zsh/site-functions/_apk
}
static() {
pkgdesc="Alpine Package Keeper - static binary"
- install -Dm755 "$srcdir"/$pkgname-$pkgver/src/apk.static \
+ install -Dm755 "$builddir"/src/apk.static \
"$subpkgdir"/sbin/apk.static
# Sign the static binary so it can be vefified from distros
@@ -64,6 +71,7 @@ static() {
"$subpkgdir"/sbin/apk.static
}
-sha512sums="0f85ec7c734f2ffc671007fa029f3c96eacfb196c45e465e33aa65c32a6fbcd7523153b6441fdf826a5b4d2e66de02d338620474d333c28cb1ce0233f1120495 apk-tools-2.10.5.tar.xz
-5892ad7038c942e82b011a64484253a157711ad65cb754b884c2b9b6047dd4693b530b6639f6d8c35aa21f9c293ee01a3f36ead1d148f77a2012053766f75ee2 dash.patch
-edff13f21debc227c7448f0ac42744b2655f8f23ea23aefa04db7d2c44e8a91f77227e84ef090e65364f6999b6ee1138c98490530cb6b9b0594b7cfeeef25b61 pmmx.patch"
+sha512sums="739cbf487a9184aba56c87448d18acebf357b6eddb4852033cc0cd331fc910d425a5d01f7b0bf109f5cd62f78f10cca96ebcbdb4fa00d197edb90726998e1523 apk-tools-v2.12.0+adelie.tar.gz
+b8e6e6e9efe2fc3a900e5fea54ed2f047bbf8917c8c3e470e001865c2169167ce6a273869ba577aceb1a1580b7dd684de115a4d92250786958fa13b9e8abf28b apk-tools-help-v2.12.0.tar.gz
+cedda9bf11e0a516c9bf0fd1a239ffa345cdd236419cbd8b10273410610ae7d0f0f61fd36e1e9ccc3bbf32f895508cdca4fb57a0e04f78dd88469b33bf64a32a apk.zsh-completion
+f92e2e0c062b71e1e5cf95f0d4997166ccc7f7a5e45af8d1650f5951a1d552d89217c8c60d24f31fa626e8e0675c5e882e6b36ef1af8f7624e54627b22801381 s6-linux-init.patch"