summaryrefslogtreecommitdiff
path: root/system/bash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/bash/APKBUILD')
-rw-r--r--system/bash/APKBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/system/bash/APKBUILD b/system/bash/APKBUILD
index 455bd5fbf..ccdf8ab13 100644
--- a/system/bash/APKBUILD
+++ b/system/bash/APKBUILD
@@ -6,19 +6,18 @@ pkgver=4.4.23
_patchlevel=${pkgver##*.}
_myver=${pkgver%.*}
_patchbase=${_myver/./}
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Bourne Again shell"
-url="http://www.gnu.org/software/bash/bash.html"
+url="https://www.gnu.org/software/bash/bash.html"
arch="all"
license="GPL-3.0+"
-makedepends_build="bison flex"
+makedepends_build="byacc flex"
makedepends_host="ncurses-dev"
depends=""
-options="!checkroot"
install="$pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang
$pkgname-binsh:binsh:noarch"
-source="http://ftp.gnu.org/gnu/bash/bash-${_myver}.tar.gz
+source="https://ftp.gnu.org/gnu/bash/bash-${_myver}.tar.gz
bash-noinfo.patch
bash44-sensible-defaults.patch
bashrc
@@ -29,7 +28,7 @@ _pad="00"
while [ $_i -le $_patchlevel ]; do
[ $_i -ge 10 ] && _pad="0"
[ $_i -ge 100 ] && _pad=
- source="$source http://ftp.gnu.org/gnu/bash/bash-$_myver-patches/bash$_patchbase-$_pad$_i"
+ source="$source https://ftp.gnu.org/gnu/bash/bash-$_myver-patches/bash$_patchbase-$_pad$_i"
_i=$(( $_i + 1))
done
@@ -40,8 +39,6 @@ done
builddir="$srcdir"/$pkgname-$_myver
prepare() {
- cd "$builddir"
-
# NOTE: This section is for applying the vendor patches, which are required to fix
# security holes. `default_prepare` does *not* apply vendor patches in the format
# shipped with bash. We also need to make sure vendor patches are applied before
@@ -62,7 +59,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -77,14 +73,11 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd ${startdir}/src/${pkgname}-${_myver}
make DESTDIR=${pkgdir} install
-
install -D -m755 "$srcdir"/bashrc "$pkgdir"/etc/bash/bashrc
}