summaryrefslogtreecommitdiff
path: root/system/binutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/binutils/APKBUILD')
-rw-r--r--system/binutils/APKBUILD48
1 files changed, 14 insertions, 34 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index 1b9705ac5..faf5fca53 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -1,7 +1,7 @@
-# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=binutils
pkgver=2.30
-pkgrel=1
+pkgrel=2
pkgdesc="Tools necessary to build programs"
url="http://www.gnu.org/software/binutils/"
depends=""
@@ -10,11 +10,10 @@ makedepends_host="zlib-dev"
makedepends="$makedepends_build $makedepends_host"
checkdepends="dejagnu"
arch="all"
-license="GPL2 GPL3+ LGPL2 BSD"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-[ "${CARCH}" != "mips" ] && subpackages="$subpackages $pkgname-gold"
+license="GPL-2.0+ AND GPL-3.0+ AND LGPL-2.0+ AND LGPL-2.1+ AND LGPL-3.0+ AND BSD-3-Clause"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
# non-PIC is unsupported by musl/ppc
-[ "${CARCH}" == "ppc" ] && options='!check'
+[ "${CARCH}" != "ppc" ] || options='!check'
source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
binutils-ld-fix-static-linking.patch
disable-gnu-mbind.patch
@@ -25,9 +24,7 @@ source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
remove-pr2404-tests.patch
remove-pr19719-test.patch
remove-pr19553c-test.patch
- gold-mips.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
if [ "$CHOST" != "$CTARGET" ]; then
pkgname="$pkgname-$CTARGET_ARCH"
@@ -75,22 +72,21 @@ build() {
--enable-64-bit-bfd \
--enable-plugins \
--enable-relro \
- --enable-gold \
+ --disable-gold \
--enable-deterministic-archives \
$_cross_configure \
$_arch_configure \
$_hash_style_configure \
--disable-werror \
- --disable-nls \
- --with-system-zlib \
- || return 1
- make || return 1
+ --with-system-zlib
+ make
}
package() {
cd "$builddir"
- make install DESTDIR="$pkgdir" || return 1
+ make install DESTDIR="$pkgdir"
if [ -d "$pkgdir"/usr/lib64 ]; then
+ die "Something really bad happened."
mv "$pkgdir"/usr/lib64/* "$pkgdir"/usr/lib/
rmdir "$pkgdir"/usr/lib64
fi
@@ -104,29 +100,14 @@ package() {
check() {
cd "$builddir"
- # We can't run the gold test suite, because it cannot be used
- # on a system with default PIE/PIC.
- make -C binutils check
- make -C gas check
- make -C ld check
+ make check
}
libs() {
- pkgdesc="Runtime libraries from binutils - libbfd and libopcodes"
+ pkgdesc="Runtime libraries from binutils"
mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/lib*.so "$subpkgdir"/usr/lib/ || return 1
-}
-
-gold() {
- pkgdesc="GNU binutils - gold linker"
-
- if [ -e "$pkgdir"/usr/bin/ld.gold ]; then
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/ld.gold "$subpkgdir"/usr/bin
- fi
- mkdir -p "$subpkgdir"/usr/$CTARGET/bin
- mv "$pkgdir"/usr/$CTARGET/bin/ld.gold "$subpkgdir"/usr/$CTARGET/bin/ld.gold
+ mv "$pkgdir"/usr/lib/lib*.so "$subpkgdir"/usr/lib/
}
sha512sums="e747ea20d8d79fcd21b9d9f6695059caa7189d60f19256da398e34b789fea9a133c32b192e9693b5828d27683739b0198431bf8b3e39fb3b04884cf89d9aa839 binutils-2.30.tar.xz
@@ -138,5 +119,4 @@ ba2b5c8cdfa95db7a1f05da8a2c1ffc3bcb35300abf7061e52249d9b29037e3fdef1aed830686bca
b40f9a3841a7af8fc12e8a4044cd672df5614bfda8461b0ca45efa57a42c3bc8490e491ea490c6c05d319a52d69993c4fca33a0aeb044090e7b7f4e4e30c6517 remove-no-static-plt-test.patch
32ab4215669c728648179c124632467573a3d4675e79f0f0d221c22eb2ec1ca5488b79910bd09142f90a1e0d0b81d99ca4846297f4f9561f158db63745facb66 remove-pr2404-tests.patch
a193d1fa7f42d91915960460a15e4d24e0df529d81e23014bcf45d283fae76bb7b300fdcb0d0a9d521cdb9137322efa1dc357112596d6ae7a7fd05988ac359b9 remove-pr19719-test.patch
-39ef9c76dd5db6b15f11ffa8061f7ca844fb79c3fb9879c3b1466eef332a28b833597c87003ab9f260b1b85023fae264659088aee27cad7e5aa77b2d58b9a3f6 remove-pr19553c-test.patch
-f55cf2e0bf82f97583a1abe10710e4013ecf7d64f1da2ef8659a44a06d0dd8beaf58dab98a183488ea137f03e32d62efc878d95f018f836f8cec870bc448556f gold-mips.patch"
+39ef9c76dd5db6b15f11ffa8061f7ca844fb79c3fb9879c3b1466eef332a28b833597c87003ab9f260b1b85023fae264659088aee27cad7e5aa77b2d58b9a3f6 remove-pr19553c-test.patch"