summaryrefslogtreecommitdiff
path: root/system/binutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/binutils/APKBUILD')
-rw-r--r--system/binutils/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index d8fc3e7c5..4cd3901ec 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=binutils
pkgver=2.31.1
-pkgrel=0
+pkgrel=1
pkgdesc="Tools necessary to build programs"
url="http://www.gnu.org/software/binutils/"
depends=""
@@ -47,9 +47,11 @@ build() {
_cross_configure="--disable-install-libiberty"
fi
- if [ "$CTARGET_ARCH" = "x86_64" ]; then
- _arch_configure="--enable-targets=x86_64-pep"
- fi
+ # -z separate-code is currently causing kernel miscompiles on x86*
+ case "$CTARGET_ARCH" in
+ x86 | pmmx | i528) _arch_configure="--disable-separate-code" ;;
+ x86_64) _arch_configure="--disable-separate-code --enable-targets=x86_64-pep" ;;
+ esac
case "$CTARGET_ARCH" in
mips*) _hash_style_configure="--enable-default-hash-style=sysv" ;;