summaryrefslogtreecommitdiff
path: root/system/bison/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/bison/APKBUILD')
-rw-r--r--system/bison/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/system/bison/APKBUILD b/system/bison/APKBUILD
index a053dd0b7..c8e2b9710 100644
--- a/system/bison/APKBUILD
+++ b/system/bison/APKBUILD
@@ -1,11 +1,14 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=bison
-pkgver=3.5.3
+pkgver=3.7
pkgrel=0
pkgdesc="The GNU general-purpose parser generator"
arch="all"
-[ -n "$BOOTSTRAP" ] && options="!check"
+# iconv issue:
+# https://lists.gnu.org/archive/html/bug-bison/2020-07/msg00001.html
+# https://www.openwall.com/lists/musl/2020/07/29/2
+options="!check" # see above
license="GPL-3.0+"
url="https://www.gnu.org/software/bison/bison.html"
depends="m4"
@@ -13,7 +16,13 @@ checkdepends="bison flex musl-locales"
makedepends="perl"
provider_priority=1
subpackages="$pkgname-doc $pkgname-lang"
-source="https://ftp.gnu.org/gnu/bison/${pkgname}-${pkgver}.tar.xz"
+source="https://ftp.gnu.org/gnu/bison/${pkgname}-${pkgver}.tar.xz
+ uaf.patch
+ "
+
+# secfixes:
+# 3.5.4-r0:
+# - CVE-2020-14150
build() {
./configure \
@@ -40,4 +49,5 @@ package() {
rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
}
-sha512sums="888a1e8d4aeda3ff2d7d0a3a88b63bbfe89bdb718cc64d48c244e05fe6c6cd39526fd88143db379fef3071cf6c2dc2ab2fd69834c24acb23ed5f739584ff6308 bison-3.5.3.tar.xz"
+sha512sums="f6c8f1522849b65046844bd51953b4f1e2c32818d8bca0b8e4a1035e72d6731d8a66bc307d4b20d1a576cac6cbe10aa1c66829112327f37938ace165e154ba6a bison-3.7.tar.xz
+4a4e22589cd02fb301fdff98078a551f97967dd7add935341f47d0df3acd95827661633ff6489d1ae36730eed8ddec1c2a8ded054628abb839feda79feae4be0 uaf.patch"