summaryrefslogtreecommitdiff
path: root/system/busybox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/busybox/APKBUILD')
-rw-r--r--system/busybox/APKBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/system/busybox/APKBUILD b/system/busybox/APKBUILD
index f48d446d2..3c8049582 100644
--- a/system/busybox/APKBUILD
+++ b/system/busybox/APKBUILD
@@ -1,18 +1,18 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Contributor: Oliver Smith <ollieparanoid@bitmessage.ch>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
pkgname=busybox
pkgver=1.28.4
-pkgrel=0
+pkgrel=1
pkgdesc="Size optimized toolbox of many common UNIX utilities"
-url=http://busybox.net
+url="http://busybox.net"
arch="all"
-license="GPL-2.0-only GPL-2.0+"
+license="GPL-2.0-only AND GPL-2.0+"
makedepends_build="openssl-dev"
makedepends_host="linux-headers"
makedepends="$makedepends_build $makedepends_host"
checkdepends="zip"
-provides="/bin/sh"
+provides="/sbin/init"
install="$pkgname.post-install $pkgname.post-upgrade
$pkgname-extras.post-install $pkgname-extras.pre-deinstall"
subpackages="$pkgname-static $pkgname-suid $pkgname-extras"
@@ -185,6 +185,16 @@ static() {
"$subpkgdir"/bin/busybox.static
}
+binsh() {
+ pkgdesc="Provide /bin/sh with BusyBox ash"
+ depends="${pkgname}"
+ provides="/bin/sh"
+ provider_priority=0
+
+ mkdir -p "$subpkgdir"/bin
+ mv "$pkgdir"/bin/sh "$subpkgdir"/bin
+}
+
sha512sums="92471617fcf3c1e28b468f3de2c83a1041f5ba5106580cc791e9c4cd602b7ccffabc51ce0807881ed734a89c3089113048265d6659a4d595528bd9150288d2ed busybox-1.28.4.tar.bz2
51d4d58baff825a51d476bd4594cb8980ec2aa4d0c864a0eec39ccbbadd1ae9f1cd1b20f492a735ffcdf7c925573594f3c4363b0561c8aa7b91ef534bfc7b2e0 0001-ash-add-support-for-command_not_found_handle-hook-fu.patch
5d2fd3e521ee29d970f377363e3a3144eaf9f7714bc57494d743ded9e39c1ad93ea8759b2febd9c3786968b41e61b8d01ce2361aa997df177b644d63718470ba 0002-fsck-resolve-LABEL-.-UUID-.-spec-to-device.patch