summaryrefslogtreecommitdiff
path: root/system/debianutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/debianutils/APKBUILD')
-rw-r--r--system/debianutils/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/system/debianutils/APKBUILD b/system/debianutils/APKBUILD
new file mode 100644
index 000000000..be3f622b1
--- /dev/null
+++ b/system/debianutils/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=debianutils
+pkgver=4.8.1.1
+pkgrel=0
+pkgdesc="Useful utilities from Debian"
+url="https://packages.qa.debian.org/d/debianutils.html"
+arch="all"
+options="!check" # No test suite.
+license="BSD-3 GPL-2.0"
+depends=""
+makedepends="mawk grep" # early package, declare these
+install=""
+subpackages="$pkgname-doc"
+source="http://ftp.debian.org/debian/pool/main/d/$pkgname/${pkgname}_${pkgver}.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="22f27692a7d3847fad1be223d73e5575581db8621771e92e68fe91bd31e67084fd655fef857905be46ab3a45340503b0af9399b8fe28f221ea5cee4b49970821 debianutils_4.8.1.1.tar.xz"