summaryrefslogtreecommitdiff
path: root/system/easy-kernel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/easy-kernel/APKBUILD')
-rw-r--r--system/easy-kernel/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/system/easy-kernel/APKBUILD b/system/easy-kernel/APKBUILD
new file mode 100644
index 000000000..74088227d
--- /dev/null
+++ b/system/easy-kernel/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=easy-kernel
+pkgver=4.14.4
+pkgrel=1
+pkgdesc="The Linux kernel, packaged for your convenience"
+url="https://kernel.org/"
+arch="all"
+options="!check !dbg !strip"
+license="GPL-2.0"
+depends=""
+makedepends="lzop openssl-dev"
+install=""
+subpackages="$pkgname-modules $pkgname-src"
+source="https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.14.tar.xz
+ https://mirrormaster.adelielinux.org/source/linux-4.14-mc$pkgrel.patch.xz
+ config-ppc64
+ config-x86_64"
+builddir="$srcdir/linux-4.14"
+
+prepare() {
+ default_prepare
+ cd "$srcdir"
+ cat linux-4.14-mc$pkgrel.patch.xz | unxz -> linux-4.14-mc$pkgrel.patch
+ cd "$builddir"
+ patch -Np1 <../linux-4.14-mc$pkgrel.patch
+ cd "$srcdir"
+ cp config-$CARCH linux-4.14/.config
+ cp -pr linux-4.14 linux-src
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/boot
+ make INSTALL_PATH="$pkgdir"/boot \
+ INSTALL_MOD_PATH="$pkgdir" \
+ install modules_install
+}
+
+modules() {
+ pkgdesc="Modules / device drivers for easy-kernel"
+ mkdir -p "$subpkgdir"/lib
+ mv "$pkgdir"/lib/modules "$subpkgdir"/lib/
+}
+
+src() {
+ pkgdesc="Kernel source code used to build THIS kernel"
+ mkdir -p "$subpkgdir"/usr/src
+ mv "$srcdir"/linux-src "$subpkgdir"/usr/src/linux
+}
+sha512sums="77e43a02d766c3d73b7e25c4aafb2e931d6b16e870510c22cef0cdb05c3acb7952b8908ebad12b10ef982c6efbe286364b1544586e715cf38390e483927904d8 linux-4.14.tar.xz
+2f734ba33493f0cf2332b7cd365d8299a237b650a4183c7e136b4f10cc1eac9297640889749438cf3e312d22c48eb6302d4d4e2b2f4c2d5afc392c5ae0bac48d linux-4.14-mc1.patch.xz
+15513dd39075d5b3b27adc193995ffef9d0bad2a5b128f04f8952b0b056a97e15a143f2f3b06de1c6eaa56e6034f28c528aa69786563e2bda6bf35e3182acfaa config-ppc64
+11ae521472ea979f89549b874101de011c3e51cf6ae094490023c32b2d6cb4dbf122d82c457edb9b984d94b4f0555d7e28884ab2555d5d371fa984030b438503 config-x86_64"