summaryrefslogtreecommitdiff
path: root/system/fcron/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/fcron/APKBUILD')
-rw-r--r--system/fcron/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/system/fcron/APKBUILD b/system/fcron/APKBUILD
index 6b2998814..1a3d7cc99 100644
--- a/system/fcron/APKBUILD
+++ b/system/fcron/APKBUILD
@@ -3,28 +3,28 @@
pkgname=fcron
pkgver=3.2.1
pkgrel=3
-pkgdesc="periodical command scheduler for systems not always up"
+pkgdesc="Task scheduler"
url="http://fcron.free.fr/"
-pkgusers="fcron"
-pkggroups="fcron"
arch="all"
options="suid !check" # No test suite.
license="GPL"
depends="cmd:sendmail vim"
makedepends="perl"
install="fcron.pre-install"
+pkgusers="fcron"
+pkggroups="fcron"
subpackages="$pkgname-doc $pkgname-openrc"
source="http://fcron.free.fr/archives/${pkgname}-${pkgver}.src.tar.gz
systab.orig
fcron.initd"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--with-editor=/usr/bin/vim \
+ --with-sendmail=/usr/sbin/sendmail \
--with-spooldir=/var/spool/fcron \
--sysconfdir=/etc/fcron \
--with-answer-all=no \
@@ -37,7 +37,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir/" install
install -Dm775 "$srcdir"/fcron.initd "$pkgdir"/etc/init.d/fcron
rm -r "$pkgdir"/var/run