summaryrefslogtreecommitdiff
path: root/system/gamin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/gamin/APKBUILD')
-rw-r--r--system/gamin/APKBUILD58
1 files changed, 0 insertions, 58 deletions
diff --git a/system/gamin/APKBUILD b/system/gamin/APKBUILD
deleted file mode 100644
index 360161d27..000000000
--- a/system/gamin/APKBUILD
+++ /dev/null
@@ -1,58 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=gamin
-pkgver=0.1.10
-pkgrel=11
-pkgdesc="Gamin is a file and directory monitoring system defined to be a subset of the FAM (File Alteration Monitor) system."
-url="http://www.gnome.org/~veillard/gamin"
-arch="all"
-license="GPL"
-subpackages="$pkgname-dev"
-depends=
-makedepends="glib-dev"
-source="http://www.gnome.org/~veillard/$pkgname/sources/$pkgname-$pkgver.tar.gz
- fix-deprecated-const.patch
- fix-pthread-mutex.patch"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- update_config_sub
- default_prepare
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-static \
- --with-threads \
- --without-python \
- --disable-debug-api \
- --disable-debug \
- --libexecdir=/usr/lib/gamin
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$_builddir"
- # some kinde of race in the make install which is not solved with -j
- export MKDIRPROG="mkdir -p"
- make DESTDIR="$pkgdir" install
-}
-
-md5sums="b4ec549e57da470c04edd5ec2876a028 gamin-0.1.10.tar.gz
-f679aeb48fe9dd376c8828cc9b6941ab fix-deprecated-const.patch
-f05a8d9fe30b6ce2871795c06d74edc4 fix-pthread-mutex.patch"
-sha256sums="28085f0ae8be10eab582ff186af4fb0be92cc6c62b5cc19cd09b295c7c2899a1 gamin-0.1.10.tar.gz
-33af6c9a94b459506fc48892c169d89cb4ad7c68e160f0c4bc74475f19ce5a2f fix-deprecated-const.patch
-bfd5ee42e385367718a4dac8ab318f9a5881ab8b669e4020f87aacaef16a2f8e fix-pthread-mutex.patch"
-sha512sums="21bfe6fcf8fb3117cd5a08c8ce3b8d0d1dd23e478e60a95b76c20d02cc29b050dde086578d81037990484ff891c3e104d2cbbf3d294b4a79346b14a0cae075bb gamin-0.1.10.tar.gz
-c4c10bee70c7231db395cbfe5bdf513ade6be599a11a9d35888ddfaca42d619fe2b5e87c2b2bab469ea98ba718bc01711252313ba5f53c392379b669f5b2902b fix-deprecated-const.patch
-70628fc39521ea8bc4a40b009d0881f6ee540334a31b2f0cb67dde0f75808c69feb78088ad24c3c4a0dec9fa59e87960fd81d1a2e56963ce9268d0a5e14f88e8 fix-pthread-mutex.patch"