summaryrefslogtreecommitdiff
path: root/system/gettext-tiny/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/gettext-tiny/APKBUILD')
-rw-r--r--system/gettext-tiny/APKBUILD31
1 files changed, 11 insertions, 20 deletions
diff --git a/system/gettext-tiny/APKBUILD b/system/gettext-tiny/APKBUILD
index 6edd0b4b3..ce62d5c99 100644
--- a/system/gettext-tiny/APKBUILD
+++ b/system/gettext-tiny/APKBUILD
@@ -1,42 +1,33 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gettext-tiny
-pkgver=0.3.0_pre1
-pkgrel=6
+pkgver=0.3.1_git20191130
+pkgrel=2
pkgdesc="An internationalisation and localisation system"
url="https://github.com/sabotage-linux/gettext-tiny"
arch="all"
options="!check" # No test suite.
license="MIT"
-depends="!gettext"
-depends_dev="!gettext-dev"
-install=""
+depends=""
+makedepends=""
subpackages="$pkgname-dev"
source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz
- omg-i-cant-believe-im-doing-ua-crap.patch
+ keyword.patch
+ line-length.patch
respect-cflags.patch
stop-doing-macro-crap.patch
- cpp-compat.patch
- double-stack-size.patch
- m4-installation.patch
- dynamic.patch
"
build() {
- cd "$builddir"
make LIBINTL=MUSL prefix=/usr
}
package() {
- cd "$builddir"
make LIBINTL=MUSL DESTDIR="$pkgdir" prefix=/usr install
}
-sha512sums="3795b9923f6820ce6e2c6a27480365a4ee1cb1f8f8916256887a40c8e0f0b582ada049a528330297f8daa1bff7d5877a15169095332456c57dc3fdb49407ef98 gettext-tiny-0.3.0_pre1.tar.xz
-2951ad99fd04ee7d8dc06b4de575b7838e350737e3b40ecd93eae9f6f2b4c15883a392370e25dfaf834a57bc801721894e946d24910cfd65c44c2e025321ade4 omg-i-cant-believe-im-doing-ua-crap.patch
-cea1596f3f20c8983e57d2e49e955a43ed2e261b244f6c4c2ae7d8b869e3cfce3bb87b0a17c16bdac59afd99703cef9c7ef4e93fca536bf1bf9aa5f9be9fa34f respect-cflags.patch
-d2a1a6b1f135c25172cf98dfed64739ff85f6016a31c3ce028b3a7aa72de0b55c1f9a54c5ba2c58817f5222c3d2a5bc3d03ec9058ae5fbae2c798df9227a4e52 stop-doing-macro-crap.patch
-0f1a1be10a038e6d30976f060c271e926f8f6b0541af7044f1b0ac2641825fc784ce3e3ff6ca13f3a5d15bbcd355a0999b60d4aa6f30c7b75254ca0edcaccc4d cpp-compat.patch
-331bd0442b400407d690cce4a90aac09acf64e1a26f9951dc1d1332cc29916987d34cc13bc13e84482c6950908cedad50f6aaf325f99118d769bb1286dd4db1b double-stack-size.patch
-090b685f6846b1cf4c266cbc982701283c7e30ddcbb1d3d263d50f83645ed168530db4bc03b6b688e46a32ac7ad09f0cd3f0e94f5c1a39e86d904f010353d91e m4-installation.patch
-06ca61de36d41ad9545c7c60e54fe0fe77eb67bb4902679f2828e7a14ad01cfc244b7b136e31debbb60d9dc9b4101b4f0463d46f95c263939017fd38fbe31b19 dynamic.patch"
+sha512sums="a318135626a0403a30a81fa475f7e1878b8af5a87053b0e00876c73b591508f3cf1e66d01f8d6a45013d1dc36a4da9f21fbf2b5050676826cb618b5b659aaaf7 gettext-tiny-0.3.1_git20191130.tar.xz
+8efbf9c11429ab26f3c15e00c34258200598833b8f846a23e4c8d95023c2184d9dcf9cbb48d58eec1604442691af76e6f8e904ad7348016c393257aa30eae7cd keyword.patch
+0a26a8481bffe2ce8c73f7f500963aea9db8379fb87849142d8efabf1656604b22f6ad345483256f14c388466f2f44e5924b9f65d88f26867a753a96d1529270 line-length.patch
+b4e7db4e415f6bc31f2214f2044506ad18ea0bd3cae4200d93bbd34aa493c7478a7f953d0a7e08f29f0fd5a5d7b7cbfa2bcfd5692c37e423706a1c193239bf1d respect-cflags.patch
+cd4cfc8cc6ea998f1e33ef666e3b9c3de3f3253994bccc942b177773c94f785e3892cb7d5f34bec1102dc7558236c07c5eac90e15d755e12ee06836336373526 stop-doing-macro-crap.patch"