summaryrefslogtreecommitdiff
path: root/system/gmp
diff options
context:
space:
mode:
Diffstat (limited to 'system/gmp')
-rw-r--r--system/gmp/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/system/gmp/APKBUILD b/system/gmp/APKBUILD
index 69f4b2c9c..ab8f1b70b 100644
--- a/system/gmp/APKBUILD
+++ b/system/gmp/APKBUILD
@@ -6,21 +6,19 @@ pkgdesc="A free library for arbitrary precision arithmetic"
url="https://gmplib.org/"
arch="all"
license="LGPL-3.0+ OR GPL-2.0+"
+depends=""
makedepends="m4 texinfo libtool"
-depends=
subpackages="$pkgname-doc $pkgname-dev libgmpxx"
source="https://gmplib.org/download/gmp/gmp-$pkgver.tar.xz
"
prepare() {
- cd "$builddir"
default_prepare
# force update to libtool with fixed cross-build support
libtoolize -f
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,12 +33,10 @@ build() {
}
package() {
- cd "$builddir"
make -j1 DESTDIR="${pkgdir}" install
}
check() {
- cd "$builddir"
[ "$CBUILD" = "$CHOST" ] && make check
}