summaryrefslogtreecommitdiff
path: root/system/heirloom-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'system/heirloom-devtools')
-rw-r--r--system/heirloom-devtools/APKBUILD38
-rw-r--r--system/heirloom-devtools/configure.patch54
-rw-r--r--system/heirloom-devtools/deauto.patch19
-rw-r--r--system/heirloom-devtools/heirloom-devtools-070527-64-bit.patch39
-rw-r--r--system/heirloom-devtools/heirloom-devtools-070527-solaris.patch230
-rw-r--r--system/heirloom-devtools/lex-compiler.patch11
-rw-r--r--system/heirloom-devtools/make-no-rpc.patch12
7 files changed, 403 insertions, 0 deletions
diff --git a/system/heirloom-devtools/APKBUILD b/system/heirloom-devtools/APKBUILD
new file mode 100644
index 000000000..974afd1e0
--- /dev/null
+++ b/system/heirloom-devtools/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=heirloom-devtools
+pkgver=070527
+pkgrel=1
+pkgdesc="Development tools compatible with UNIX"
+url="http://heirloom.sourceforge.net/devtools.html"
+arch="all"
+options="!check" # No test suite.
+license="CDDL-1.0"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev"
+source="https://superb-sea2.dl.sourceforge.net/project/heirloom/heirloom-devtools/$pkgver/heirloom-devtools-$pkgver.tar.bz2
+ configure.patch
+ deauto.patch
+ lex-compiler.patch
+ make-no-rpc.patch
+ $pkgname-$pkgver-solaris.patch
+ $pkgname-$pkgver-64-bit.patch"
+
+build() {
+ cd "$builddir"
+ make -j1 CXXFLAGS="${CXXFLAGS} -DMAXNETNAMELEN=255"
+}
+
+package() {
+ cd "$builddir"
+ make ROOT="$pkgdir" install
+}
+
+sha512sums="1f1f10a7b49402053172cc028bbd939a46fcf933994cb867fa40e8c5bbd7b1291575b3bac254cd79dc4fce3e3a2c88fe0f890449888fda16169c8e6a2540f055 heirloom-devtools-070527.tar.bz2
+d89c5b7490d11e6cab7491f7221f5b9f096b014dc3e9c642c6cc86660a6511303cc0c67df09cabfc820b34122cbed7fb672b7f8c59193d391cd87a40222aab64 configure.patch
+ebe4ae6af3b49290bdb50b396ff23973b3d6ba1429953563fe2b0e43312c1cca85dd754a140aa65bb2163a8307fd68a9dce3e3c4d1fa08d2d908e49df952f730 deauto.patch
+ac29808a3bd5439fe4d8e8765bddc4944951ac53c91cb24f60c117fe2441a234bd0d8c1dcc59ed996d9c220789cb03eade03ab858c07d673797fac295eb80b5a lex-compiler.patch
+b3c5d271f2edd5a8f331bfaf88b2f75a639cc79005c489d04fed90b2b6dfb1286dcc3084f0c7729519da06f0d0318c91f5e30c08f849c8c548b0b622221f4aba make-no-rpc.patch
+335fdabef9b9a8b93ffa6eab2b66d2db11af29b24989c4b64ea64695cfadd4471c31a865c2fcb823c1f4c11eebc1babb53ab83c9c2bdf83c05f497faf16e3f1c heirloom-devtools-070527-solaris.patch
+5523e670c9c9d57f0415e30d1aab4dfcd7d8ad74e2535136afbbe4c6e407c713e7801cbcbf7ddbe798ab2790fc196a2fdbf9d5295fa8c475c73360f5e3a27066 heirloom-devtools-070527-64-bit.patch"
diff --git a/system/heirloom-devtools/configure.patch b/system/heirloom-devtools/configure.patch
new file mode 100644
index 000000000..6d4652175
--- /dev/null
+++ b/system/heirloom-devtools/configure.patch
@@ -0,0 +1,54 @@
+--- heirloom-devtools-070527/mk.config.old 2007-05-27 11:56:51.000000000 -0500
++++ heirloom-devtools-070527/mk.config 2017-11-24 21:27:26.961471332 -0600
+@@ -17,12 +17,12 @@
+ #
+ # A BSD-compatible install command.
+ #
+-INSTALL=/usr/ucb/install
++INSTALL=/usr/bin/install
+
+ #
+ # Prefix.
+ #
+ PREFIX=/usr/ccs
+
+ #
+ # Where to place binaries.
+@@ -32,7 +32,7 @@
+ #
+ # Where to place additional binaries that aim at POSIX conformance.
+ #
+-SUSBIN=/usr/5bin/posix
++SUSBIN=/usr/5bin
+
+ #
+ # Where to place libraries.
+@@ -47,7 +47,7 @@
+ #
+ # Binaries are stripped with this command after installation.
+ #
+-STRIP=strip
++STRIP=true
+
+ #
+ # C++ compiler.
+@@ -57,8 +57,8 @@
+ #
+ # Compiler flags.
+ #
+-CFLAGS=-O
+-CXXFLAGS=-O
++CFLAGS ?= -O
++CXXFLAGS ?= -O
+
+ #
+ # C preprocessor flags.
+@@ -76,7 +76,7 @@
+ #
+ # Linker flags.
+ #
+-LDFLAGS=
++LDFLAGS ?=
+
+ #
+ # Additional libraries to link with.
diff --git a/system/heirloom-devtools/deauto.patch b/system/heirloom-devtools/deauto.patch
new file mode 100644
index 000000000..76e98f2d4
--- /dev/null
+++ b/system/heirloom-devtools/deauto.patch
@@ -0,0 +1,19 @@
+--- heirloom-devtools-070527/make/bsd/bsd.cc.old 2007-01-21 20:11:25.000000000 -0600
++++ heirloom-devtools-070527/make/bsd/bsd.cc 2017-12-12 04:18:01.749422384 -0600
+@@ -50,13 +50,13 @@
+ extern SIG_PF
+ bsdsignal (int Signal, SIG_PF Handler)
+ {
+- auto SIG_PF previous_handler;
++ SIG_PF previous_handler;
+ #ifdef SUN5_0
+ #ifdef sun
+ previous_handler = sigset (Signal, Handler);
+ #else
+- auto struct sigaction new_action;
+- auto struct sigaction old_action;
++ struct sigaction new_action;
++ struct sigaction old_action;
+
+ new_action.sa_flags = SA_SIGINFO;
+ new_action.sa_handler = (void (*) ()) Handler;
diff --git a/system/heirloom-devtools/heirloom-devtools-070527-64-bit.patch b/system/heirloom-devtools/heirloom-devtools-070527-64-bit.patch
new file mode 100644
index 000000000..d6c3cd7a5
--- /dev/null
+++ b/system/heirloom-devtools/heirloom-devtools-070527-64-bit.patch
@@ -0,0 +1,39 @@
+--- a/make/vroot/lock.cc 2007/01/18 15:06:32 1.1
++++ b/make/vroot/lock.cc 2007/10/01 11:44:26 1.2
+@@ -31,7 +31,7 @@
+ /*
+ * Portions Copyright (c) 2007 Gunnar Ritter, Freiburg i. Br., Germany
+ *
+- * Sccsid @(#)lock.cc 1.4 (gritter) 01/13/07
++ * Sccsid @(#)lock.cc 1.5 (gritter) 10/1/07
+ */
+
+ #include <avo/intl.h> /* for NOCATGETS */
+@@ -53,7 +53,7 @@
+ extern int sys_nerr;
+ #endif
+
+-static void file_lock_error(char *msg, char *file, char *str, int arg1, int arg2);
++static void file_lock_error(char *msg, char *file, char *str, const char *arg1, const char *arg2);
+
+ #define BLOCK_INTERUPTS sigfillset(&newset) ; \
+ sigprocmask(SIG_SETMASK, &newset, &oldset)
+@@ -123,7 +123,7 @@
+
+ if (errno != EEXIST) {
+ file_lock_error(msg, name, NOCATGETS("symlink(%s, %s)"),
+- (int) name, (int) lockname);
++ name, lockname);
+ fprintf(stderr, "%s", msg);
+ return errno;
+ }
+@@ -171,7 +171,8 @@
+ * Format a message telling why the lock could not be created.
+ */
+ static void
+-file_lock_error(char *msg, char *file, char *str, int arg1, int arg2)
++file_lock_error(char *msg, char *file, char *str,
++ const char *arg1, const char *arg2)
+ {
+ int len;
+
diff --git a/system/heirloom-devtools/heirloom-devtools-070527-solaris.patch b/system/heirloom-devtools/heirloom-devtools-070527-solaris.patch
new file mode 100644
index 000000000..c6b394208
--- /dev/null
+++ b/system/heirloom-devtools/heirloom-devtools-070527-solaris.patch
@@ -0,0 +1,230 @@
+diff --git a/make/include/mksh/defs.h b/make/include/mksh/defs.h
+index 1992205..8065a77 100644
+--- a/make/include/mksh/defs.h
++++ b/make/include/mksh/defs.h
+@@ -63,7 +63,6 @@
+ #include <widec.h>
+ #endif
+
+-#ifndef __sun
+ /*
+ * Definition of wchar functions.
+ */
+@@ -90,7 +89,6 @@
+ # define wscmp(x,y) wcscmp(x,y)
+ # undef wsncmp
+ # define wsncmp(x,y,z) wcsncmp(x,y,z)
+-#endif
+
+ #if defined (__FreeBSD__) || defined (__APPLE__) || defined (__hpux)
+ extern "C" { wchar_t *wcsdup(const wchar_t *s); }
+diff --git a/make/makestate/lock.c b/make/makestate/lock.c
+index cdf7562..aa6083e 100644
+--- a/make/makestate/lock.c
++++ b/make/makestate/lock.c
+@@ -42,18 +42,6 @@
+ #include <sys/errno.h>
+ #include <errno.h> /* errno */
+
+-#if defined(_LP64)
+-/*
+- * The symbols _sys_errlist and _sys_nerr are not visible in the
+- * LP64 libc. Use strerror(3C) instead.
+- */
+-#else /* #_LP64 */
+-#if defined (__sun) || defined (__hpux)
+-extern char * sys_errlist[];
+-extern int sys_nerr;
+-#endif
+-#endif /* #_LP64 */
+-
+ static void file_lock_error(char *, char *, const char *, char *, char *);
+
+ /*
+@@ -167,16 +155,7 @@ file_lock_error(char * msg, char * file, const char * str, char * arg1,
+ len = strlen(msg);
+ sprintf(&msg[len], str, arg1, arg2);
+ strcat(msg, " failed - ");
+-#if defined(_LP64)
+ /* Needs to be changed to use strerror(3C) instead. */
+ len = strlen(msg);
+ sprintf(&msg[len], "errno %d", errno);
+-#else /* #_LP64 */
+- if (errno < sys_nerr) {
+- strcat(msg, sys_errlist[errno]);
+- } else {
+- len = strlen(msg);
+- sprintf(&msg[len], "errno %d", errno);
+- }
+-#endif /* #_LP64 */
+ }
+diff --git a/make/mksh/macro.cc b/make/mksh/macro.cc
+index 6ddb624..23b0315 100644
+--- a/make/mksh/macro.cc
++++ b/make/mksh/macro.cc
+@@ -43,6 +43,7 @@
+ /*
+ * Included files
+ */
++#include <alloca.h>
+ #include <wordexp.h>
+ #include <mksh/dosys.h> /* sh_command2string() */
+ #include <mksh/i18n.h> /* get_char_semantics_value() */
+@@ -1403,13 +1404,6 @@ found_it:;
+ new_value = ALLOC_WC(length);
+ new_value_allocated = true;
+ WCSTOMBS(mbs_buffer, old_vr);
+-#ifdef __sun
+- wsprintf(new_value,
+- NOCATGETS("/usr/arch/%s/%s:%s"),
+- ha->string_mb + 1,
+- ta->string_mb + 1,
+- mbs_buffer);
+-#else
+ char * mbs_new_value = (char *)getmem(length);
+ sprintf(mbs_new_value,
+ NOCATGETS("/usr/arch/%s/%s:%s"),
+@@ -1418,7 +1412,6 @@ found_it:;
+ mbs_buffer);
+ MBSTOWCS(new_value, mbs_new_value);
+ retmem_mb(mbs_new_value);
+-#endif
+ }
+ if (new_value[0] != 0) {
+ setvar_daemon(virtual_root,
+diff --git a/make/mksh/misc.cc b/make/mksh/misc.cc
+index 11122cf..d617591 100644
+--- a/make/mksh/misc.cc
++++ b/make/mksh/misc.cc
+@@ -382,30 +382,7 @@ setup_char_semantics(void)
+ char *
+ errmsg(int errnum)
+ {
+-#ifndef __sun
+ return strerror(errnum);
+-#else // __sun
+-
+- extern int sys_nerr;
+-#ifdef SUN4_x
+- extern char *sys_errlist[];
+-#endif
+- char *errbuf;
+-
+- if ((errnum < 0) || (errnum > sys_nerr)) {
+- errbuf = getmem(6+1+11+1);
+- sprintf(errbuf, "Error %d", errnum);
+- return errbuf;
+- } else {
+-#ifdef SUN4_x
+- return(sys_errlist[errnum]);
+-#endif
+-#ifdef SUN5_0
+- return strerror(errnum);
+-#endif
+-
+- }
+-#endif // !__sun
+ }
+
+ extern const char *progname;
+diff --git a/make/src/implicit.cc b/make/src/implicit.cc
+index 2d388cc..a1cee7e 100644
+--- a/make/src/implicit.cc
++++ b/make/src/implicit.cc
+@@ -43,10 +43,13 @@
+ /*
+ * Included files
+ */
++#include <cstdio>
+ #include <mk/defs.h>
+ #include <mksh/macro.h> /* expand_value() */
+ #include <mksh/misc.h> /* retmem() */
+
++using std::printf;
++
+ /*
+ * Defined macros
+ */
+@@ -97,8 +100,6 @@ extern void add_target_to_chain(Name target, Chain * query);
+ * recursion_level Used for tracing
+ */
+
+-extern int printf (const char *, ...);
+-
+ static Boolean actual_doname = false;
+
+ /* /tolik/
+diff --git a/make/src/nse_printdep.cc b/make/src/nse_printdep.cc
+index 6201a18..38826d2 100644
+--- a/make/src/nse_printdep.cc
++++ b/make/src/nse_printdep.cc
+@@ -37,9 +37,12 @@
+ /*
+ * Included files
+ */
++#include <cstdio>
+ #include <mk/defs.h>
+ #include <mksh/misc.h> /* get_prop() */
+
++using std::printf;
++
+ /*
+ * File table of contents
+ */
+@@ -59,7 +62,6 @@ static void print_rule(register Name target);
+ static void print_rec_info(Name target);
+ static Boolean is_out_of_date(Property line);
+ extern void depvar_print_results (void);
+-extern int printf (const char *, ...);
+ extern int _flsbuf (unsigned int, FILE *);
+
+ /*
+diff --git a/make/vroot/lock.cc b/make/vroot/lock.cc
+index 1d6239b..1a20bc0 100644
+--- a/make/vroot/lock.cc
++++ b/make/vroot/lock.cc
+@@ -48,11 +48,6 @@
+ #include <signal.h>
+ #include <errno.h> /* errno */
+
+-#if defined(sun) || defined(HP_UX)
+-extern char *sys_errlist[];
+-extern int sys_nerr;
+-#endif
+-
+ static void file_lock_error(char *msg, char *file, char *str, int arg1, int arg2);
+
+ #define BLOCK_INTERUPTS sigfillset(&newset) ; \
+@@ -179,20 +174,6 @@ file_lock_error(char *msg, char *file, char *str, int arg1, int arg2)
+ len = strlen(msg);
+ sprintf(&msg[len], str, arg1, arg2);
+ strcat(msg, " failed - ");
+-#ifdef __sun
+- if (errno < sys_nerr) {
+-#ifdef SUN4_x
+- strcat(msg, sys_errlist[errno]);
+-#endif
+-#ifdef SUN5_0
+- strcat(msg, strerror(errno));
+-#endif
+- } else {
+- len = strlen(msg);
+- sprintf(&msg[len], NOCATGETS("errno %d"), errno);
+- }
+-#else
+ strcat(msg, strerror(errno));
+-#endif
+ }
+
+diff --git a/sccs/src/vc.c b/sccs/src/vc.c
+index d7f7187..1c0ffb1 100644
+--- a/sccs/src/vc.c
++++ b/sccs/src/vc.c
+@@ -37,6 +37,7 @@
+ */
+ /* from OpenSolaris "sccs:cmd/vc.c" */
+ # include <defines.h>
++# include <limits.h>
+ # include <locale.h>
+
+
diff --git a/system/heirloom-devtools/lex-compiler.patch b/system/heirloom-devtools/lex-compiler.patch
new file mode 100644
index 000000000..e0d6e9967
--- /dev/null
+++ b/system/heirloom-devtools/lex-compiler.patch
@@ -0,0 +1,11 @@
+--- heirloom-devtools-070527/lex/sub1.c.old 2005-11-26 12:50:23.000000000 -0600
++++ heirloom-devtools-070527/lex/sub1.c 2017-12-12 04:13:27.493347227 -0600
+@@ -162,7 +162,8 @@
+ }
+
++#undef index
+ int
+ index(int a, CHR *s)
+ {
+ int k;
+ for (k = 0; s[k]; k++)
diff --git a/system/heirloom-devtools/make-no-rpc.patch b/system/heirloom-devtools/make-no-rpc.patch
new file mode 100644
index 000000000..d80dd05dc
--- /dev/null
+++ b/system/heirloom-devtools/make-no-rpc.patch
@@ -0,0 +1,12 @@
+--- heirloom-devtools-070527/make/src/pmake.cc.old 2007-01-18 09:34:13.000000000 -0600
++++ heirloom-devtools-070527/make/src/pmake.cc 2017-12-12 04:21:31.058974256 -0600
+@@ -46,7 +46,9 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <sys/utsname.h>
++#ifdef _sun
+ #include <rpc/rpc.h> /* host2netname(), netname2host() */
++#endif
+ #include <unistd.h> /* getdomainname() */
+
+ /*