summaryrefslogtreecommitdiff
path: root/system/inih/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/inih/APKBUILD')
-rw-r--r--system/inih/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/system/inih/APKBUILD b/system/inih/APKBUILD
new file mode 100644
index 000000000..9d701cd95
--- /dev/null
+++ b/system/inih/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=inih
+pkgver=58
+pkgrel=0
+pkgdesc="Simple .INI file parser in C"
+url=" "
+arch="all"
+license="BSD-3-Clause"
+depends=""
+makedepends="meson"
+subpackages="$pkgname-dev"
+source="https://github.com/benhoyt/inih/archive/r58/$pkgname-$pkgver.tar.gz
+ testrun.patch
+ "
+builddir="$srcdir/inih-r58"
+
+build() {
+ meson setup \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ --wrap-mode=nofallback \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C output
+}
+
+sha512sums="d69f488299c1896e87ddd3dd20cd9db5848da7afa4c6159b8a99ba9a5d33f35cadfdb9f65d6f2fe31decdbadb8b43bf610ff2699df475e1f9ff045e343ac26ae inih-58.tar.gz
+88f38fa41efa91a3eeef065251a6424fdfbb6d4ed975dfcce4730374f61f328ca2b13f3db123eed2c5ade9e54c1f797481dbcb284b22554dd89068053ead1035 testrun.patch"