summaryrefslogtreecommitdiff
path: root/system/itstool/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/itstool/APKBUILD')
-rw-r--r--system/itstool/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/system/itstool/APKBUILD b/system/itstool/APKBUILD
new file mode 100644
index 000000000..c4fee9e06
--- /dev/null
+++ b/system/itstool/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=itstool
+pkgver=2.0.6
+pkgrel=0
+pkgdesc="ITS-based XML translation tool"
+url="http://itstool.org/"
+arch="noarch"
+license="GPL-3.0+"
+depends="py3-libxml2 python3"
+makedepends=""
+subpackages="$pkgname-doc"
+source="http://files.itstool.org/itstool/$pkgname-$pkgver.tar.bz2
+ fix-segfault.patch"
+
+build() {
+ PYTHON="/usr/bin/python3" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+ # verify that the shebang is correct
+ chmod +x itstool
+ ./itstool
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="51058bdcb208f6fb84810f71f9bf67e42b00bf157a9756be45f060849c0aff36f695f4403404193720d4446818fa77de61fa94eed9e8789d26c07a2926072eb7 itstool-2.0.6.tar.bz2
+eb426e7cc9f151154f47b93ef46d6fcfb5fa0982be3bf78863ebf5ea009a89de252a6c63dfb090d76003c47107ebb5d1ac2a7d1ef7db08defe19e32f996dbdbd fix-segfault.patch"