summaryrefslogtreecommitdiff
path: root/system/libaio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/libaio/APKBUILD')
-rw-r--r--system/libaio/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/system/libaio/APKBUILD b/system/libaio/APKBUILD
index b40b031aa..7423a10d7 100644
--- a/system/libaio/APKBUILD
+++ b/system/libaio/APKBUILD
@@ -2,20 +2,21 @@
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname="libaio"
pkgver=0.3.111
-pkgrel=0
+pkgrel=1
pkgdesc="Asynchronous input/output library"
url="http://lse.sourceforge.net/io/aio.html"
arch="all"
license="LGPL-2.1+"
-depends=
+depends=""
makedepends="linux-headers"
-install=
subpackages="$pkgname-dev"
-source="http://ftp.debian.org/debian/pool/main/liba/$pkgname/${pkgname}_${pkgver}.orig.tar.gz"
+source="http://ftp.debian.org/debian/pool/main/liba/$pkgname/${pkgname}_${pkgver}.orig.tar.gz
+ improper-strncpy-usage.patch
+ "
build() {
cd "$builddir"
- make
+ make LDFLAGS="$LDFLAGS -lssp_nonshared"
}
check() {
@@ -29,4 +30,5 @@ package() {
make prefix="$pkgdir/usr" install
}
-sha512sums="440f2b62f99ca2e72ffc8c2c04b4779a1a7cf24a8ba2a30b34d18b4ee77630a2078610fe8c435559f81a5c3bfa93049bd53d77464a0da8267833fbde3f40ceeb libaio_0.3.111.orig.tar.gz"
+sha512sums="440f2b62f99ca2e72ffc8c2c04b4779a1a7cf24a8ba2a30b34d18b4ee77630a2078610fe8c435559f81a5c3bfa93049bd53d77464a0da8267833fbde3f40ceeb libaio_0.3.111.orig.tar.gz
+8294a17b60676838375b3f17b84af19f3f3224788bdc944eda6b235305f48b6b292899f9d528be7b4b87305e7beac409afc0f250d052454b2a739bd990104b83 improper-strncpy-usage.patch"