summaryrefslogtreecommitdiff
path: root/system/libarchive/revert-autotools-Fix-static-linking-when-openssl-is-.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/libarchive/revert-autotools-Fix-static-linking-when-openssl-is-.patch')
-rw-r--r--system/libarchive/revert-autotools-Fix-static-linking-when-openssl-is-.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/system/libarchive/revert-autotools-Fix-static-linking-when-openssl-is-.patch b/system/libarchive/revert-autotools-Fix-static-linking-when-openssl-is-.patch
new file mode 100644
index 000000000..24acd4080
--- /dev/null
+++ b/system/libarchive/revert-autotools-Fix-static-linking-when-openssl-is-.patch
@@ -0,0 +1,49 @@
+From 57b52cb8b54ec57d72ed0ccacacc1f6506749d17 Mon Sep 17 00:00:00 2001
+From: Zach van Rijn <me@zv.io>
+Date: Tue, 11 Apr 2023 17:14:18 -0500
+Subject: [PATCH] Revert "autotools: Fix static linking when openssl is enabled
+ in windows"
+
+This reverts commit a83f3d327aefe8d628230f326621b014d82f55b4.
+
+diff --git a/build/pkgconfig/libarchive.pc.in b/build/pkgconfig/libarchive.pc.in
+index 1f51e77f..4b631e63 100644
+--- a/build/pkgconfig/libarchive.pc.in
++++ b/build/pkgconfig/libarchive.pc.in
+@@ -10,4 +10,3 @@ Cflags: -I${includedir}
+ Cflags.private: -DLIBARCHIVE_STATIC
+ Libs: -L${libdir} -larchive
+ Libs.private: @LIBS@
+-Requires.private: @LIBSREQUIRED@
+diff --git a/configure.ac b/configure.ac
+index 349e7580..d60f66fb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -378,7 +378,6 @@ if test "x$with_iconv" != "xno"; then
+ AC_CHECK_HEADERS([localcharset.h])
+ am_save_LIBS="$LIBS"
+ LIBS="${LIBS} ${LIBICONV}"
+- LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
+ AC_CHECK_FUNCS([locale_charset])
+ LIBS="${am_save_LIBS}"
+ if test "x$ac_cv_func_locale_charset" != "xyes"; then
+@@ -1210,7 +1209,6 @@ fi
+ if test "x$with_openssl" != "xno"; then
+ AC_CHECK_HEADERS([openssl/evp.h])
+ saved_LIBS=$LIBS
+- LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }libssl libcrypto"
+ AC_CHECK_LIB(crypto,OPENSSL_config)
+ CRYPTO_CHECK(MD5, OPENSSL, md5)
+ CRYPTO_CHECK(RMD160, OPENSSL, rmd160)
+@@ -1221,8 +1219,6 @@ if test "x$with_openssl" != "xno"; then
+ AC_CHECK_FUNCS([PKCS5_PBKDF2_HMAC_SHA1])
+ fi
+
+-AC_SUBST(LIBSREQUIRED)
+-
+ # Probe libmd AFTER OpenSSL/libcrypto.
+ # The two are incompatible and OpenSSL is more complete.
+ AC_CHECK_HEADERS([md5.h ripemd.h sha.h sha256.h sha512.h])
+--
+2.25.1
+