summaryrefslogtreecommitdiff
path: root/system/libedit
diff options
context:
space:
mode:
Diffstat (limited to 'system/libedit')
-rw-r--r--system/libedit/APKBUILD15
-rw-r--r--system/libedit/tinfo.patch30
2 files changed, 42 insertions, 3 deletions
diff --git a/system/libedit/APKBUILD b/system/libedit/APKBUILD
index f5d3bf0d2..899ee01ab 100644
--- a/system/libedit/APKBUILD
+++ b/system/libedit/APKBUILD
@@ -9,12 +9,20 @@ arch="all"
license="BSD-2-Clause"
depends=""
depends_dev="ncurses-dev" # XXX is this always unconditionally needed?
-makedepends="$depends_dev"
+makedepends="$depends_dev autoconf automake"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://thrysoee.dk/editline/libedit-20180525-3.1.tar.gz"
+source="http://thrysoee.dk/editline/libedit-20180525-3.1.tar.gz
+ tinfo.patch
+ "
builddir="$srcdir/$pkgname-20180525-3.1"
+prepare() {
+ cd "$builddir"
+ default_prepare
+ autoreconf -v -f --install
+}
+
build() {
cd "$builddir"
./configure \
@@ -37,4 +45,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="63b4dae3f0a71714ba66c074d6cf9b49dbc82dd795f1290ca978cfe3cb57944dffb6d89d275f9bbb200b4672b5a1101d9e62ebf492a83bb7f795b2e4d9d3d2ea libedit-20180525-3.1.tar.gz"
+sha512sums="63b4dae3f0a71714ba66c074d6cf9b49dbc82dd795f1290ca978cfe3cb57944dffb6d89d275f9bbb200b4672b5a1101d9e62ebf492a83bb7f795b2e4d9d3d2ea libedit-20180525-3.1.tar.gz
+b9cfb07733d14339cfb053b5c4249b74486268005474f65f377e412e5cccbe29d3ce55663a9795db0b682155084cca5a9424de348c7defdc8698dea042c2a674 tinfo.patch"
diff --git a/system/libedit/tinfo.patch b/system/libedit/tinfo.patch
new file mode 100644
index 000000000..597529ca8
--- /dev/null
+++ b/system/libedit/tinfo.patch
@@ -0,0 +1,30 @@
+From 7aa660fd9d446567d3280765ba2a50a46b2a9159 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 12 Jun 2017 21:36:54 +0200
+Subject: [PATCH] configure: Support -ltinfo as split in newer ncurses
+
+The newer versions of ncurses support building terminfo routines
+as a split -ltinfo library. Account for that by adding this library
+to the search list.
+---
+ configure.ac | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9a571b2..5d714b5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -49,7 +49,9 @@ EL_MANTYPE
+ AC_CHECK_LIB(ncurses, tgetent,,
+ [AC_CHECK_LIB(curses, tgetent,,
+ [AC_CHECK_LIB(termcap, tgetent,,
+- [AC_MSG_ERROR([libncurses, libcurses, or libtermcap is required!])]
++ [AC_CHECK_LIB(tinfo, tgetent,,
++ [AC_MSG_ERROR([libncurses, libcurses, libtermcap, or libtinfo is required!])]
++ )]
+ )]
+ )]
+ )
+--
+2.13.1
+