summaryrefslogtreecommitdiff
path: root/system/libelf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/libelf/APKBUILD')
-rw-r--r--system/libelf/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/system/libelf/APKBUILD b/system/libelf/APKBUILD
new file mode 100644
index 000000000..7ba1a6cc0
--- /dev/null
+++ b/system/libelf/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=libelf
+pkgver=0.8.13
+pkgrel=4
+pkgdesc="ELF object file access library"
+url="http://www.mr511.de/software/"
+arch="all"
+license="LGPL-2.0+"
+depends=
+makedepends=
+subpackages="$pkgname-dev"
+source="http://www.mr511.de/software/$pkgname-$pkgver.tar.gz"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-shared \
+ --enable-gnu-names \
+ --enable-compat
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install prefix="$pkgdir"/usr
+}
+sha512sums="d2a4ea8ccc0bbfecac38fa20fbd96aefa8e86f8af38691fb6991cd9c5a03f587475ecc2365fc89a4954c11a679d93460ee9a5890693112f6133719af3e6582fe libelf-0.8.13.tar.gz"