summaryrefslogtreecommitdiff
path: root/system/linux-headers/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/linux-headers/APKBUILD')
-rw-r--r--system/linux-headers/APKBUILD43
1 files changed, 16 insertions, 27 deletions
diff --git a/system/linux-headers/APKBUILD b/system/linux-headers/APKBUILD
index 67afac211..9f39bf5b0 100644
--- a/system/linux-headers/APKBUILD
+++ b/system/linux-headers/APKBUILD
@@ -1,26 +1,23 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=linux-headers
-pkgver=4.4.6
-_kernver=${pkgver%.*}
-pkgrel=2
+pkgver=4.14.48
+pkgrel=8
pkgdesc="Linux system headers"
-url="http://kernel.org"
+url="https://kernel.org"
arch="all"
+options="!check !dbg !strip !tracedeps" # Headers only
license="GPL-2.0-only"
makedepends="perl"
-options="!check !dbg !strip !tracedeps"
-source="https://kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
- https://kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
- 0001-libc-compat.h-fix-some-issues-arising-from-in6.h.patch
- 0002-libc-compat.h-prevent-redefinition-of-struct-ethhdr.patch
- 0003-remove-inclusion-of-sysinfo.h-in-kernel.h.patch
+source="https://kernel.org/pub/linux/kernel/v4.x/linux-4.14.tar.xz
+ https://distfiles.adelielinux.org/source/linux-4.14-mc$pkgrel.patch.xz
"
+builddir="$srcdir/linux-4.14"
prepare() {
- cd "$srcdir"/linux-$_kernver
- if [ "$_kernver" != "$pkgver" ]; then
- unxz -c < "$srcdir"/patch-$pkgver.xz | patch -p1 || return 1
- fi
+ cd "$srcdir"
+ cat linux-4.14-mc$pkgrel.patch.xz | unxz -> linux-4.14-mc$pkgrel.patch
+ cd "$builddir"
+ patch -Np1 <../linux-4.14-mc$pkgrel.patch
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -28,10 +25,6 @@ prepare() {
done
}
-build() {
- return 0
-}
-
package() {
local _carch=$CARCH
@@ -41,12 +34,11 @@ package() {
mips*) _carch="mips" ;;
s390*) _carch="s390" ;;
ppc*) _carch="powerpc" ;;
-# not sure about this -- ppc64*) _carch="powerpc64" ;;
esac
- cd "$srcdir"/linux-$_kernver
+ cd "$builddir"
mkdir -p "$pkgdir/usr"
- make headers_install ARCH="${_carch}" INSTALL_HDR_PATH="$pkgdir/usr" || return 1
+ make headers_install ARCH="${_carch}" INSTALL_HDR_PATH="$pkgdir/usr"
find "$pkgdir/usr" \( -name .install -o -name ..install.cmd \) -exec \
rm -f {} \;
@@ -55,8 +47,5 @@ package() {
rm -rf "$pkgdir"/usr/include/drm
}
-sha512sums="13c8459933a8b80608e226a1398e3d1848352ace84bcfb7e6a4a33cb230bbe1ab719d4b58e067283df91ce5311be6d2d595fc8c19e2ae6ecc652499415614b3e linux-4.4.tar.xz
-73da057476eb31d818eed4b66c883f5ceec65f18ec8ea60d64e48334c7681af4ed4cf7eb8684481f705446a59fd124de9449d22e28805bc9617b6608ecec491d patch-4.4.6.xz
-6ceaaa285bcc7699b72f07f04c018d8edc2e1a2860004c677da6ff8ca042fcecd37f7f264d8ec9783e4e2f60a91bd45ddc432f7ec063da1e3f4e9dfb75b5ba65 0001-libc-compat.h-fix-some-issues-arising-from-in6.h.patch
-fbce0bf59dd8ed3da8d90db725e98ace410f1e1a71b1c2e0ef16c53327e3850019b4e52afb1b16115a8616492a1e758fab02158ea686113b1b6cd94c7b08f310 0002-libc-compat.h-prevent-redefinition-of-struct-ethhdr.patch
-e5431719b3910162c17c7a46e296c4424f5b82f4ad4bc45ba933da7e7ebcf896bb98782f7764e584c573c49d9e6b00fe63f3a36ae4b3b137add6b9a21ddf14a0 0003-remove-inclusion-of-sysinfo.h-in-kernel.h.patch"
+sha512sums="77e43a02d766c3d73b7e25c4aafb2e931d6b16e870510c22cef0cdb05c3acb7952b8908ebad12b10ef982c6efbe286364b1544586e715cf38390e483927904d8 linux-4.14.tar.xz
+3fe2da1714cc83d909ba43d27c7f22ef4f2a6ecfd91ff81e0e141a0dd742ec78ad11392186871762f410615ae7c7f33dd814e0f194c7f7aed1dee2d9fca0252d linux-4.14-mc8.patch.xz"