summaryrefslogtreecommitdiff
path: root/system/make/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/make/APKBUILD')
-rw-r--r--system/make/APKBUILD5
1 files changed, 0 insertions, 5 deletions
diff --git a/system/make/APKBUILD b/system/make/APKBUILD
index 725ce49ae..944f1c8b3 100644
--- a/system/make/APKBUILD
+++ b/system/make/APKBUILD
@@ -5,7 +5,6 @@ pkgrel=2
pkgdesc="GNU make utility to maintain groups of programs"
url="https://www.gnu.org/software/make"
arch="all"
-options="!checkroot"
license="GPL-3.0+"
depends=""
checkdepends="perl"
@@ -15,13 +14,11 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2
"
prepare() {
- cd "$builddir"
update_config_sub
default_prepare
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
[ "$CBUILD" != "$CHOST" ] || (ulimit -n 64 && PERL5LIB=. make check) || return 1
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}