summaryrefslogtreecommitdiff
path: root/system/mpc1
diff options
context:
space:
mode:
Diffstat (limited to 'system/mpc1')
-rw-r--r--system/mpc1/APKBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/system/mpc1/APKBUILD b/system/mpc1/APKBUILD
index a0c516857..f90ee06ed 100644
--- a/system/mpc1/APKBUILD
+++ b/system/mpc1/APKBUILD
@@ -6,17 +6,14 @@ pkgdesc="Multiprecision C library"
url="http://www.multiprecision.org/"
arch="all"
license="LGPL-3.0+"
-depends=
+depends=""
makedepends_host="gmp-dev mpfr-dev"
makedepends="$makedepends_host"
-install=
subpackages="$pkgname-dev $pkgname-doc"
source="https://ftp.gnu.org/gnu/mpc/mpc-$pkgver.tar.gz"
-
builddir="$srcdir"/mpc-$pkgver
build() {
- cd "$builddir"
# workaround for a bug in configure script
EGREP=egrep \
./configure \
@@ -32,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}