summaryrefslogtreecommitdiff
path: root/system/mutt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/mutt/APKBUILD')
-rw-r--r--system/mutt/APKBUILD61
1 files changed, 0 insertions, 61 deletions
diff --git a/system/mutt/APKBUILD b/system/mutt/APKBUILD
deleted file mode 100644
index 2b3424421..000000000
--- a/system/mutt/APKBUILD
+++ /dev/null
@@ -1,61 +0,0 @@
-# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Contributor: Andrew Manison<amanison@anselsystems.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=mutt
-pkgver=1.9.1
-pkgrel=0
-pkgdesc="a small but very powerful text-mode email client"
-url="http://www.mutt.org"
-arch="all"
-license="GPL"
-makedepends="cyrus-sasl-dev gdbm-dev gettext-dev gpgme-dev
- libidn-dev ncurses-dev openssl-dev perl"
-options="suid !check"
-subpackages="$pkgname-doc $pkgname-lang"
-source="https://bitbucket.org/$pkgname/$pkgname/downloads/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
-
-build() {
- cd "$builddir"
- ISPELL=/usr/bin/hunspell \
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --enable-imap \
- --enable-pop \
- --enable-smtp \
- --enable-hcache \
- --enable-gpgme \
- --enable-sidebar \
- --enable-smime \
- --with-curses \
- --with-mailpath=/var/spool/mail \
- --with-docdir=/usr/share/doc/$pkgname \
- --without-included-gettext \
- --with-ssl \
- --with-sasl
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-
- rm "$pkgdir"/etc/*.dist \
- "$pkgdir"/etc/mime.types \
- "$pkgdir"/usr/bin/muttbug \
- "$pkgdir"/usr/bin/flea
-
- # Don't tamper with the global configuration file.
- # Many options set in the global config cannot be
- # overwritten in the users configuration file.
- # Example: Resetting colors isn't possible.
- install -Dm644 contrib/gpg.rc \
- "$pkgdir"/etc/Muttrc.gpg.dist
-}
-
-sha512sums="1a6871eb8499c60ae18b03d56b81e64de1643c68f8fbe05bbe114085b20098be58175e5bd6d2515e8332a824cbed75640744a261d4f10654c56625f903224095 mutt-1.9.1.tar.gz"