summaryrefslogtreecommitdiff
path: root/system/ncurses/ncurses-6.3-20220319.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/ncurses/ncurses-6.3-20220319.patch')
-rw-r--r--system/ncurses/ncurses-6.3-20220319.patch327
1 files changed, 327 insertions, 0 deletions
diff --git a/system/ncurses/ncurses-6.3-20220319.patch b/system/ncurses/ncurses-6.3-20220319.patch
new file mode 100644
index 000000000..ca0501c09
--- /dev/null
+++ b/system/ncurses/ncurses-6.3-20220319.patch
@@ -0,0 +1,327 @@
+# ncurses 6.3 - patch 20220319 - Thomas E. Dickey
+#
+# ------------------------------------------------------------------------------
+#
+# Ncurses 6.3 is at
+# ftp://ftp.invisible-island.net/ncurses/
+# https://invisible-mirror.net/archives/ncurses/
+# https://ftp.gnu.org/gnu/ncurses/
+#
+# Patches for ncurses 6.3 can be found at
+# ftp://ftp.invisible-island.net/ncurses/6.3
+# https://invisible-mirror.net/archives/ncurses/6.3
+#
+# ------------------------------------------------------------------------------
+# ftp://ftp.invisible-island.net/ncurses/6.3/ncurses-6.3-20220319.patch.gz
+# patch by Thomas E. Dickey <dickey@invisible-island.net>
+# created Sun Mar 20 00:45:48 UTC 2022
+# ------------------------------------------------------------------------------
+# NEWS | 9 +++++-
+# VERSION | 2 -
+# dist.mk | 4 +-
+# misc/terminfo.src | 52 ++++++++++++++++++++++++++++++-------
+# package/debian-mingw/changelog | 4 +-
+# package/debian-mingw64/changelog | 4 +-
+# package/debian/changelog | 4 +-
+# package/mingw-ncurses.nsi | 4 +-
+# package/mingw-ncurses.spec | 2 -
+# package/ncurses.spec | 2 -
+# package/ncursest.spec | 2 -
+# progs/tic.c | 8 ++++-
+# 12 files changed, 71 insertions(+), 26 deletions(-)
+# ------------------------------------------------------------------------------
+Index: NEWS
+Prereq: 1.3786
+--- ncurses-6.3-20220312+/NEWS 2022-03-12 19:32:10.000000000 +0000
++++ ncurses-6.3-20220319/NEWS 2022-03-20 00:18:08.000000000 +0000
+@@ -26,7 +26,7 @@
+ -- sale, use or other dealings in this Software without prior written --
+ -- authorization. --
+ -------------------------------------------------------------------------------
+--- $Id: NEWS,v 1.3786 2022/03/12 19:32:10 tom Exp $
++-- $Id: NEWS,v 1.3788 2022/03/20 00:18:08 tom Exp $
+ -------------------------------------------------------------------------------
+
+ This is a log of changes that ncurses has gone through since Zeyd started
+@@ -46,6 +46,13 @@
+ Changes through 1.9.9e did not credit all contributions;
+ it is not possible to add this information.
+
++20220319
++ + add xgterm -TD
++ + correct setal in mintty/tmux entries, add to vte-2018 (report by
++ Robert Lange)
++ + add blink to vte-2018 (report by Robert Lange)
++ + improve tic warning about XT versus redundant tsl, etc.
++
+ 20220312
+ + add xterm+acs building-block -TD
+ + add xterm-p370, for use in older terminals -TD
+Index: VERSION
+--- ncurses-6.3-20220312+/VERSION 2022-03-12 11:56:09.000000000 +0000
++++ ncurses-6.3-20220319/VERSION 2022-03-19 11:19:25.000000000 +0000
+@@ -1 +1 @@
+-5:0:10 6.3 20220312
++5:0:10 6.3 20220319
+Index: dist.mk
+Prereq: 1.1470
+--- ncurses-6.3-20220312+/dist.mk 2022-03-12 11:56:09.000000000 +0000
++++ ncurses-6.3-20220319/dist.mk 2022-03-19 11:19:25.000000000 +0000
+@@ -26,7 +26,7 @@
+ # use or other dealings in this Software without prior written #
+ # authorization. #
+ ##############################################################################
+-# $Id: dist.mk,v 1.1470 2022/03/12 11:56:09 tom Exp $
++# $Id: dist.mk,v 1.1471 2022/03/19 11:19:25 tom Exp $
+ # Makefile for creating ncurses distributions.
+ #
+ # This only needs to be used directly as a makefile by developers, but
+@@ -38,7 +38,7 @@
+ # These define the major/minor/patch versions of ncurses.
+ NCURSES_MAJOR = 6
+ NCURSES_MINOR = 3
+-NCURSES_PATCH = 20220312
++NCURSES_PATCH = 20220319
+
+ # We don't append the patch to the version, since this only applies to releases
+ VERSION = $(NCURSES_MAJOR).$(NCURSES_MINOR)
+Index: misc/terminfo.src
+--- ncurses-6.3-20220312+/misc/terminfo.src 2022-03-12 19:04:55.000000000 +0000
++++ ncurses-6.3-20220319/misc/terminfo.src 2022-03-20 00:10:41.000000000 +0000
+@@ -6,8 +6,8 @@
+ # Report bugs and new terminal descriptions to
+ # bug-ncurses@gnu.org
+ #
+-# $Revision: 1.981 $
+-# $Date: 2022/03/12 19:04:55 $
++# $Revision: 1.985 $
++# $Date: 2022/03/20 00:10:41 $
+ #
+ # The original header is preserved below for reference. It is noted that there
+ # is a "newer" version which differs in some cosmetic details (but actually
+@@ -4233,9 +4233,7 @@
+ setal=\E[5%p1%dm, use=xterm+256color,
+ use=mintty+common,
+ mintty-direct|Cygwin Terminal direct-color,
+- setal=\E[%?%p1%{8}%<%t5%p1%d%e58:2::%p1%{65536}%/%d:%p1
+- %{256}%/%{255}%&%d:%p1%{255}%&%d%;m,
+- use=xterm+direct, use=mintty+common,
++ use=kitty+setal, use=xterm+direct, use=mintty+common,
+ mintty+common|shared capabilities for mintty,
+ km@, npc,
+ kcbt=\E[Z, kent=\EOM, rmm@, rmpch=\E[10m,
+@@ -4659,6 +4657,7 @@
+ sgr0=\E[m, smir=\E[4h, smkx=\E[?1h\E=, smso=\E[7m,
+ smul=\E[4m, tbc=\E[3g, use=vt220+pcedit, use=vt100+enq,
+ use=xterm+kbs,
++
+ # Compatible with the R6 xterm
+ # (from XFree86 3.2 distribution, <acsc> and <it> added, <blink@> removed)
+ # added khome/kend, hts based on the R6 xterm code - TD
+@@ -5813,6 +5812,30 @@
+ smcup=\E[?1;41s\E[?1;41h\E=, smir=\E[4h, smso=\E[7m,
+ smul=\E[4m, use=ecma+color, use=vt220+keypad,
+
++# The IRAF source has a terminfo using "xterm-r5", but line-drawing does not
++# work in that case. This entry uses xterm+acs, to work around that problem.
++#
++# Home/end keys do not work, due to a bug in the X Consortium xterm on which
++# this is based:
++#
++# https://invisible-island.net/xterm/xterm.faq.html#bug_xterm_r6
++#
++# Comparing to the X11R5 source, xgterm has dynamic and ANSI colors (probably
++# not bce). It interchanges mouse buttons 2/3 for menus.
++#
++# It also has a few features found in later versions of xterm:
++# - vi-button and dired-button,
++# - i18n stuff like X11R6.
++# - colorBD, colorUL
++# - scrollBarRight
++#
++# Debian provides a package for xgterm (and iraf). Although the source for
++# xgterm implements the control-sequences for ANSI color, the packaged xgterm
++# does nothing with those, even after installing the app-defaults file which
++# was overlooked by the Debian packager.
++xgterm|graphic terminal for IRAF,
++ use=xterm+acs, use=xterm-r5, use=xterm+keypad,
++
+ # The 'nxterm' distributed with Redhat Linux 5.2 is a slight rehack of
+ # xterm-sb_right-ansi-3d, which implements ANSI colors, but does not support
+ # SGR 39 or 49. SGR 0 does reset colors (along with everything else). This
+@@ -6031,8 +6054,11 @@
+ # 2018, respectively. Overline (Smol/Rmol) has been supported since December
+ # 2017.
+ vte-2018|VTE 0.51.2,
++ blink=\E[5m, enacs=\E(B\E)0,
++ sgr=\E[0%?%p6%t;1%;%?%p2%t;4%;%?%p4%t;5%;%?%p5%t;2%;%?%p7%t;
++ 8%;%?%p1%p3%|%t;7%;m%?%p9%t\016%e\017%;,
+ Rmol=\E[55m, Smol=\E[53m, Smulx=\E[4:%p1%dm,
+- use=vte-2017,
++ use=kitty+setal, use=vte-2017,
+
+ vte|VTE aka GNOME Terminal,
+ use=vte-2018,
+@@ -7677,6 +7703,10 @@
+ use=ecma+strikeout, use=ecma+italics,
+ use=xterm+alt1049, use=att610+cvis, use=xterm+tmux,
+
++kitty+setal|set underline colors (nonstandard),
++ setal=\E[58:2::%p1%{65536}%/%d:%p1%{256}%/%{255}%&%d:%p1
++ %{255}%&%dm,
++
+ ######## WAYLAND CLIENTS
+
+ #### Foot
+@@ -8235,9 +8265,7 @@
+ use=xterm+256setaf, use=tmux,
+
+ tmux-direct|tmux with direct-color indexing,
+- setal=\E[%?%p1%{8}%<%t5%p1%d%e58:2::%p1%{65536}%/%d:%p1
+- %{256}%/%{255}%&%d:%p1%{255}%&%d%;m,
+- use=xterm+direct, use=tmux,
++ use=kitty+setal, use=xterm+direct, use=tmux,
+
+ #### Mosh
+ # https://mosh.org/
+@@ -27403,4 +27431,10 @@
+ # + add dec+sl to xterm-new, per patch #371 -TD
+ # + add mosh and mosh-256color -TD
+ #
++# 2022-03-19
++# + add xgterm -TD
++# + correct setal in mintty/tmux entries, add to vte-2018 (report by
++# Robert Lange)
++# + add blink to vte-2018 (report by Robert Lange)
++#
+ ######## SHANTIH! SHANTIH! SHANTIH!
+Index: package/debian-mingw/changelog
+--- ncurses-6.3-20220312+/package/debian-mingw/changelog 2022-03-12 11:56:09.000000000 +0000
++++ ncurses-6.3-20220319/package/debian-mingw/changelog 2022-03-19 11:19:25.000000000 +0000
+@@ -1,8 +1,8 @@
+-ncurses6 (6.3+20220312) unstable; urgency=low
++ncurses6 (6.3+20220319) unstable; urgency=low
+
+ * latest weekly patch
+
+- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 12 Mar 2022 06:56:09 -0500
++ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 19 Mar 2022 07:19:25 -0400
+
+ ncurses6 (5.9-20131005) unstable; urgency=low
+
+Index: package/debian-mingw64/changelog
+--- ncurses-6.3-20220312+/package/debian-mingw64/changelog 2022-03-12 11:56:09.000000000 +0000
++++ ncurses-6.3-20220319/package/debian-mingw64/changelog 2022-03-19 11:19:25.000000000 +0000
+@@ -1,8 +1,8 @@
+-ncurses6 (6.3+20220312) unstable; urgency=low
++ncurses6 (6.3+20220319) unstable; urgency=low
+
+ * latest weekly patch
+
+- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 12 Mar 2022 06:56:09 -0500
++ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 19 Mar 2022 07:19:25 -0400
+
+ ncurses6 (5.9-20131005) unstable; urgency=low
+
+Index: package/debian/changelog
+--- ncurses-6.3-20220312+/package/debian/changelog 2022-03-12 11:56:09.000000000 +0000
++++ ncurses-6.3-20220319/package/debian/changelog 2022-03-19 11:19:25.000000000 +0000
+@@ -1,8 +1,8 @@
+-ncurses6 (6.3+20220312) unstable; urgency=low
++ncurses6 (6.3+20220319) unstable; urgency=low
+
+ * latest weekly patch
+
+- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 12 Mar 2022 06:56:09 -0500
++ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 19 Mar 2022 07:19:25 -0400
+
+ ncurses6 (5.9-20120608) unstable; urgency=low
+
+Index: package/mingw-ncurses.nsi
+Prereq: 1.510
+--- ncurses-6.3-20220312+/package/mingw-ncurses.nsi 2022-03-12 11:56:09.000000000 +0000
++++ ncurses-6.3-20220319/package/mingw-ncurses.nsi 2022-03-19 11:19:25.000000000 +0000
+@@ -1,4 +1,4 @@
+-; $Id: mingw-ncurses.nsi,v 1.510 2022/03/12 11:56:09 tom Exp $
++; $Id: mingw-ncurses.nsi,v 1.511 2022/03/19 11:19:25 tom Exp $
+
+ ; TODO add examples
+ ; TODO bump ABI to 6
+@@ -10,7 +10,7 @@
+ !define VERSION_MAJOR "6"
+ !define VERSION_MINOR "3"
+ !define VERSION_YYYY "2022"
+-!define VERSION_MMDD "0312"
++!define VERSION_MMDD "0319"
+ !define VERSION_PATCH ${VERSION_YYYY}${VERSION_MMDD}
+
+ !define MY_ABI "5"
+Index: package/mingw-ncurses.spec
+--- ncurses-6.3-20220312+/package/mingw-ncurses.spec 2022-03-12 11:56:09.000000000 +0000
++++ ncurses-6.3-20220319/package/mingw-ncurses.spec 2022-03-19 11:19:25.000000000 +0000
+@@ -3,7 +3,7 @@
+ Summary: shared libraries for terminal handling
+ Name: mingw32-ncurses6
+ Version: 6.3
+-Release: 20220312
++Release: 20220319
+ License: X11
+ Group: Development/Libraries
+ Source: ncurses-%{version}-%{release}.tgz
+Index: package/ncurses.spec
+--- ncurses-6.3-20220312+/package/ncurses.spec 2022-03-12 11:56:09.000000000 +0000
++++ ncurses-6.3-20220319/package/ncurses.spec 2022-03-19 11:19:25.000000000 +0000
+@@ -1,7 +1,7 @@
+ Summary: shared libraries for terminal handling
+ Name: ncurses6
+ Version: 6.3
+-Release: 20220312
++Release: 20220319
+ License: X11
+ Group: Development/Libraries
+ Source: ncurses-%{version}-%{release}.tgz
+Index: package/ncursest.spec
+--- ncurses-6.3-20220312+/package/ncursest.spec 2022-03-12 11:56:09.000000000 +0000
++++ ncurses-6.3-20220319/package/ncursest.spec 2022-03-19 11:19:25.000000000 +0000
+@@ -1,7 +1,7 @@
+ Summary: Curses library with POSIX thread support.
+ Name: ncursest6
+ Version: 6.3
+-Release: 20220312
++Release: 20220319
+ License: X11
+ Group: Development/Libraries
+ Source: ncurses-%{version}-%{release}.tgz
+Index: progs/tic.c
+Prereq: 1.308
+--- ncurses-6.3-20220312+/progs/tic.c 2021-12-12 00:00:33.000000000 +0000
++++ ncurses-6.3-20220319/progs/tic.c 2022-03-19 20:38:50.000000000 +0000
+@@ -49,7 +49,7 @@
+ #include <parametrized.h>
+ #include <transform.h>
+
+-MODULE_ID("$Id: tic.c,v 1.308 2021/12/12 00:00:33 tom Exp $")
++MODULE_ID("$Id: tic.c,v 1.309 2022/03/19 20:38:50 tom Exp $")
+
+ #define STDIN_NAME "<stdin>"
+
+@@ -1741,6 +1741,8 @@
+ } else if (have_XT && screen_base) {
+ _nc_warning("screen's \"screen\" entries should not have XT set");
+ } else if (have_XT) {
++ char *s;
++
+ if (!have_kmouse && is_screen) {
+ if (VALID_STRING(key_mouse)) {
+ _nc_warning("value of kmous inconsistent with screen's usage");
+@@ -1756,7 +1758,9 @@
+ "to have 39/49 parameters", name_39_49);
+ }
+ }
+- if (VALID_STRING(to_status_line))
++ if (VALID_STRING(to_status_line)
++ && (s = strchr(to_status_line, ';')) != NULL
++ && *++s == '\0')
+ _nc_warning("\"tsl\" capability is redundant, given XT");
+ } else {
+ if (have_kmouse